Grid 10 Arrived, now what...General

Last Updated:

  1. Humpty Dumpty

    Humpty Dumpty Member

    My Grid 10 arrived today ( 7 Oct 2011).

    No surprise. As expected, this is an unfinished (software) device with some respectable potential. I have already received a follow-up email from Fusion Garage (FG) about future software updates (Flash Player & others).

    My Grid 10 has relatively few "issues," in terms of bugs, glitches and functionality and I am generally pleased with it, especially in light of scathing reviews at Engadget and the Wall Street Journal.

    I have thrashed this tablet all afternoon and learned a bit about the Grid OS, but have been unable to discover anything that allows me to, "Go to System>About Grid10>System updates." Is this a missing widget "bug," or am I missing something obvious?

  2. helpme2

    helpme2 Member

    I am here hoping somebody reveals some insight into this thing. Received mine Thursday, downloaded the free Kindle bookstore app, paid for a couple of books and now neither the Amazon bookstore or books that I purchased will download. Okay - so I was hoping I could use this as a reader. I really don't want to trash this thing and wait for the Kindle Fire. Otherwise, I like it. What I wanted is a good, easy to use tablet that would let me browse the web, receive and respond to emails, read mags, newspapers and books. So far, I have only managed the email. Also, I have a problem with the display timing out way to fast. I have gone into the settings and tried changing the short shutdown time but my system always defaults to the 15 seconds. That's a problem when you are trying to read something.
  3. Humpty Dumpty

    Humpty Dumpty Member

    I expect that, given enough time, developers and hackers will fill in what the gang at FG are unable to do, unless the Android world just shrugs their collective shoulders and walks away from this platform.

    I don't think that will happen. Grid 10 has a good processor and has considerable potential. Another month and we are likely to see many, if not most, of the bugs resolved, Flash 10.3 and better battery utilization. Eventually someone will create a 40-pin connector to USB cable for less than $30 and an affordable HDMI output cable as well.

    I will start exploring some of the bluetooth capability this week. My Grid 10 GPS couldn't find any satellites this afternoon, though my HTC Hero had no problem locking in eight or nine of them quickly. I will also drop in a 32 GB micro sdhc and see if Grid 10 can format and use this feature as well.

    For an extra $100 you can go for the polish and power of an ASUS Transformer running Honeycomb, with access to the Android Market. Not every Grid 10 buyer will want to hang around and slog through the digital swamp while the kinks are worked out, and you can't blame them.

    I remember all too well trying for more than a year to get my Okidata printer to work with my Osborne portable and Wordstar - never did get it right. Compared to the CP/M and Win95 days, this isn't bad at all...
  4. helpme2

    helpme2 Member

    Back in the day DOS seemed a whole lot easier.
  5. helpme2

    helpme2 Member

    My Grid10 is going to have to work until the perfect Android tablet comes out. I could make a list of what make for the perfect tablet but no body would care.
  6. Humpty Dumpty

    Humpty Dumpty Member

    Really getting to dislike the Grid OS browser a great deal. Installed Opera Mini browser this AM and it seems to be both fast and civilized.

    No, there is no Adobe Flashplayer and Adobe won't let you download anything either.

    Lilliputing's article today summarized the Fusion Garage situation and quoted what FG says about all the software fixes coming in the next "3 or 4 weeks" to make everything right. Why am I not optimistic?

    Was having problems with GPS not finding my location until I installed GPS Status and Toolbox from Amazon. Seems to have enabled the GPS hardware or software - wouldn't be without it and the price is right.

    Bluetooth seems to work, in that the bluetooth device I was using was "paired but not connected," but as is often the case with wireless tech, there are so many variables that it's nearly impossible to determine why the link doesn't work. Much exploring still to do.

    Every day something reminds me that we're in the infancy of Android and the line between phone and tablet applications is really blurred. Try to download a page I visit frequently with my laptop to my tablet, but it's just not having any of that and pushes me to the mobile page every time. Will it take Android 3.2 to get the "I'm not a phone." message out? Probably.

    Another day in the Now What world of Grid OS.
  7. helpme2

    helpme2 Member

    Thanks for the info re Opera mini browser and GPS. I am finding it extremely difficult to use this thing without Adobe Flash. It is available through the Android Market and when I download it, it goes to my Sprint HTC EVO phone. Very frustrating.
  8. helpme2

    helpme2 Member

    I have managed to download Adobe Flash and Opera Mini browser to my SD card, along with other Android apps. Problem - can somebody tell me how to access the contents of my SD card on my Grid10 so that I can attempt to install from the SD? I'm clueless.
  9. helpme2

    helpme2 Member

    My current Grid10 problems with more to follow

    SD card is mounted per the settings menu, it is a good card and works with my PC. The Grid10 camera can’t find the card and will not take a photo because the device won’t recognize that the card is in the camera program. Can’t find card in the device to see what’s on it. I have to move it to my PC. Next I will try reformatting the card with the Grid. Don’t have anything to lose.

    Amazon Store program credits my sale and sends me an email purchase notice but does not complete the downloads. I deleted the Amazon Store program and attempted to download and install again but it will not download.

    Can’t access video programming due to lack of Adobe Flash

    Screen timeout defaults to 15 seconds, actually goes out in about 5 seconds, regardless of how I set it. No time to look up.

    What works? My email and screen resolution.

    I am very disappointed because I wanted this to be a good tablet. The tech specs are good or at least competitive with other tablets. Can’t believe these issues will be corrected with one update.
  10. Humpty Dumpty

    Humpty Dumpty Member

    Sorry to hear about your micro SD problem. You might try borrowing some micro SD cards and swapping them in to see if Grid 10 is just particular about brand. Some tablets/phones are...

    You really need a file manager app to help solve your Amazon Appstore reload problem. I uninstalled the Appstore app and then couldn't re-install either, until I installed a file manager app that will allow you to "side load" apps from the actual .apk files you download and save. I successfully re-installed Amazon Appstore from the .apk.

    I have decided to avoid the Fusion Garage experience and am returning my Grid 10 to FG. Had an issue with the hardware - vibrate came on with a system notification and would not shut off - tried everything short of reset, but it continued until the battery ran out. FG customer support seems to be excellent and FEDEX is picking up the device Monday, 10/17/11. I might have nursed the Grid 10 through a host of hardware/software issues, but just don't have the energy for it these days.

    I expect the Grid 10 community, though small, will be as dedicated to the platform as the JooJoo group is. If you can hang on through the rough spots, it could very well be what you're looking for.
  11. thestimp

    thestimp New Member

    Soon as I figure out how to boot this sucker in devel mode its on, this OS has got to go. It could be a rocking multimedia tablet for traveling and lounging. But the FG OS is just not finished at all.....
  12. thestimp

    thestimp New Member

    Got into the boot menu, going to try and root/flash possibly load honeycomb...give me a while, lots of work to do.
  13. thestimp

    thestimp New Member

    resistance is futile...i need a blasted usb cable to load anything, wont budge from sdcard.... :( nooooooooooooooooooooo
  14. kool kat2

    kool kat2 Well-Known Member

    You guys are scaring me away from this tablet :p
  15. joeblowstein

    joeblowstein New Member

    Woohoo!!! I have been looking put a stock version of Android on this device. The 'Grid' is useless.

    My device came without a root password. I installed a terminal program, fired it up, and type 'su'. BAM - I'm in. Amazing. I also was able to install busybox.

    I am not much of a hacker, but am interested in getting into it with my Grid10. So would love to work with someone on loading honeycomb and eventually ICS.
  16. thestimp

    thestimp New Member

    I'm trying to do the honeycomb thing too, Grid OS needs to be finished before i'll even use the thing. Unfortunately I've lost my charger...:mad: Getting a new one and a usb cable in the coming week. having no buttons it might be hard to load an android OS with out the swype features though...
  17. joeblowstein

    joeblowstein New Member

    Any progress? I haven't been able to touch my Grid10 much because of other priorities. But my kids love playing Angry Birds on it, so at least it's good for something!

    Today I was reading through a Cyanogenmod update on ICS and it sounds promising, with support for Tegra2 in the works: CM9 Progress Update | CyanogenMod

    So what do we need to do to get Grid10 working with CM9 when it is released?
  18. Laciq

    Laciq New Member

    hello, today arrived my new Grid10!
    I have problem with my registration!
    Can I start the machine without Registering?He has a problem with registration because fugion garage set aside a server? Is it possible to bypass it somehow? Can I install another OS? What do I do with it?

    pls mail:
  19. obywan

    obywan New Member

    I reset my grid-10 without being aware that the company had gone away. Now it won't let me past the registration screen. i've punched/held the power button and gotten into the boot menu where it's possible to reset, update, etc... but no information on bypassing registration protocol.

    any idea how to bypass the device registration?


Share This Page