1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

GS2 can't update...Support


  1. jb_1982

    jb_1982 New Member

    Hello,

    This is my 1st post here on this forum. my wife is currently having issues with her GS2. The battery is draining extremely fast, within hours!!!

    I have taken it on myself to sort this problem

    I phoned her phone provider 02, they have suggested she updates her phone to the more recent android version, the phone currently has version 2.3.3 and something about Gingerbread on it!! (As you can tell I have no idea what all this means I use iPhone). However, when I plug the phone into my mac and open Kies it says 'your device does not support upgrading via Kies'. I have restored the phone to its factory settings, as I read that the phone could be 'rooted', and that by restoring the phone would eliminate this. I have tried to figure out exactly what this 'rooted' is (If anyone can tell me what this is, thanks). Anyway, restroing the the factory settings has not solved the issue.

    Any advice would be greatly appreciated.

    Thanks

    Advertisement
    :
  2. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Welcome to the forums! :D

    Rooting would be similar to your iPhone being jail broken. Actually rooting gives you much more freedom than a jail broken iPhone but that nay be the best way for you to think about it.


    I've never owned a Samsung device, so I can't really help you more than that. No worries, someone else will be along shortly
    jb_1982 likes this.
  3. jb_1982

    jb_1982 New Member

    I'll be back in the morning. Hope someone out there can help me. I've tried everything I can think of. Is there a way to download the update to a mac as a file and update manually???
  4. maxmaxter

    maxmaxter Well-Known Member

    Nothing against apple... but did you try to update to ICS using a PC and the newest kies version? I have heard this problem previously... some people are not able to update either. I noticed that you are using v2.3.3 (gingerbread), which was updated over the air (OTA) to 2.3.6 (go to phone settings, then to about phone, then to update. It should update over the air to the latest gingerbread version (2.3.6). Then, after this OTA update, try to connect to kies again and see if it installs.

    In any case, if you decide to root (this solved ALL the problems I ever had with my phone), here's the best rooting link for the i777 (READ EVERYTHING before anything): How to Root ICS on AT&T Galaxy S2 SGH-i777! | Galaxy S2 Root

    The next step is to update your kernel (http://www.linfo.org/kernel.html): [KERNEL] Siyah - JELLYBEAN - ICS [v4.1.4] "One kernel to rule them all!" - xda-developers

    and finally, install a ROM (this is like a "theme" on a jailbroken iPhone), but a ROM has MUCH more (it's like a whole new OS). I'm using CM9 and loving it (CyanogenMod Downloads)

    Good Luck! :)
  5. jb_1982

    jb_1982 New Member

    I had thought about the PC v Mac problem, I don't own a PC but I will try to see if I can update it on my Fathers PC! Hopefully this may work. Thanks
Loading...

Share This Page