GS2 WiFi Internect ConnectionSupport

Last Updated:

  1. Process

    Process Member


    The shared is the problem with my new galaxy S2.

    I can not connect to internet while its connected to WiFi with full bars signal. Its time to time but unfortunately often!. the message of " the webpage can not be shown" is appearded after each unsuccessfull trial.

    I made a test by putting my gs2 beside one galaxy plus while sitting near by router. the other phone were connecting to any website quickly while mine was turning around to give me the painfull message.

    Any one have encountered this prob so far or any idea how to reolve?


  2. Hawker

    Hawker Well-Known Member

    In your network settings, does it say that you are connected to the router, or does it say disconnected or obtaining ip address.

    If it says its connected then try dropping down the notification bar at the top, turn wifi off, wait for 5 seconds then turn it back on again.
  3. Process

    Process Member

    Its in the "Connected" status while I trying to brows the web. its connecting time to time but often it can not. I wonder what it could be related to as all the softwares are in original Samsung sonfiguration an I didnt change anything, even still I didnt insert the Simcard in.
  4. Hawker

    Hawker Well-Known Member

    What version firmware, modem, and kernel are you on? (menu>settings>about phone)

    build number=firmware
  5. Process

    Process Member

    Some details of the phone :
    Model No: GT-I9100
    Android Ver. : 2.3.3
    Baseband Ver. : I9100DXKF1
    kernel Ver. :, root@DELL106 #2
  6. Hawker

    Hawker Well-Known Member

    Thats quite an old version of the firmware, and I seem to remember reading a few threads on here a while back regarding wifi issues on older firmwares.

    Apart from downloading newer firmware, all I can suggest is for you to check your authentication type/security mode in your router. If its WPA2 then try WEP and see what happens.

    You will have to forget your connection then reconnect of course.
  7. Process

    Process Member

    Dear Hawker,

    The router authentication is WPA2-PSK. But I could find how to change it to WEP.

    By the way once the mobile couldnt connect, this error is popping up :
    "Data connectivity problem
    The server failed to communicate.
    Try again later"
  8. Hawker

    Hawker Well-Known Member

    To change the router you need to open internet explorer and enter its ip address in the address bad (usually and then log in (usually admin) then go to the wireless security setup
    Process likes this.
  9. Process

    Process Member

    I try to attach a screen shot of the router setup page. may be its indicative for you
    But I'm not able to to do that in this page. If you provide your email I send it via email.
    I couldnt find how to change it actually.

Share This Page