1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

GS3 wont turn on or chargeSupport


  1. kLN93

    kLN93 Active Member

    Last night before I went to sleep my phone battery died, woke up and now it wont turn on at all and it doesn't charge. I tried different chargers but that didn't help, i just tried it in my computer, it's on the charging screen right now, there's a battery icon with a yellow triangle next to it. When the screen goes off, there is no red LED light to show it's charging, any help please?

    Edit: the led light is flashing red now.

    Advertisement
  2. Rukbat

    Rukbat Well-Known Member

    Sounds like a bad battery. Allowing the battery to go down to 0 charge isn't a good idea. These are lithium ion batteries, not nickel cadmium batteries. Eventually, bring the battery down to 0 charge kills it. (40% to 60% charge is the ideal recharge point for maximum life. If you need longet times between charges than that, carry a spare battery. They're small.)
  3. mydian

    mydian Well-Known Member

    Try a different battery or an external charger. There is a thread somewhere in this forum where people with a similar problem had to bring up the battery's charge a little with an external charger first, then it worked fine in the phone again. For some reason this phone has a problem if the battery was ran down too low.

    Although I have done this a few times myself with no problems so far, as Rukbat says it's very bad for lithium ion batteries to be ran all the way dead. Recharging from above above 40% is ideal for maximum battery life expectancy.
  4. kLN93

    kLN93 Active Member

    The battery is fine, I charged the battery by putting it in my cousins s3 and let it charge fully. I had a look at the charging port and that was very dusty in there, I managed to get most of the dust out but that didn't fix the problem. I think the charging port is damaged to be honest, i've tried different chargers and on all of them, I had to wiggle the lead around to get it to charge. BTW, I have a new battery now

Share This Page