1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

GS4 SD card damgedSupport


Last Updated:

  1. JDMRavi

    JDMRavi New Member This Topic's Starter

    Joined:
    May 11, 2013
    Messages:
    1
    Likes Received:
    0
    Hello, so last night I had and update for what I believe to be an andriod update and after my GS4 rebooted it was saying that it couldn't read the SD card and it was damaged and to try and reformat it. Its the standard samsung 8gb SD card. Can you guys help me on this problem? I'm on sprint if that helps.

    Thanks,
    Ravi
     

    Advertisement
  2. jaydo

    jaydo New Member

    Joined:
    May 14, 2013
    Messages:
    1
    Likes Received:
    0
    I have a similar problem on my GS4. The phone saying my memory card is under write protection but when i try to reformat the card it is not write protected.

    Someone please help
     
  3. abevuk

    abevuk Active Member

    Joined:
    Jul 16, 2012
    Messages:
    39
    Likes Received:
    2
    Not much help I'm sure but I've had S3, note 2 and now the S4. My 64gb card has corrupted in every device....getting a tad expensive now!
     
  4. Tware

    Tware Well-Known Member

    Joined:
    Mar 3, 2011
    Messages:
    131
    Likes Received:
    14
    the Sandisk Class 10 32 gig (legit local retail purchase) that worked well in my GS3 immediately started corrupting pics taken with the GS4. :( Also, several games that write huge files/resources to the SD when first run failed repeatedly. I took the card out and cleaned the contacts with a cloth and reseated it several times. And the games installed/ran.. but I haven't been brave enough to send pics to SD again
     
  5. ScandaLeX

    ScandaLeX Wasn't Me

    Joined:
    May 4, 2010
    Messages:
    3,828
    Likes Received:
    932
    I was getting the same messages as the OP. I have the Note 2 and so far 2 system updates have killed 2 32GB Class 10 SanDisks cards. It's kind of hard for me to not think the updates had anything to do with it since both cards worked flawlessly before.

    I don't know what cards I'll buy next but I know it's not SanDisk.
     

Share This Page

Loading...