[GSM] Just rooted evo 3d (rogers) wont stop looping

Last Updated:

  1. EmeraldNova

    EmeraldNova Member

    Hey guys,

    Im new to the forum, and you could say I am a noob as i still dont know what all this rooting or unlocking bootloader does! lol

    Anyways, I used this amazing guide (http://androidforums.com/3892643-post2.html) by jerofld to root the phone I have, however, the issue now is that despite following all the steps exactly (except that I installed the latest cyagenmod rom for evo 3d gsm instead of the superuser stock rom) the phone is stuck in a boot loop.

    When i bootload it to the computer while connected, this phone does not give the "fastboot usb" thing

    Also I made sure to clear the two caches that were suggested and wiped the data.

    Does anyone have any suggestions to help me install the cm rom on this phone, and get back to normal? :)

    Thanks a ton,

  2. Brian706

    Brian706 Moderator Moderator

    Usually you need a downgraded hboot to flash the aosp roms. This basically means your current hboot version isn't compatible with the rom you flashed. It can't boot the rom. You can't downgrade unless you are s-off. Try flashing the suggested rom from the guide and see if your phone boots up. Also, if you followed all the steps in the guide, then you should have made a nandroid backup before flashing a rom. If that's true, then you could restore your backup to get booted back up and then go from there.

    To restore your backup, do a battery pull and then hold volume down+power to get into your bootloader. From there select recovery. Once in recovery go to backup/restore and restore the backup you made.

    It's always a good idea to make a backup before flashing anything, for this exact reason. If something goes wrong, you can just restore your backup.
    EmeraldNova and scotty85 like this.
  3. EmeraldNova

    EmeraldNova Member

    Hey thanks for the suggestion, and i restored the backup like suggested, and did the rest, but even this SuperUser rom patch does not work. The phone is still in a loop cycle. :S
    scotty85 likes this.
  4. Brian706

    Brian706 Moderator Moderator

    So you successfully restored your backup and your pone booted up? Then flashing the stock rom caused a bootloop again?!

    To at least get root on your phone try this:
    -Restore backup again so you can have a working stock rom.
    -Go to this post: http://forum.xda-developers.com/showthread.php?t=1538053 and download the file called UPDATE-SuperSU-v1.02.zip
    - Put that file on your sd card and boot into your recovery again and choose install zip from sd card. Then select that file. Let it flash and you should be rooted.

    To check, download root checker from the play store and make sure.

    Flashing this super user patch on your stock rom is really the same thing as flashing a stock rom with super user. This way you are just rooting your stock rom. The other way you are flashing the rooted stock rom.

    This should at least have you rooted on the stock rom, then after you have root we can figure out how to flash some other roms if you want to.
    EmeraldNova and scotty85 like this.
  5. EmeraldNova

    EmeraldNova Member

    The only backup i have made is from Step 6:

    "Now that we have CWM installed, we should make a back up. This is done by using the volume keys and pushing power as enter. If I remember how CWM makes backups correctly, it backs up everything."

    I did that but now when I restore that and I turn on the phone it starts looping again.. I dont know if it is supposed to do that.
    scotty85 likes this.
  6. Brian706

    Brian706 Moderator Moderator

    Hmm... It sounds like possibly you may need to flash a boot.img or something. I am not as familiar with the GSM version so I don't feel comfortable telling you specific files to flash because I would hate to brick your phone.

    I am going to PM Scotty as he is very familiar with GSM and also everything HTC related. He is the man! I will ask him to come look at your thread as soon as he can. :eek:

    As a last resort, we could run the RUU for your phone and get it back to stock so you could at least boot up until you are ready to try rooting it again. But this might be unnecessary as Scotty may have a simpler solution!
    scotty85 and EmeraldNova like this.
  7. EmeraldNova

    EmeraldNova Member

    Hey man, thanks for all the help. Looking forward to Scotty helping me further!
    scotty85 and Brian706 like this.
  8. scotty85

    scotty85 Guides Guide

    a link to the specific rom you used may be helpful. as brian mentioned,many AOSP roms require the gingerbread hboot. due to the different mount points on ICS /JB and GB,the hboots are not compatible without modifications to the rom.

    if you had successfully flashed the boot image and a cm 9 or 10 rom that required the older hboot,then that is a problem.

    if you flashed an AOSP rom designed to work with 1.53 hboot,but did not successfully flash an AOSP boot image,then that is also a prollem :eek:

    if you have an AOSP kernel on you your phone from the initial rom flash,then tried to restore a backup or flash a new (stock)rom without also flashing the boot image,then again,that is a prollem.

    in a nutshell:
    -rom and boot image need to be compatible
    -rom and firmware(hboot) need to be compatible

    this is why htcdev sucks for rom flashing. recovery CANNOT write to the boot image,it must be installed manually. in theory,all we need to do id install a rom that matches the kernel on the phone,or install a kernel that matches the rom.

    im a little confused about how/if you flashed the kernel,and also it may be a prollem that you do not have fastboot usb displayed onthe fastboot screen. this suggests that:
    -the phone is in hboot,not fastboot
    -you may have a bad cable
    -you may need to switch ports,or reboot the pc
    -you may have htc sync,pdanet,or some other program running that is interfering with phone comunication.

    at this point,i think we need to pick a stable rom/boot image and start over to get back to a working device. you can either:
    1)flash the rom in recovery,and manually flash the boot image in fastboot


    2)launch your recovery into phone memory so that it is able to write the boot image like any other s-off device. more info on that here: http://androidforums.com/gsm-evo-3d...install-recovery-root-htcdev.html#post5139976

    i would highly suggest #2. this is what i did when i was cursed with s-on devices. while its an inconvenience to hook to the PC and boot recovery,the process is overall easier than manually extracting the boot image and flashing it seperately.

    just holler if you have questions :)
    EmeraldNova and Brian706 like this.
  9. Brian706

    Brian706 Moderator Moderator

    Thanks so much scotty! You are so good at explaining things on a level that I can't! I didn't have to deal with s-on too much because I decided to get s-off pretty quickly after rooting. But the advice scotty gave is great! I knew we needed to flash a compatible rom, which you tried but it makes sense now why you were still in a bootloop.
    EmeraldNova and scotty85 like this.
  10. scotty85

    scotty85 Guides Guide

    ive had more s on experience than id like to admit to,lol.. my rezound was s on for a long time before jpbear. an unfortunatel repair experience with htc has left my un-s off-able one x back on s on :mad: and i just picked up a one s(also s offable)

    fastboot booting the recovery into phone memory really does work,and makes dealing with s on alot easier. the biggest disadvantge being having to plug in to launch recovery,followed by a close second of being stuck on one firmware ;)

    hopefully launching recovery into memory and either restoring the backup,or flashing a stock rom will get everything sorted :smokingsomb:
    EmeraldNova and Brian706 like this.
  11. EmeraldNova

    EmeraldNova Member

  12. EmeraldNova

    EmeraldNova Member

    Woah man Scotty, all that stuff sounds tight.. Its very difficult for me to understand the terms though ( as you know I am newbie lol)

    I downloaded the latest cyanogen rom in this downloads section here (CyanogenMod Downloads)

    I think its called cyanogenmod rom for shooteru

    I had to take the usb cable out as the phone was bootlooping.. (to take out the battery, the build is such that you have to take out the cover first) But the phone was fastboot before it started looping

    And now I am in Fastboot USB thanks for the tip.. I was not in Fastboot usb after i tried reflashing with the superuser patch rom, i dunno if that makes a difference..

    So would you suggest that I do the temporary or permanent recovery if I want to get s-off and install cyanogenmod?

    Thanks guys
  13. scotty85

    scotty85 Guides Guide

    if you want to get s off,the unlimited teaM is very specific that you must be on a stock,rooted rom. what we should do if you want to become s-off:
    1)relock bootloader
    2)run the ruu for your current build
    3)re-unlock the bootloader
    4)install or launch recovery(doesnt really matter wich to flash superuser)
    5)flash superuser
    6)run jpbear tool

    more info and links here: http://androidforums.com/gsm-evo-3d...nfo-faq-root-s-off-gsm-evo-3d-all-hboots.html

    we will need to figure out what your previous build number/cid is. we can find this by doing the following:
    since you allready have the sdk set up from rooting,you may not need all those directions. the important steps for you are:
    -open cmd window
    -chagne to fastboot directory(like when you got the id token)
    -place phone in fastboot and plug in
    fastboot getvar all

    paste the resulting output here :)

    in the mean time,you can get back to a working phone by following the directions to boot recovery,then restore your backup. ext 4 will restore a cw backup.

    the link above should have taken you to the second post. you wont need the first post directions since youre allready rooted. the directions you need to follow specifically are these:
    once youve got 4ext running from those directions,restore your stock backup,and we should be back to a working phone :)

    *note that the directions assume a working phone. since yours wont boot,simply ignore the adb devices and adb reboot bootloader commands. just start with your phone in fastboot and plugged in.

    to answer your other question,the superuser files wont cause your phone to bootloop,and they wont fix it either. your phone is not booting becasue your rom and kernel dont match,or your rom and hboot dont match. or all 3 :p

    restoring your backup with a booted recovery is your best bet to get back to a functional device at this point :)
    EmeraldNova and Brian706 like this.
  14. EmeraldNova

    EmeraldNova Member

    Hey Scotty,

    So this is what I got:

    C:\sdk-tools>fastboot getvar all
    INFOversion: 0.5
    INFOversion-bootloader: 1.53.0007
    INFOversion-baseband: N/A
    INFOversion-cpld: None
    INFOversion-microp: None
    INFOversion-main: 3.28.631.1
    INFOserialno: HT17WV306965
    INFOimei: 357197040116975
    INFOproduct: shooter_u
    INFOplatform: HBOOT-8260
    INFOmodelid: PG8631000
    INFOcidnum: ROGER001
    INFObattery-status: good
    INFObattery-voltage: 5714mV
    INFOpartition-layout: Generic
    INFOsecurity: on
    INFObuild-mode: SHIP
    INFOboot-mode: FASTBOOT
    INFOcommitno-bootloader: 10e127f0
    INFOhbootpreupdate: 11
    INFOgencheckpt: 0
    all: Done!
    finished. total time: 0.498s

    And woohoo, its alive!
  15. scotty85

    scotty85 Guides Guide

    awsome! glad you are sorted :smokingsomb: did you restore the backup to get it working?

    the other good news is that your build numper(i.e. your main version above) is available on Shipped ROMs

    there are .exe and .zip files that we can run if you decide to try and do s off. in the mean time,you might just enjoy a working phone for a couple days,and if you want to try and flash other roms,just launch recovery and flash them. just make sure to read the OP thuroughly and confirm they are compatible with your new hboot.

    just holler if you have more questions! :)
    EmeraldNova likes this.
  16. EmeraldNova

    EmeraldNova Member

    Hey Scotty,

    Ya, i restored the backup to get it working :)

    If i already have the version that you just helped me install, would i need to install this main version?

    The main reason I actually rooted the phone was to get CyanogenMod :( and it is not in the shipped rom link you showed above :(

    http://forum.xda-developers.com/showthread.php?t=2108195 this forum has cyanogen mod and it says:

    md5sum: 49c62df894df91542fb1d3eaa90561b6

    Do not use superwipes
    Must not be on ICS HBOOT
    4ext recovery
    Wipe data, cache, and system (wipe all partitions except sdcard if on 4ext recovery) if coming from any ROM except CM10
    Wipe cache and dalvik-cache, flash new 4.2.1 GAPPS and after boot wipe data on clock if flashing new version from previous installation of CM10
    Wipe cache and dalvik-cache if flashing new version from previous installation of CM10.1
    Flash ROM
    Flash GAPPS

    so I would have to have s-off like you said, but I can only find broken links for methods that would require me to downgrade my hboot first.. Also I dont know If i have ICS hboot.. basically dont understand anything at all :S lol

    If you could just help me in my journey to get CyanogenMod, that would be AWESOME!

    Thanks so much for bringing the phone back from the dead man, you are awesome.

  17. scotty85

    scotty85 Guides Guide

    unfortunately,you do have the ics hboot,and there is no way to downgrade it without being s off. none that i would recomend for just anyone,anyway.

    your best bet is to become s off. info here:
    look at the "1.53.0007" method

    youve allready htcdev unlocked,so you just need to be on a 100% stock rooted rom,and run the jpbear tool. the unlimited team is very forceful about folks writing NOT guides and using their tools in other tools,as these may not get updated as they update their tools,so unfortunately it would be against their wishes to offer a detailed step by step guide. i can only give some basic advice,and try and answer any concerns you may have before hand.

    if your backup was of 100% stock,all bloatware intact and no files deleted or modified,then you can prolly just use that without having to run the RUU.

    i am going to go ahead and unlock the other thread,in case you have questions pertaining to s off,etc. and want to address them there. :)
    Brian706 and EmeraldNova like this.
  18. EmeraldNova

    EmeraldNova Member

    Hey Scotty and Brian,

    Thanks so much for the help! I will try to get s-off and like you said above, and install CM on the HTC.

    Aren't I already a 100% on a stock rooted rom? So I can just run the jpbear tool to s-off?

    Thanks bros
  19. Brian706

    Brian706 Moderator Moderator

    Assuming that you hadn't deleted any bloatware or modify anything after you rooted. The problem is, is that unlimited.io won't offer support if you didn't follow the directions exactly. But most likely you will be fine with what you have!

    Also, watch this video about the wire trick so you can see the timing and stuff:
    EmeraldNova likes this.
  20. EmeraldNova

    EmeraldNova Member

    That's awesome buddy!

    scotty85 likes this.
  21. EmeraldNova

    EmeraldNova Member

    Hello guys,

    I was just wondering would I change the hboot from ICS to a different one when i accept the new hboot that the jpbear s-off method offers? Would that mean I can flash the Cyanogenmod successfully? (satisfying all the conditions that they require) ?

    Thanks again!
  22. Brian706

    Brian706 Moderator Moderator

    I believe the juopunutbear hboot is a patched gingerbread hboot and will work with CM. In fact it's supposed to work with every rom except stock ics roms :)
    EmeraldNova and scotty85 like this.
  23. scotty85

    scotty85 Guides Guide

    it depends on what you were on when you ran jp bear.

    if you were on GB,jpbear installed 1.49.9999,wich is patched GB

    if you were on ICS,then jpbear installed 1.53.5353,wich is patched ICS.

    so youre still in the same boat- youll need to double check the roms OP for hboot recomendations :)
    EmeraldNova and Brian706 like this.

Share This Page