GTalk Signs out when screen shuts off/stand by


Last Updated:

  1. N2o

    N2o Active Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    42
    Likes Received:
    0
    Please tell me there is a way to prevent my Gtalk account from singing off every time I lock my phone?

    It seems every time my screen goes dark, or in "standby mode" Google Talk disconnects. I've been told my name comes online and offline all the time by others. I can't for the life of me figure this out. When I sign back in, I get bombarded with messages all at once.

    Anyone have a similar issue? And apparently my phone has been in standby mode 62% of its life according to stats. Standby vs screen off. Whats the diff?
     

    Advertisement
  2. Shiggs

    Shiggs Active Member

    Joined:
    Nov 9, 2009
    Messages:
    26
    Likes Received:
    0
    Menu > Settings > More

    Uncheck Automatic away-status

    I also have Automatically sign in checked.
     
  3. N2o

    N2o Active Member This Topic's Starter

    Joined:
    Nov 11, 2009
    Messages:
    42
    Likes Received:
    0
    I have the same settings. If I unlock fast enough and hit the talk button on the main screen, I can see a "Lost connection to server" message disappear really fast and my list refresh.

    I also tried using WiFi thinking maybe it was a 3g thing, but the same results happen. My WiFi shuts off when my phone goes into standby as well.
     
  4. breakerfall

    breakerfall Member

    Joined:
    Nov 3, 2009
    Messages:
    20
    Likes Received:
    1
    I'm sitting at my desk right now in front of my computer, signed into gmail, with my Droid next to me (also signed in) and the screen is off.

    my auto-away status is off.

    I can confirm that, if someone IMs me fresh (or after a few minutes of inactivity in gmail), the notification hits my desktop browser and my phone at the same time.
     
  5. CRPercodani

    CRPercodani OFWGKTA VIP Member

    Joined:
    Oct 24, 2009
    Messages:
    2,940
    Likes Received:
    564
    Mine never signs out when the screen is off.
     
  6. armandov99

    armandov99 Well-Known Member

    Joined:
    Dec 17, 2009
    Messages:
    77
    Likes Received:
    4
    Having this same issue but mine is a Sprint Hero. I get no GTalk notifications, no GMail notifications, until I wake the phone up and try to send a message. Then GTalk will say "Lost connection to server. Messages will send when online" or something to that effect. Then I'll get ALL the incoming messages from however long ago it had been since I put it to sleep.

    This wasn't happening to me for the first 5 days I had the phone, until I ported my number in from my old carrier, then I started having this issue. Tried EVERYTHING including a hard reset, it still happens. I changed the number and MSID for the phone to zeroes and back to re-do the provisioning, it helped but the next day this problem was back after I turned the phone off overnight.

    I'm going to call Sprint and see what's up. Maybe something went wrong when porting. IF not I'll have it exchanged, it's unusable when you get no notifications if it's sleeping.
     
  7. rhamm621

    rhamm621 Active Member

    Joined:
    Jun 17, 2010
    Messages:
    41
    Likes Received:
    4
    I am having this same issue. Was wondering if any of you found a solution, since no one followed up with replies.
     
  8. Clementine_3

    Clementine_3 Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    4,214
    Likes Received:
    3,481
    Are you just having a problem today or is it ongoing? GTalk was up and down all day today...
     
  9. rhamm621

    rhamm621 Active Member

    Joined:
    Jun 17, 2010
    Messages:
    41
    Likes Received:
    4
    It was most noticable Tuesday, but I also noticed it happening on Monday as well. From the exensive searching I have done on this issue, it seems to be an account issue and not a phone issue.
     
  10. Alain024

    Alain024 Member

    Joined:
    Aug 30, 2010
    Messages:
    7
    Likes Received:
    0
    Same issue here... Please help us D:
     
  11. mas90guru

    mas90guru Well-Known Member

    Joined:
    May 2, 2010
    Messages:
    79
    Likes Received:
    6
    Having the same issue here - only common thing that I can point to is I didn't notice the problem on my HTC EVO 4G prior to porting in my phone number.

    Then overnight something seemed to go south. I would get a hung marketplace download (downloading) followed by an inability to connect to Gtalk.
     
  12. umshamrock

    umshamrock Well-Known Member

    Joined:
    Sep 28, 2009
    Messages:
    87
    Likes Received:
    1
    my gtalk had been working fine for over a year and now it won't stay signed in - it's the same thing you guys are having, where gtalk loses connection to the server if the phone goes to sleep. i can't figure out what is going on since it worked great for so long... did anyone solve this?
     
  13. flint1

    flint1 New Member

    Joined:
    Jan 13, 2011
    Messages:
    1
    Likes Received:
    0
    Same problem here. Any updates?
     
  14. reddv1

    reddv1 New Member

    Joined:
    Dec 8, 2008
    Messages:
    3
    Likes Received:
    0
    Same problem here, Google Talk signs out a few minutes after i turn off my screen. This never happened before until April 15 it started all of a sudden. I've tried everything, flashing back to stock, changing roms but the problem persists in every rom. This is definitely a problem on Google's side!
     
  15. umshamrock

    umshamrock Well-Known Member

    Joined:
    Sep 28, 2009
    Messages:
    87
    Likes Received:
    1
    actually in my case my carrier had changed a setting or something...so my phone was using WAP instead of Mobile date. i figure it out two ways: 1) i set the wifi to remain on and never turn off and it stayed signed in (i tested by signing into laptop with 2nd gtalk account and waiting for gtalk on phone to idle) and 2) i put a diff sim from another carrier in my mob and it was fine.

    so make sure your carrier settings are right, and that it is using mobile data instead of WAP!
     
  16. lcompare

    lcompare New Member

    Joined:
    Sep 17, 2011
    Messages:
    1
    Likes Received:
    0
    same thing happens to me.
    I live in uruguay, my data settings are ok, I used to have the same settings on my old phone and it was working fine.

    do you have any update?
     
  17. brunobrunic

    brunobrunic New Member

    Joined:
    Nov 10, 2011
    Messages:
    1
    Likes Received:
    0
    Did you try with this:

    Settings > Wireless & Networks > Mobile Networks > Enable always-on mobile data ON :eek:
     

Share This Page

Loading...