Root [GUIDE] CDMA Workshop and Manual PRL Updates

Discussion in 'Android Devices' started by imfm, Mar 10, 2012.

  1. imfm

    imfm Well-Known Member
    53

    Sep 29, 2011
    154
    84
    53
    Social Scientist
    Texas
    I can verify that after some trial and error I finally was able to manually push a PRL to the Marquee using this method.

    Steps:

    1) Get your MSL. As far as I know, the only way to get your MSL with the Marquee is to call boost. You should be able to get it easily by telling them you want to do a factory reset.

    2) Install all three LG driver packages. Go here:
    LG LGLS855 Support: Find Manuals & Warranty Info | LG USA
    Download the LG Mobile support tool found in the middle of the page.

    3) Install the software, tell it you want to download drivers for the LS 855. It goes through an awkward install process that should download 3 driver packages.

    4) After the drivers are installed, put your phone into DM by dialing Dial ##7678#, entering your MSL, and checking the box that says DM mode. DO NOT REBOOT.

    5) Now when you plug your phone into your PC, it should install a bunch of drivers including one for a virtual COM port.

    6) Put your phone in USB Debug Mode: Settings -> Applications -> development -> USB Debugging

    7) Find a PRL file you want to use. You can find a bunch of them here:
    http://androidforums.com/attachment...dtest-net-results-after-couple-tweaks-prl.zip

    8) Now you are ready to use CMDA Workshop. Follow the instructions here starting at "1. Open CDMA-Workshop:":
    http://androidforums.com/samsung-galaxy-precedent/441045-idiots-guide-flashing-prls-precedent.html
    Substitute LG xxx whatever for Samsung xxx whatever in the steps, and skip step "2. goto your Phones DialPad and dial ##8778# -> enter your MSL -> Select USB:"

    Notes:
    If you are using MarkyBeats, you should be able to flash PRL without switching to DM.

    Also, you might want to try DFS instead of CDMA workshop. My trial ran out and I couldn't find a workaround, but I was able to flash a new PRL using this guide:
    [Guide]How to change your MSL and PRL (Not CDMA Workshop)
    Using DFS, connect to modem first, then serial port, then proceed as instructed.

    THANKS, DONATIONS, AND HUGS APPRECIATED (BUT ESPECIALLY DONATIONS)
    Donate Link:
    https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=X356LXTFRD9GE
     

    Advertisement
    jaymzway and tombob like this.
  2. TryingToRoot

    TryingToRoot Well-Known Member
    68

    Sep 11, 2011
    296
    115
    68
    Helicopter Flight Engineer
    Savannah, Ga
    To get your msl open terminal and type "getprop ril.msl" then hit enter
     
  3. imfm

    imfm Well-Known Member
    53

    Sep 29, 2011
    154
    84
    53
    Social Scientist
    Texas
    On the Marquee this didn't work for me.
     
  4. TryingToRoot

    TryingToRoot Well-Known Member
    68

    Sep 11, 2011
    296
    115
    68
    Helicopter Flight Engineer
    Savannah, Ga
    I think you are right. I originally called and got mine from boost but remembered that step from the prevail, I should have tried it first.thank you for the correction
     
  5. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    ive tried every trick to get msl on the marquee. even 2 i was able to come up with were both wrong. its a pain in the a##
     
  6. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    This strategy WORKS to get MSL:


    download aLogcat (free) from market. Open it and start the log. Hit the "home" button on the phone and go to dialer and enter ##3282# then hit "advanced" hit "view". Then hit the back button on your phone and go to "data profile" hit "edit" and enter 000000. It will say it is wrong, hold the home button and switch back to aLogcat and pause it. Hit "filter" and type msl


    should be good from there on with cdma workshop
     
  7. wartorn

    wartorn Active Member
    16

    Feb 3, 2012
    27
    3
    16
    i couldnt get my fone into DM using this code. is there some other code i could use? i am using the Undeniable ROM.
     
  8. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    just do it with your phone off, or in recovery
     
    wartorn likes this.
  9. munguse

    munguse Well-Known Member
    43

    Nov 26, 2011
    184
    35
    43
    Male
    NorCal
    There is no option to go into DM Mode with the ##7678# code, just Development Mode. Or are they the same :thinking:
    [​IMG]

    Tried that but all that shows up in cdma workshop are these 2 ports and
    can't connect to either because they need the registered version. Anyone with ideas?
    [​IMG]


    These are the drivers that are installed.
    [​IMG]
     
  10. imfm

    imfm Well-Known Member
    53

    Sep 29, 2011
    154
    84
    53
    Social Scientist
    Texas
    If you are using MarkyBeats, you should be able to flash PRL without switching to DM. Also, you might want to try DFS instead of CDMA workshop. I was able to flash a new PRL using this guide:
    http://androidforums.com/warp-all-t...ow-change-your-msl-prl-not-cdma-workshop.html

    P.S. Using DFS, connect to modem first, then serial port, then proceed as instructed.
     
  11. munguse

    munguse Well-Known Member
    43

    Nov 26, 2011
    184
    35
    43
    Male
    NorCal
    tombob and phreak311 like this.
  12. phreak311

    phreak311 Well-Known Member
    36

    Mar 24, 2012
    102
    8
    36
    Male
    West Virginia
    I couldn't get CDMA workshop to work for pushing a new PRL. I'm going to try this. Thank you!
     
  13. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    tombob likes this.
  14. tombob

    tombob Well-Known Member
    53

    Feb 10, 2012
    154
    40
    53
    Thanks guys, I was able to successfully flash this prl using DFS. Unfortunately it did squat for my sorry-ass download speeds :mad:
     
  15. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    Sprint Corporate 12121
     

    Attached Files:

    tombob likes this.
  16. Phrant1c

    Phrant1c Well-Known Member
    53

    May 9, 2012
    283
    76
    53
    Chicago
    this worked very easily to get the MSL. Took all of maybe 30 seconds.
     
  17. tombob

    tombob Well-Known Member
    53

    Feb 10, 2012
    154
    40
    53
    So a month ago this method worked great for me to push a prl, but now I can't seem to get it to work. After starting DFS I can get the modem to open, but the serial port doesn't ever seem to open. Any suggestions of what I may be doing wrong? Thanks.
     
  18. wetbiker7

    wetbiker7 Well-Known Member
    Contributor
    5,323

    Jun 27, 2011
    7,475
    3,426
    5,323
    Male
    USN Vet. / Certified Drug and Alcohol Abuse Counse
    So-Cal

    Have you changed ROMs? This requires a stock based ROM to work.


    Try flashing the Half Ass ROM or CTMod 2.5. Then see what you get.
     
    tombob likes this.
  19. tombob

    tombob Well-Known Member
    53

    Feb 10, 2012
    154
    40
    53
    That may be it, running CTMod 3.6.5. Thanks.

    edit: That was it, thanks. I flashed Blood's ZVC stock rooted and DFS connected first try. Pushed the prl no problem, rebooted and confirmed voice and data, then restored my backup. Back to where I was but with 12121 prl. Everything is right with the world.
     
  20. wetbiker7

    wetbiker7 Well-Known Member
    Contributor
    5,323

    Jun 27, 2011
    7,475
    3,426
    5,323
    Male
    USN Vet. / Certified Drug and Alcohol Abuse Counse
    So-Cal

    Right on man. Glad it worked for ya. :D
     
  21. wachoface

    wachoface Member
    16

    Jun 11, 2012
    19
    1
    16
    I was messing around in the LG Hidden Folder, just under the NAI settings is the PPP settings. I switched the PPP Carrier from Sprint to HTK_Sprint. The phone immediately rebooted and I then had no data service. I switched it back and still, no data. I could call and text until I tried to fix it. I tried the ##72786# -> MSL -> yes trick and that took all calling and texting capabilities away. So now I have a wifi only Marquee. I am running ctmod 6.5 with the unleashed kernel also with the HC theme. I changed back to stock and tried again, still no change. It tries the hands free activation but can't contact the network. What do I do?
     
  22. Capn069

    Capn069 Well-Known Member
    Contributor
    53

    Aug 6, 2011
    238
    78
    53
    Male
    Georgia
    I have a question for the developers. Does anyone know if it is possible to create a script such as the DM-CM7 ran in Script Manager for the Prevail to put the phone into DM without having to swap roms? This would make for an easy way to change PRL's with DFS or CDMA. I don't know if anyone was working on one or not.
     
  23. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    its a different file path. the stock needs no script at all, dont even have to change any hidden menu settings.

    Im not sure if ctmod just doesnt have it, or if its in a different spot
     
  24. Capn069

    Capn069 Well-Known Member
    Contributor
    53

    Aug 6, 2011
    238
    78
    53
    Male
    Georgia
    I was just wondering because I can swap the PRL on my Prevail in like 30 seconds with the script and dfs. Is there a way to get the Marquee into Dm without swapping roms? I run CTMod 3.6.5 with hyperkernel 1.5.
     
  25. lMonsterl

    lMonsterl Well-Known Member
    213

    Jul 18, 2011
    1,313
    602
    213
    Self-Employed
    U.S.
    Not that I've found yet. I just restore a backup then revert back after
     
Tags:

Share This Page

Loading...