[Guide] Downgrade from 2.37 to 1.32.405.6 - 100% CONFIRMED

Last Updated:

  1. CuBz

    CuBz Well-Known Member

  2. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Updated the root sticky and added a link to this thread :).

    You got a copy of the convo or a link to an XDA thread? I'd like to link that too.
  3. CuBz

    CuBz Well-Known Member

    I realised this morning that I had forgot to add the ADB steps to the guide lol, I have updated it now, sorry about that, had a f***ed up head yesterday after trying many different methods to downgrade, when I finally did it and posted the guide, I missed some steps haha
    El Presidente and CdTDroiD like this.
  4. CuBz

    CuBz Well-Known Member

    Please could anyone with any firmware above 2.37 please PM me for testing
    El Presidente likes this.
  5. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

  6. CuBz

    CuBz Well-Known Member

    My guide made it to the XDA home page :)
  7. Seventeen

    Seventeen Member

    Hi; believe it or not, I'm such an idiot that I registered to ask/confirm a few silly things:

    In step 5, does "download stock 1.32 PD98IMG.zip ROM" mean 'download another PD98IMG.zip file that isn't the one acquired in step 2' ?

    And if so, does that also mean 'after booting the phone into Bootloader with PD98IMG.zip (acquired in step 2), turn off the phone and remove the SD card' ?

    And then, do step 5 and 6 mean 'download the second PD98IMG.zip on your computer from the internet, then stick it on the card, then proceed with the adb work' ?

    Might I also ask, what IS the PD98IMG ROM? Or what is it from?

    Sorry I sound like such a moron... I'm actually a computer technician and relatively tech savvy, but I'm completely new to Android. When I saw "Open up CMD" in step 9 I was thinking "Oh man, the CRAZY phone stuff is finally over- back to the basics (read: warm embrace of Windows" :p Thanks for all you've done for the community and for any help you can give.
  8. CuBz

    CuBz Well-Known Member

    Hope the answers above helped.

    Please post in the 2.37 DOWNGRADE ISSUES THREAD if you have any further issues :)
    Seventeen likes this.
  9. Seventeen

    Seventeen Member

    That clarified a heck of a lot of things. Rootin' is serious business, I can tell, so I just wanted to make sure I didn't make some clutz mistake. Hope my confusion/your answers helps anyone with the same questions in the future!

    Good to know you get where I'm coming from too :p Every time I think I get something, it gets crazier:

    "Oh okay, I get rooting now- wait wtf is DEODEXED?"
    "Ah well that makes sense, now for- huh? S-OFF? S-ON? ENG-OFF? SPANISH-ON?"
    etc etc

    Next thing you know I have to run LINUX commands through Busybox and I'm losing touch with reality.

    Thanks :)
  10. CuBz

    CuBz Well-Known Member

    Believe it or not I didn't know about things like S-OFF, etc, until about 2 weeks ago. I only knew how to root. It's crazy how quickly you can take everything on. One minute you're pulling your hair out not having a clue what to do, getting confused and feel like you're reading a different language, then a few hours later you know it all and feel like a super hero lmao

    I love helping people who don't have a clue what they are doing because I've been in that situation where everyone ignores your questions, and most devs look down on you. There's one dev that really hates me just because I posted this guide before he could even figure out the method.

    As stupid as this may sound, it feels good to achieve something like this, and I especially felt proud seeing my guide make it on the XDA home page.

    If you need anymore help just pm me and I'll give you all the help you need
    hellibelli likes this.
  11. Seventeen

    Seventeen Member

    Wow, that really is hard to believe. Looking at your post count and the fact that you essentially pioneered this downgrade method, you'd think you were born in an Android phone factory. You know what I mean anyway haha.

    I'm glad there are people like you in the community; it really inspires me to be able to help others the same way (whenever I start connecting enough dots in my head anyway). I might've tentatively approached the goldcard/downgrade with a 10KM pole, then given up due to its heaviness.

    I am going to give all this a try today/right now so I'll let you know how it goes :)

    Thanks again, you are a super hero :D

    Edit: I am going to provide a kind of 'live root' of the problems I face. Reason is so that people searching issues they have might be informed by how I overcome these issues.

    First Problem: Loading into bootloader greets you with "No image or wrong image" errors for PD98IMG.zip, then takes you back to the main bootloader menu, having done nothing.

    How I got around it: I used a 1GB Toshiba card (0650U15398U SD-C01G JAPAN) at first. Formatting and using the 8GB Samsung card that came with my DHD worked. Not really a solution, but if you're having problems this may be at least why. I've seen people reccomending certain Kingston 2GB cards which seem to always work.

    By the way make sure you use the mmc2 reverse CID number, not mmc1 or mmc0. It will look something like this: 00b400812aba031030303030304d531b

    Second Problem: I tried to flash the second PD98IMG.zip (the stock 1.32 ROM) and kept getting this error:

    Main Version is older!
    Update Fail!
    Press <POWER> to reboot.

    How I got around it: Just followed the wrong instructions :) The "Main Version is older!" error occurs because, well, the version of the rom is older. What the adb commands do is trick the phone into thinking that the rom you use is actually newer. Remember that the first PD98IMG.zip rom you flash is still 2.37 so 1.32 will be older. So, you set the version on the phone to 1.31.405.6 so that your older 1.32 will appear to be newer, no longer prevented from flashing.

    You DO NOT need to load the second PD198IMG.zip (the stock 1.32 ROM) in bootloader in step 6 or 7. You do that in step 11, AFTER the adb commands.

    Also note that if you see the message "Patching and backing up partition XX..." (for me it was partition 17), it's pretty much done. I was silly and thought the "..." implied it was working but you only need to give it about 5 minutes. It is the last output you will see, so once ready, disconnect the phone from USB and reboot into bootloader.
    hellibelli likes this.
  12. CuBz

    CuBz Well-Known Member

    I've just realised I made a mistake, do the adb work BEFORE going into bootloader. I have edited the post for others. Sorry about that
    Seventeen likes this.
  13. berocksr

    berocksr Well-Known Member

    i think i have just suffered reverse steps. tried the boot loader before the adb and didnt work
  14. CuBz

    CuBz Well-Known Member

    Ye sorry that was a mistake I made a few posts up. Do the adb steps before you run the bootloader for the 2nd time
  15. berocksr

    berocksr Well-Known Member

    Sorry dude.

    i have done the goldcard and copied the IMG file into the root of the sd card.
    put the sd card in the phone and held down the power button with volume down to find a white screen


    what now can please try be specific thank you :)
  16. berocksr

    berocksr Well-Known Member

    this is the first img file.... 230 MB that i copied onto the sd

    when do i do the commands?
  17. CuBz

    CuBz Well-Known Member

    Put the first PD98IMG.zip file on the goldcard, then make sure your phone is not connected to the computer. Turn the phone off. Hold the volume down button whilst powering on. Then the bootloader will appear and should automatically start updating.

    If it doesn't then you have a damaged SDCard, or the PD98IMG.zip file is not on the root of the card, make sure it is on the root
  18. berocksr

    berocksr Well-Known Member

    It doesnt start automaticlly.

    just a white screen

    the root of the sd card is the main directory where the folders are ? its in there

    might try another sd card i guess thanks
  19. CuBz

    CuBz Well-Known Member

    Try formatting the card, recreating it as a goldcard using physical disk NOT logical disk
  20. berocksr

    berocksr Well-Known Member

    am i correct to say the root is "c:\" for example... or my sd card is in h: so the root directory is "H:\"
  21. CuBz

    CuBz Well-Known Member


    So the file would be H:\PD98IMG.zip (so it should not be inside a folder)
  22. berocksr

    berocksr Well-Known Member

    yeah i have done all of this

    formated the sd card FAT32

    Made the goldcard file with mm2 done the hex editor thing physical drive removable disk 1
    with read only unchecked.

    copied the first img file on root of sd.

    i have now tried doing this with another sd card i had and i cant even get to the bootloader whilst pressing down and power it just boots up normal with vodafone logo !! how annoying!!! im ready to give up this is giving me the shits!

    saved it copied the
  23. berocksr

    berocksr Well-Known Member

    and the other goldcard i did goes to the bootloader but doesnt start automaticlly

    i click on fast boot and it cant find the img file !!!
  24. berocksr

    berocksr Well-Known Member

    ahahaha what an idiot.

    when i downloaded the PD98IMG file i tried a few times and it ended up been saved as PD98IMG-4..... haha a simple rename and now im updating sorry mate haha
  25. berocksr

    berocksr Well-Known Member

    been a long day !

Share This Page