Root [GUIDE] FroYo 2.2.1 for Root Users! (Updated 3/3/2011 at 3:40 pm EST - NOW EASIER THAN EVER!)

Discussion in 'Android Devices' started by Trident, Jan 22, 2011.

  1. FalconFour

    FalconFour Well-Known Member
    26

    I'm using Windows 7 x64 and the updater was a complete and total gibberish trainwreck. I just did OTA update and it rooted fine (see my long post above for guidance). Vista is exactly the same driver architecture as Windows 7 as far as USB devices are concerned, so I couldn't imagine there's any reason Vista wouldn't work. It's still a good idea to ditch Vista and upgrade to Windows 7 ASAP, though... your computer would thank you for it. :D
     

    Advertisement

  2. JokaLo

    JokaLo Well-Known Member
    38

    Jan 21, 2011
    245
    13
    38
    Ota and root wouldnt give me fastboot tho, or am i wrong?
     
  3. FalconFour

    FalconFour Well-Known Member
    26

    Fastboot is the name of the bootloader for the Ally, so it's kinda like a computer's MBR. If it weren't there your phone wouldn't start. ;) At least as far as I understand.

    The trick is just getting into it, and that is why you get ADB working. Once you get ADB working, you can send the "adb reboot-bootloader" or "adb shell" & "reboot bootloader" commands to get you into fastboot, then you use "fastboot flash recovery amonra_recovery.img" and "fastboot boot amonra_recovery.img" (NOT "flash boot", lol), to get into recovery. Then flash the "su" zip package from SD and remove the recovery installer per the guide, reboot, and bam, root root you're rooted. :D
     
  4. Crash89

    Crash89 Well-Known Member
    18

    Nov 11, 2010
    91
    19
    18
    NC
    I was able to do it on Vista with help from the guys on IRC, and alternate drivers.

    HTML:
    1.  
     
  5. d3310n

    d3310n Well-Known Member
    38

    Jan 13, 2011
    280
    10
    38
    florida
    drivers for what and post the link for them
     
  6. Crash89

    Crash89 Well-Known Member
    18

    Nov 11, 2010
    91
    19
    18
    NC
    Please?

    I am on my Ally, can't right now.


    They are in the topic in IRC. #ally.
     
  7. d3310n

    d3310n Well-Known Member
    38

    Jan 13, 2011
    280
    10
    38
    florida
    same problem its very strange please help someone?
     
  8. JokaLo

    JokaLo Well-Known Member
    38

    Jan 21, 2011
    245
    13
    38

    Ive been in irc for about 2 days, could you pm me the drivers you used please? Im on steps 11 and 12 and one of them installed successfully, it was LGMU that is giving me problems i do believe, but days and days of this and im getting irritable, please god, have pitty on me!!
     
  9. dautley

    dautley VIP Member
    VIP Member
    243

    Jul 23, 2010
    1,823
    502
    243
    Dickson, TN.
    Trident, Donated. Thanks!!
     
  10. d3310n

    d3310n Well-Known Member
    38

    Jan 13, 2011
    280
    10
    38
    florida
    sadly i do not have the link for the drivers any more and dont use lgmu just use ota updates worked for me ill try to send u the drivers tho
     
  11. Ekim Gram

    Ekim Gram Well-Known Member
    18

    Aug 9, 2010
    98
    10
    18
    Male
    Musician
    NY
    I have drives that I used from D2A if you'd like them. Sent them to me last night.
     
  12. jmar

    jmar Nexican
    VIP Member
    523

    Sep 27, 2010
    4,851
    3,131
    523
    Male
    Sales
    San Jose, CA
    I completed this guide with Vista...completely ignoring the fact that I didn't have XP or 7...took a risk I guess...it worked for me.
     
  13. JokaLo

    JokaLo Well-Known Member
    38

    Jan 21, 2011
    245
    13
    38
    Ekim and jmartino, if you could both sling sum assistance to me with tips and drivers that would be so appreciated...so so much, ty in advance, im just stuck with lgmu around steps 11 and 12
     
  14. believe

    believe New Member
    5

    Jan 4, 2011
    1
    0
    5
     
  15. Afteraffekt

    Afteraffekt Well-Known Member
    53

    Nov 1, 2010
    354
    76
    53
    Computer Electronics Engineer
    South Carolina
    Its "possible" with vista, but help from IRC is your best bet
     
  16. < RoMe >

    < RoMe > Member
    26

    Sep 18, 2010
    18
    1
    26
    I wanna try this but I'm really afraid I'll fail and mess up my phone. Can someone please and like try and make a video guide on how to do this. If you do you'll like be my hero I swear.
     
  17. odbo255

    odbo255 Active Member
    16

    Nov 19, 2010
    42
    4
    16
  18. krisdezzy

    krisdezzy Well-Known Member
    38

    Nov 30, 2010
    184
    16
    38
    May someone post the directions as a video sometimes I'm missing some stuff and I just want someone to post directions as a video. Thanks
     
  19. XJLI

    XJLI Member
    5

    Nov 17, 2010
    8
    0
    5
    made it to step 28... stuck at the LG splash screen.

    went to reset factory settings... nothing. still stuck.
     
  20. pito74862

    pito74862 Member
    5

    Dec 7, 2010
    5
    0
    5
    kidz
    tampa
    My crappy laptop wont let me use the guide have fun for me everybody.
     
  21. joeymogul

    joeymogul Active Member
    15

    Sep 5, 2010
    37
    0
    15
    I'm sorry guys...I've had the hardest time with this guide. I'm running Windows 7, but I just keep having trouble. Had to unbrick it twice.

    Has anyone come up with another way to go to stock, update to 2.2, root, recovery and then Velocity 1.0??
     
  22. FalconFour

    FalconFour Well-Known Member
    26

    Went over my method earlier in the thread... I was excited to get on 2.2 stock, so I restored mine from a custom ROM to my stock backup, wiped all user data (factory reset), then let it do the OTA update. Once I got the SDK all updated and driver installed, it was pretty simple, just fastboot with adb (need to use "platform-tools" folder instead of "tools", and reference fastboot.exe using "..\tools\fastboot.exe" to avoid a DLL error in the latest SDK), then flash amonra recovery image, boot the amonra recovery image, load the SU zip file onto your SD card (may have to do this before hand if you don't have a MicroSD reader), then use amonra-recovery to install the SU zip file (disable signature verification first). Then remove the recovery-installer script and, far as I remember, reboot. Basically just skip to the end of the gude where you start working with amonra_recovery.img, and modify the commands to reference "..\tools\" before the paths (since you'll need to run them from the "platform-tools" folder). Then you'll be rooted in no time with all applicable OTA updates :)

    Of course I may have gotten lucky with my software version being up to date and not needing a manual update. I haven't yet had anyone else confirm that they can skip the manual update and just use OTA...
     
  23. McLovlein13

    McLovlein13 Well-Known Member
    53

    Nov 1, 2010
    271
    64
    53
    School
    Minnesota
    [EDIT] deleteable, i wasnt thinking
     
  24. everkleer

    everkleer New Member
    5

    Jan 3, 2011
    3
    0
    5
    Well, it wasn't quite as bad as I thought it would be. Two issues I had were when I tried to install the ADB drivers, it said it was missing some files, and also when I went to flash the su zip in the last step it said Verification Failed. For the first issue, the following worked for me:
    For the second issue, I just chose Toggle Verification on the phone (seemed scary but it worked.

    I just wish I'd known beforehand that this would wipe all my apps/data. (I didn't read far enough in here.) Does anyone know if there's any way to recover anything, or is it gone? I have one particular app (called Lifting Log) that I just spent a long time setting up, so I would really like to get my data back for it.
     
  25. Neon Thing In A Jar

    Neon Thing In A Jar New Member
    5

    Oct 20, 2010
    2
    0
    5
    Got stuck on step 31, until I figured out to change the option to verify the signature. Bye-bye CityID! Bye-bye Skype! Woo hoo!

    Now if I could only figure out how to make changes to those start animations stick... :cool:
     
Tags:

Share This Page

Loading...