[GUIDE] FroYo 2.2.1 for Root Users! (Updated 3/3/2011 at 3:40 pm EST - NOW EASIER THAN EVER!)


Last Updated:

  1. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    Your best bet at this point is to visit the AllyIRC and get help there in real time. I would not have succeeded either without their help. Sometimes it gets a little hectic in there but patience and politeness go a long way. :) Most of the folks who hang out there have already done this, including the devs themselves who made the rom and wrote the instructions. They are usually very helpful. If you search the Ally thread for a post by member Dots and 'AllyIRC' you can find a thread with a link to get you to the AllyIRC easily.
     

    Advertisement
  2. zoomnet

    zoomnet New Member

    Joined:
    Feb 17, 2011
    Messages:
    4
    Likes Received:
    1
    this is one of the eaisest root programs i have found for rooting most android phones. connect your phone to your computer, make sure all your drivers for your phone are installed on your computer, turn on usb debugging, remove sd card and then click root.
     

    Attached Files:

  3. jovian2805

    jovian2805 New Member

    Joined:
    Feb 17, 2011
    Messages:
    2
    Likes Received:
    0
    I am using the LG Ally and everything was fine until part 27 and 28. When I try to reboot my phone it keeps going back and forth between the LG screen and the Verizon screen. All I am able to do is pull up the recovery screen.
     
  4. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    You can get Froyo now without having to execute step 27, as it is being pushed OTA to everyone. Just do one more CHECKIN dialing and you should get a notification at the top of the screen asking if you want to download it. IIRC the file is 52.3MB. Thanks to Dots for telling me about this.
     
  5. flick159

    flick159 Well-Known Member

    Joined:
    Jun 29, 2010
    Messages:
    228
    Likes Received:
    19
    Just curious if anyone could answer this for me? Still hesitant to make the jump, just wondering if someone could let me know.
     
  6. jovian2805

    jovian2805 New Member

    Joined:
    Feb 17, 2011
    Messages:
    2
    Likes Received:
    0
    Well I can't get past the LG and Verizon part. Even if I try from recovery I still get the LG and Verizon loop
     
  7. afastyzfr1

    afastyzfr1 Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    81
    Likes Received:
    2
    I just got Froyo 2.2.1 running and my blue-tooth isn't working. Any help?
     
  8. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    Re: both previous posts. AllyIRC is your quickest path to help.
     
  9. afastyzfr1

    afastyzfr1 Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    81
    Likes Received:
    2
    I guess blue-tooth doesn't work yet. Hopefully they come out with an update :)
     
  10. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    I can pair via Bluetooth with 2 other devices (both are Windows Mobile) but I cannot actually connect with them. I did "once" and was able to see files on the first device. But I can't make it happen a second time.

    Is this what you meant by "not working" or are you unable to do anything at all with Bluetooth? I am not very familiar with it.
     
  11. afastyzfr1

    afastyzfr1 Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    81
    Likes Received:
    2

    I cant pair my hands free headset. Phone searches for it but doesn't find anything. I am running Velocity 1.0 so not sure if that affects things.
     
  12. Zoandroid

    Zoandroid Well-Known Member

    Joined:
    May 28, 2010
    Messages:
    1,746
    Likes Received:
    209
    About the only thing I can offer is to check and make sure your HF headset uses a Bluetooth profile which is supported by the Ally. If not, that would prevent you from pairing.

    I don't know if you already read this but the Ally user manual has a section on how to pair and connect with Bluetooth, in case you had not seen that yet. One thing easily missed is remembering to set your device to "discoverable" when doing the initial pairing setup.
     
  13. AllyRootNoob

    AllyRootNoob Member

    Joined:
    Feb 18, 2011
    Messages:
    9
    Likes Received:
    1
    I ALMOST got all the way through this guide, after having probs with the LGMU and having to do the "[GUIDE][LGNPST] Alternate v6 Restore Method" posted by Death2All.

    On the LAST STEP (#34), here is what my phone displays after I "select "Flash zip menu" in recovery and choose "su-2.3.6.1-ef-signed.zip"


    Finding...
    Opening...
    Verifying...
    E:Wrong digest :
    META-INF/com/google/android/updater-script
    E:verification failed

    Installation aborted

    Does that mean I have a corrupted copy of su-2.3.6.1-ef-signed.zip?
    Should I try to re-download the .zip and put it on my sd card (making sure to check the md5 hash)?

    Thank you for all the help I've received thus far and I look forward to one (or a few) more kind soul(s) to get me over the hump! Then, helllloooo Velocity 1.0!
     
  14. magedassad

    magedassad New Member

    Joined:
    Dec 28, 2010
    Messages:
    4
    Likes Received:
    0
    Me too, im getting the same error,
    E: Wrong digest:
    META-INF/com/google/android/updater-script
    E: verification failed

    Installation aborted.

    The zip file was in the right place because it found it, its not liking the updater-script.

    Any suggestions?
     
  15. AllyRootNoob

    AllyRootNoob Member

    Joined:
    Feb 18, 2011
    Messages:
    9
    Likes Received:
    1
    I just talked to Trident on the IRC;

    Select "Toggle Signature Verification" (in the same menu as 'Flash Zip Menu") and try it again. That worked for me.

    I rebooted phone from the menu and now have the Superuser android jolly roger in the app menu!
     
  16. bamaredwingsfan

    bamaredwingsfan Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    525
    Likes Received:
    27
    Question. If i upgraded an old ally that had v6 on an upgraded through tridents guide to get 2.2 an root, but had to use the one of the quick root apps to get root, did i retain fastboot since i came from an older v6 version of software?
     
  17. afastyzfr1

    afastyzfr1 Well-Known Member

    Joined:
    Dec 18, 2010
    Messages:
    81
    Likes Received:
    2

    I figured it out! I was being dumb and didn't do a step on headset. Blue-tooth works!
     
  18. magedassad

    magedassad New Member

    Joined:
    Dec 28, 2010
    Messages:
    4
    Likes Received:
    0

    for some reason it failed again and when I went back and click on toggle verification, it said verification is disabled so I went to flash sd again and selected the zip file it worked! not sure why but it did.
     
  19. jmedina1024

    jmedina1024 New Member

    Joined:
    Oct 30, 2010
    Messages:
    1
    Likes Received:
    0
    Hello everyone and good work btw, to all the peopole that had a hand in making this possible, it looks epic. cant wait!!!!! :-D my problem so far is running the kp500 after #16, kp500 stays loading and wont do anything else. I am running velocity.2, baseband is vs740mv7.5210.1013, SW version is vs740zvb. any ideas on what i might be doing wrong?
     
  20. muellerl25

    muellerl25 Member

    Joined:
    Sep 27, 2010
    Messages:
    18
    Likes Received:
    1
    Try booting into Bootloader to find out. I forget the key combo to boot into the bootloader, but it can also be done through QuickBoot. If you see the blue fastboot screen after rebooting into bootloader, it would be my understanding that you still have fastboot.
     
    bamaredwingsfan likes this.
  21. dautley

    dautley VIP Member VIP Member

    Joined:
    Jul 23, 2010
    Messages:
    1,823
    Likes Received:
    502
    If your talking about SuperOneClick yes, it won't wipe out fastboot or your custom recovery.
     
    bamaredwingsfan likes this.
  22. roadworrier

    roadworrier Member

    Joined:
    Feb 7, 2011
    Messages:
    6
    Likes Received:
    0
    (OK, I guess I posted to the wrong thread earlier, sorry.:confused:) Tried some failed steps in other guides but finally this seems to be the one I want. Some folks kind of asked this question, but I didn't see the answer.

    I have installed the OTA 2.2.1 and have SW Version VS740ZVD. Can I start Trident's instructions at step #29? Or do I have to downgrade and then upgrade again to get root?

    Thanks all.
     
  23. bamaredwingsfan

    bamaredwingsfan Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    525
    Likes Received:
    27



    That was what i was thinking, but im really inexperienced with the ally. Its my wifes phone so you how that goes, they freak if even say oops just once doing one of these processes:D
     
  24. muellerl25

    muellerl25 Member

    Joined:
    Sep 27, 2010
    Messages:
    18
    Likes Received:
    1
    Lol, yes I hear that. Thankfully I have an understanding spouse that allows me to do these things to his phone ;) but a barely muttered 'uh-oh' on my part still sends his alarm bells ringing.
     
  25. bamaredwingsfan

    bamaredwingsfan Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    525
    Likes Received:
    27
    This is the 2nd ally we have had, i permabricked the 1st one an had her at devcon 5:D
     

Share This Page

Loading...