[GUIDE] FroYo 2.2.1 for Root Users! (Updated 3/3/2011 at 3:40 pm EST - NOW EASIER THAN EVER!)


  1. flyinjoe13

    flyinjoe13 Well-Known Member

    Hmm, then I guess i'd better wait because I need to be able to go back to a previous ROM for testing sake.
  2. Valkerie

    Valkerie Well-Known Member


    Then I can remove my previous backups and save some space on my SD card.

    I still prefer how 2.1 a2sd works over stock 2.2s.
  3. phillk6751

    phillk6751 Member

  4. eharlow49

    eharlow49 Well-Known Member

    In command prompt, after typing adb reboot-bootloader, I get error:closed. Any suggestions?
    guitarzero likes this.
  5. jmar

    jmar Nexican VIP Member

    I forgot to remove install-recovery.sh from the system in adb. PLEASE IGNORE THIS "PROBLEM" as it was USER ERROR.

    Trident's method is challenging but worthwhile and rewarding.

    Lots of help in the IRC if you ask well stated questions.
  6. oddbondboris

    oddbondboris Member

    i only received one ota. *#*#CHECKIN#*#* does nothing and i'm on VS740ZV8 after the first OTA... what am i missing in all this?

    **EDIT** i was roaming apparently after the first update...
  7. dvanlinton

    dvanlinton Well-Known Member

    Ok i done all the steps but everytime when i get to the update stage it says problem with communication between cell phone and pc.. anyone have any clues on this???
  8. therealciviczc

    therealciviczc Well-Known Member

    That sucked! It worked, but there were some changes in XP. I couldn't have done it without help from IRC. I'll try to write down what was different in XP as soon as I can get back to a PC. Go to IRC for help if you get stuck, but be friendly and patient please. Its a madhouse. Thanks soooo much to the devs for this. Incredible.

    A few personal notes... I was using XP.

    * When installing/updating SDK, I got errors about folders not being able to be created. Make sure your android-sdk-windows folder is closed in the background. Hit yes. It will install fine even if you continue to get those errors from my experience.

    * I had to name my folders short old school shitty names because DOS wouldn't recognize special characters... so instead of android-sdk-windows, I had android... instead of platform-tools, I had ptools. If you start getting invalid directory errors in DOS, do this.

    * Make sure your phone is not plugged in when you install the LG driver. I had to uninstall and reinstall because mine was.

    * During the device manager portion, updating the driver, I had to rename two of the files. WdfCoInstaller01009.dll renamed to WdfCoInstaller01007.dll and winusbcoinstaller2.dll renamed to winusbcoinstaller.dll. No idea why as this was a tip from someone in IRC.

    * Coming from punisher, before I could do the fastboot -w portion, I had to clear all user data on the phone. I don't know why or if that is unique, but I had to do this.

    * Waiting for the updates took a long time for me. Don't expect them all at once.

    * I had to move everything in \platform-tools to just \tools

    Most of this was from Jazz_Fan4 in the IRC. I'd have accomplished absolutely nothing without the help. There is more. When I do our second phone, I'll jot down some of the things I had to do. Its not cut and dry people, so be prepared. Its not bad once its done. Personally I still like Punisher and Velocity waaaaaaaayyyyyy better than Froyo, but hopefully there will be some good ROMs in the future.
    sfboy likes this.
  9. phillk6751

    phillk6751 Member

    I finally got it to work, I went through all the steps, but when I type su i get permission denied...do I now have to use one click root to root it now or something?
  10. klumpingkalooper

    klumpingkalooper Active Member

    I had the same problem.
    Try adb shell reboot bootloader
  11. sdellgen

    sdellgen Member

    i have a question for one of the dev. on this thread.

    Is it possible that i could just use z4root w/2.2.1 Froyo ?

    and I want to thankyou guys for all the dev work, you know people out there with lg allies want to do more with there phones but they just dont know how to, so with your help and making these things simple.. its good :cool:
  12. Scrillex

    Scrillex Well-Known Member

    z4 root doesnt work with froyo.
  13. flyinjoe13

    flyinjoe13 Well-Known Member

    The directions are a bit confusing. First off, the phone actually reboots before the LG Updater software says it is complete. Wasn't sure if i'm supposed to wait for a second reboot or not. Then when the original install of vz6 is finished, they say to pull the battery, which I assume means the phone will shut off except it doesn't because you have it plugged into a usb power source so I have to remove the usb cable as well. Then when I put the battery back in and power it up holding the vloume down, home and end keys, it boots into recovery (which may be what it is supposed to do). Then when I try and load the bootloader, it tells me more than one device and emulator.
  14. death2all110

    death2all110 VIP Member VIP Member

    Trident could you possibly add a link to this guide:http://androidforums.com/ally-all-t...-alternate-v6-restore-method.html#post2177011 some are in IRC complaining about LGMU. mine is just an alternate for those having trouble with the v6 part of yours. you didnt do anything wrong but i noticed it doesnt work for everybody. just trying to help...

    and the step where you have them flash amonra_recovery via fastboot. after that you have them do fastboot reboot but some cant press the buttons fast enough you could replace fastboot reboot with fastboot boot amonra_recovery.img that will take them straight to recovery. no losing the recovery either because once they run that they can remove the install-recovery.sh file
    ownzordage, MikeyV311 and kpedx like this.
  15. phillk6751

    phillk6751 Member

    So i finally have root...i found out that for step ....
    that it was failing install, i chose the other option (to not verify the file), and ran it again and it worked...plus, the ok button doesn't work in this menu, use the return button instead.

    also removed all useless apps...101MB Available space for internal phone storage, this is kicka**
  16. flyinjoe13

    flyinjoe13 Well-Known Member

    I'm lost. I can get through the LG Updater part, but after that nothing makes sense. Pulling the battery doesn't shut the phone off and it continues to try and boot. Holding down the vloume, home and end keys takes me to the clockwork recovery. Typing in the DOS commands gives me an error about mulitple devices. Trying to update the USB drivers tells me no driver exists for my device when I point it to the supplied .inf file. I guess i'm going to stick with 2.1 for awhile until I or someone can tell me where i'm going wrong. I know i'm following the steps to the letter, but it ain't working.
  17. sdellgen

    sdellgen Member

  18. dots

    dots Well-Known Member

  19. flyinjoe13

    flyinjoe13 Well-Known Member

    Wow, I finally got it too work, but I sure didn't follow these directions. I used a combination of steps: some listed here, some listed by d2a in another thread and some just general common sense stuff when the directions didn't work as they were supposed too. In the end, it all worked out and that's all that matters I guess.

    Thanks to all involved in getting us an available version of Froyo that is rooted. Don't know how you guys know all this stuff, but all of us dummies sure are lucky you do.
  20. bnitty

    bnitty Well-Known Member

    these steps are totally confusing. I just won't be rooted until the thunderbolt comes out
  21. flyinjoe13

    flyinjoe13 Well-Known Member

    I'm going to write a little tutorial later tonight outlining the steps I had to use when I couldn't figure these ones out. It was actually pretty easy looking back on it now that I got everything done.

    A quick summary is that I used death2all's steps for getting back to stock v6 and updating all the way through vzc. Then I came back here and started on step #28 and went from there all the way through the end. There were only a couple of hiccups I had to figure out since I started in the middle and didn't do a few things that got done in the steps I skipped.

    I'll try and get it written up as soon as possible after I get my phone back in working order.
  22. Cjohn8792

    Cjohn8792 Well-Known Member

    Is it likely that there will be an easier process for this if we wait? Perhaps a zip file at one point that will do everything for us? I don't expect something for nothing, but I am unsure if my phone will work with this. I just have a rooted ally with velocity .4, I don't know what versions of what need to be on my phone for any of this to work. Is this guide supposed to put us back to factory, update to the OTAs and then root? Is it possible for me to just revert to factory with the steps then update and not root?
  23. dcooterfrog

    dcooterfrog Well-Known Member

  24. flyinjoe13

    flyinjoe13 Well-Known Member


    Yes it is, but if you do it that way, you will never be able to root. It's my understanding that there is no way to root the OTA update. What these guys have put together is the only viable way to have Froyo and root at the same time.
  25. Cjohn8792

    Cjohn8792 Well-Known Member

    I am just going to stay with 2.1-1 until there is a different way of doing this, or I buy a newer phone and start from scratch. My ally has given me a lot of good times, but I need something that can process more at once.
Loading...

Share This Page