1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[GUIDE] How to Install firmware(1.5/2.1) on your GalaxyTips


  1. frankmehta

    frankmehta New Member

  2. TylerDurdenk

    TylerDurdenk New Member

    Looks like there is no support from the OP.

    Eventually I installed XP to my Net Book and played around more with the drivers some more. Finally got it working, but don't ask me to explain why.
  3. sriharsha_m

    sriharsha_m Member

  4. noworry

    noworry Active Member

    Yesterday I successfully upgraded my spica to android 2.1 I570EXXJCE from 1.5

    I also got the "setup connection.." stuck forever. I had all the drivers installed properly and they were shown correctly in the Device Manager.

    The solution that worked for me is:

    1) In Odin, I selected One Package and chose the old spica ops file. Then started the flash.

    2) Once the phone reboots, an exclamation mark will come in the phone. During that stage, close the odin, unplug the usb and remove the battery from the phone.

    3) Next, start the phone in the download mode (Volume down + Camera + Power) button. Open odin and select the new spica_jc3.ops. Then connect the usb and start the flashing.
    It went smoothly and it will finish in 6 mins with PASS in odin !!
  5. Leo Khenir

    Leo Khenir New Member

    Update: Oh, it finally started. Got exactly what mentioned above. Am now flashing with new .ops file. Crossing my fingers. Actually trembling a bit :(
  6. Zargon

    Zargon Well-Known Member

    Try as I might, I cannot get my laptop to apply the correct drivers when I connect the phone in 'download mode'. The drivers are fine in phone mode, but not in 'download mode'.

    Just says 'unknown device', and when I try to install the drivers (from the driver pack) it says it can't.

    Maybe a quirk of my PC...
    :confused:
  7. acoole

    acoole Well-Known Member

    I'm still here and I'm sorry for the lack of support I've just been rather busy.

    People having issues with drivers there's not much I can do, I can't see why sometimes the drivers work and sometimes they don't, they are completley irratic.

    If your having alot of trouble with updating then I suggest you wait for an official release in your country which will be better than the current releases, however the wait could be long so it's up to you :)

    Thanks,
    Andrew
  8. kingdave

    kingdave Well-Known Member

    I've given up waiting for Samsung and T-Mobile to get their act together so I think I am going to Odin my Portal.

    Trouble is, following the guide at the top, I don't get the COM port thing (the bit in yellow on the picture) in Odin. There is nothing there on my Odin screen.

    I've checked in device manager and my USB device and Android modem are there as described.

    Any ideas?
  9. gusto5

    gusto5 Well-Known Member

    PC studio and New PC Studio aren't required.

    Individuals who want to use XX firmwares should use JCE/JCF/JD1 as these are newer than the ones in the OP.

    Also remember to find the right spica_ops file that corresponds to the firmware.

    You should also at least credit the person you took the pictures from
  10. crypticmiss

    crypticmiss Member

    i don't have pc studio and can't use the disc that came with the phone cos I use Mac! Is there any way to update to 2.1 on my Mac?
  11. Warlain

    Warlain New Member

    WHEN i do all your steps i finally get a exclamation marc on my phone! what does it mean? and when i get the battery off and try to turn it on again it stays on samsung screen! :( what should i do! help me please :(:confused::(
  12. kingdave

    kingdave Well-Known Member


    Mine is successfully flashed, and it does stay on the Samsung screen for ages. Give it a couple of minutes and the phone should then boot up.

    If not, try reflashing.
  13. Beerkan

    Beerkan Well-Known Member

    Anyone experiencing problems with Odin recognising their phone, blame the crappy USB drivers. You may need to attach, and re-attach the phone once Odin has started.

    Try re-booting the phone, and or your PC.

    Failing that install the Kies software.

    See Download Kies Here

    It comes with later USB drivers. Also ensure neither Kies or PC studio are running when you run Odin.

    If you're running Windows7 you definately need kies.
  14. twolves14

    twolves14 Member

    Will this guide work for someone in America?
  15. Beerkan

    Beerkan Well-Known Member

    Yes, even Americans.
  16. bus_ter

    bus_ter Member

    I finally got mine to work after getting stuck at "<1> Setup Connection.."

    It seems to be really fussy.. so here are some things to try that may solve the problem..

    1)Make sure any Samsung programs like PC Studio or keis are not running when you use ODIN (close them in the taskbar)

    2)) Remove everything Samsung from add/remove programs (I actually had a fair few with the modem drivers appearing multiple times..) Install Keis only and reboot.

    3) Try a factory reset of the phone (dial *2767*3855# )

    4) Unplug other USB devices and try a different USB plug for the phone.

    5) Plug the phone into the USB with the phone switched on in normal mode, remove phone. Start ODIN. Reboot phone into Download mode and plugin again.

    6) Try another PC/version of windows if available

    7) Try installing parts of the firmware separatly (see this thread for details). I didn't have to do this.

    8) Give up and throw crappy Samsung phone in the Bin and buy a shiny new phone with Android 2.1 pre installed! :)


    EXTRA: There seems to be a large variation in the speed and stability of different firmware versions. If you're in Europe use firmware I570EXXJD4 which has been tested as the best version so far.. (though not the newest, which doesn't matter because they're all android 2.1 update 1 anyway)
  17. jiteshdivine

    jiteshdivine New Member

    Hi, i have windows 7 64-bit installed on my computer. Would it be possible for getting the drivers for the phone? and would the flashing be a success?

    TIA
  18. Beerkan

    Beerkan Well-Known Member

    Need the latest drivers for your i5700 Galaxy Spica/Lite/Portal on Win7-64bit..

    Install Kies

    Flashing to latest firmware for them Merrycans?

    No problem.
  19. andy-roid

    andy-roid Well-Known Member

    dose any body no if there will be a any june updates released or is that it for the i5700
  20. bigbrett

    bigbrett Member

    can anybody help me please i tried to flash 2.1 on my phone and with great effort i thought i had done it but when starting the phone back up i get an exclamation mark in a triangle with a picture of a phone at the side of it. i have tried to take the battery out and restart and it starts to load then looks like it resets and starts again but it never actually finishes loading. ive been through the forums and tried alsorts like reflashing but still nothing please HELP !!!
  21. Beerkan

    Beerkan Well-Known Member

    It takes a few minutes after flashing to reboot. How long did you leave it before removing the battery?
  22. daveleach

    daveleach New Member

    hi a couple of days ago I managed to get samsung nps to recognise my phone (not entirely sure how brcause now its not working) and it came up with "this device only supports update" or something like that. So I went to update device, chose GT-i5700, but then came up with "this device doesn't support update." I think I'm close, can someone help. Is it a missing driver... or what.
  23. bigbrett

    bigbrett Member

    i left it for a few hours as i had to pop out but still nothing when i got back. i tried to flash to a dif firmware which seems to of worked but now i can't make any calls or txt anybody im on tmobile in uk any ideas folks
  24. Beerkan

    Beerkan Well-Known Member

    Have you got the correct T-Mobile APN settings in your Mobile network settings

    Menu
    Settings
    Wireless & Networks.
    Mobile Networks
    Access Point Names
    T-Mobile UK

    T-Mobile Settings:

    Internet
    Name: T-Mobile UK
    APN: general.t-mobile.uk
    Proxy: 149.254.201.132
    Port: 8080
    Username: t-mobile

    MMS
    MMSC: http://mmsc.t-mobile.co.uk:8002
    MMS Proxy: 149.254.201.135
    MMS Port: 8080
    MCC: 234
    MNC: 30
    Authentication: Normal (PAP)
    APN Type: Internet + mms

    SMS
    Service Centre No. +447958879879
    bendsinister likes this.
  25. bigbrett

    bigbrett Member

    i tried all them but still can't make calls or text. i can connect to internet through phone with wifi turned off. i am now able to reflash and have tried numerous firmwares but still can't call or txt but can use internet how strange. please please help
Loading...

Share This Page