[guide] How to manually downgrade firmware build 6.01.605.05 and newer


Last Updated: 2014-05-18 04:05:51
  1. scotty85

    scotty85 Guides Guide

    htcdev directions added in post 2. if i can get an s-on volunteer to verify it works,that would be awsome :smokingsomb:

    Advertisement
  2. iiichrisiii

    iiichrisiii New Member

    Hi, I got to the fastboot devices step, but nothing showed up in the cmd prompt. It brought my phone to a different screen and I had the option of rebooting, rebooting the bootloader etc. So I rebooted the phone, went to fastboot getvar mainver and now it has just been sitting at < waiting for device >

    What should I do from here? I don't want to screw my phone up. Is there a way to start fresh or if I just stop the process will my phone be messed up?
  3. scotty85

    scotty85 Guides Guide

    the screen you are describing is fastboot. the prior command(adb reboot bootloader) is the one that takes you there. from your description,it sounds like you entered fastboot devices prior to the phone actually being in fastboot(it sometimes takes a minute or 2). the next command failed and hung at 'waiting for device' becasue you rebooted back to the OS,but it needed to be entered in the fastboot screen as well,as do all the commands after it.

    you can either:
    1)start again at the adb reboot bootloader command,amd this time wait for fastboot to load before you enter the next commands.
    or
    2)manually put your phone in fastboot by booting to hboot,then select fastboot from the hboot menu. pick up the commands at fastboot devices

    hopefully that should get you thru the rest of it. :)
    bberryhill0 likes this.
  4. iiichrisiii

    iiichrisiii New Member


    Got through it with no problems! Thank you sir. :)
    scotty85 likes this.
  5. scotty85

    scotty85 Guides Guide

    awsome sauce :smokingsomb:
  6. Goon2Gods

    Goon2Gods New Member

    Thanks your the man have failed in everything with tacoroot and been unlocked this whole time decided to try your 2nd post and let me tell you worked like butter i made an account just to thank you bro! :D youve made one more person a happy man lol
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    excellent! i will go about adding a lil more detail to it. thanks for reporting and glad it worked for ya :cool:
  8. bberryhill0

    bberryhill0 Well-Known Member

    Thanks Scotty. It's really cool to have a root thread that works here.
    scotty85 likes this.
  9. scotty85

    scotty85 Guides Guide

    youre quite welcome. im glad its helpful :smokingsomb:
  10. skullabyss

    skullabyss New Member

    when I go to use this command: md5sums RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.605.3_Ra dio_1.09.01.0622_NV_VZW1.92_release_199487_si.zip

    I get an error saying "Unable to read file/directory RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.605.3_Ra dio_1.09.01.0622_NV_VZW1.92_release_199487_si.zip"

    any solutions?
  11. scotty85

    scotty85 Guides Guide


    You prolly have a space between Ra and dio. Delete the space,or Rename the file to something short and simple in the miniadb folder,and change the command accordingly :)
    bberryhill0 likes this.
  12. wolfdroid2012

    wolfdroid2012 Member

    I'm stuck on this part. I did it and now all I see is a silver htc and the cmd prompt window saying sending 'zip' <292817 KB>... _ and the underscore is flashing. It's been like this for an hour and I don't know what's going on...does it really take that long to flash the zip over? Or did I mess up?
  13. scotty85

    scotty85 Guides Guide

    as long as its 'sending' youre ok to unplug it. once it starts spitting out stuff(look in the codebox in the OP to see what it looks like),definatley do NOT interupt it.

    id uplug it,you may have to pull the battery and manually place the phone back into fastboot to get it recognized again by fastboot devices

    sounds like something else is running. make sure you disable htc sync,pda net,easytether,and any other program capable of interacting with the phone.

    you did get a matching md5 for the RUU at that step,correct?
  14. wolfdroid2012

    wolfdroid2012 Member

    Correct. Everything worked up until the point where it's sending the zip file. Should I restart the cmd prompt window too?
  15. wolfdroid2012

    wolfdroid2012 Member

    I just unplugged the phone and it said FAILED <data transfer failure <too many links>

    On the phone it's on the fastboot screen that says

    ***LOCKED***
    Vivo_W XB SHIP S-ON RL
    HBOOT-0.98.0000
    RADIO-1.09.01.0312
    eMMC-boot
    Jul 18 2011, 12:39:36
    RUU
  16. scotty85

    scotty85 Guides Guide

    yup... the phone is still ruu mode. plug it back in,and it should go back to the black/silver htc screen.

    do:
    fastboot devices

    then
    fastboot reboot-bootloader
    then
    fastboot reboot
    if you need to be able to use/boot the phone :)
  17. wolfdroid2012

    wolfdroid2012 Member

    Does that mean that the tacoroot worked? Or do I have to manually install that zip onto the sd card and then unzip them via bootloader? Or can I just go straight to revolutionary now to finish the root?
  18. Travo85

    Travo85 New Member

    I am stuck at the same thing
    sending 'zip' <292817 KB>

    I don't know what I am doing wrong. I've never rooted a phone. The HTC Sync and other programs that you mentioned are those on my phone or computer? How do I stop those?
    Thanks for the help
  19. scotty85

    scotty85 Guides Guide

    if the answer to the fastboot getvar mainver command was 2.18.605.3,then taco root and the adb commands worked. unfortunately,youre only halfway there,you do need to flash the downgrade to be on revolutionary-able firmware.

    if you cannot figure out what is running on your PC and confusing the phone,then you certianly can rename the downgrade .zip to PG32IMG and let your phone flash it from your sd card in hboot.

    once that downgrade finishes,reboot the phone,then check hboot and make sure you have the .97 hboot :)
  20. wolfdroid2012

    wolfdroid2012 Member

    I will give that a try and report back! Thanks!

    When you say this, do I rename RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.605.3_Ra dio_1.09.01.0622_NV_VZW1.92_release_199487_si.zip to PG32IMG and move it to the SD card, then reboot? Should it automatically update?

    And what about the 1.09.01.0312_vivow_Radio_PG32IMG.zip file?

    Thank you so much again for answering all these questions.
  21. scotty85

    scotty85 Guides Guide

    yes,rename "RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_2.18.605.3_Ra dio_1.09.01.0622_NV_VZW1.92_release_199487_si.zip" to PG32IMG and place it on the root of your sd. boot to hboot,it should find the file and ask you to update. tell it yes :)

    im still a lil unlcear what situations require the 0312 radio. all i know for sure,is that you need to run revolutionary,then if you start experiencing reboots,then install the radio. you can install it in hboot from the sd as well,if you need to.

    just remember,always remove PG32IMG from your sd card immediately after flashing and rebooting. its presense will keep you from entering recovery thru hboot in case of an emergency :eek:
    wolfdroid2012 likes this.
  22. bberryhill0

    bberryhill0 Well-Known Member

    The .0312 radio is required to run Sense ROMs. This is only true if you downgrade from the 6.*** firmware. CM ROMs will run with the older radios.
    scotty85 likes this.
  23. wolfdroid2012

    wolfdroid2012 Member

    It worked! Everything worked out. After changing the files to PGIMG32 and updating it via hboot (for both of the files) I was able to use revolutionary and then install superuser. Thank you so much!
    scotty85 likes this.
  24. bberryhill0

    bberryhill0 Well-Known Member

    Scotty is totally awesome.
    scotty85 likes this.
  25. scotty85

    scotty85 Guides Guide

    cool,thanks for the info. for some reason i thot it was a lil more complicated than that :eek:

    awsome! glad it worked for you :smokingsomb:

Share This Page