[GUIDE] How to revert to Gingerbread from ICS (or go to ICS from GB)Tips


  1. Atma

    Atma Well-Known Member

    I'm not sure what the problem is. I just tried and after 30 seconds it gave me the download link. Which browser you using? I'm using Firefox.
    mrdeath2000 likes this.
  2. alextop30

    alextop30 Well-Known Member

    He is correct the second button from the left on the touch keys at the bottom of the screen activates the wipe. So the button on the left of the back arrow. My stock recovery does not respond with the power key either so to confirm the wipe press the button I described to confirm.


    Ok really do not mind me tapatalk is playing some tricks on me the last post that I saw was the one I quoted and later when I use phandroid app I saw that I answered a post that was already solved.
  3. mrdeath2000

    mrdeath2000 Member

    IE7 or 8, cant recall off hand. Pop-up blocker turned off, tried 64bit and 32bit browser.
    I click on link from 1st post and it opens the window with the option to choose free or premium download comparison. chose free, wait 30s then it looks like its loading, then nothing, same page.

    I am going to install JDownloader when I get home and will try that. Maybe I'm doing it wrong... I thought a window would just pop up like normal downloads to say open/save/save as.
  4. Atma

    Atma Well-Known Member

    Another window doesn't popup for me. After 30 seconds, the other text you see (the free and the premium stuff) disappears and then it just says 'click here to download'.
    mrdeath2000 likes this.
  5. mrdeath2000

    mrdeath2000 Member

    Worked just like you described. Went home after work and it worked just fine... maybe the site was just being buggy at the time.

    Phone is nice and snappy again. Thanks for this thread person of unknow gender LOL
    Atma likes this.
  6. Atma

    Atma Well-Known Member

    Bump for the people looking for it.
  7. jhintak

    jhintak New Member

    hi, i'm super thankful for your help

    i did everything as told, but instead of pass i get failed.

    i have t-mobile phone, not like the other guy who had att, so i don't know what i'm supposed to do. if i reset it, it boots fine, but after many tries i still cant get ODin to pass...
  8. jhintak

    jhintak New Member

    hah...

    i don't know if any of you guys ever watched a british tv show called "IT CROWD" but i just pulled a Roy... i "tried turning it off and on again" by reseting the computer, and it worked. i guess something had updated and it needed a restart.

    :)
  9. Atma

    Atma Well-Known Member


    Welcome to the forums jhintak. :ciao:


    Glad you got it working. :congrats:
  10. GalaxDon

    GalaxDon Member

    Hi ATMAzzz.

    I need to know if the revert to GB 2.3.5 will change my IMEI number ???
    I've found the file on the internet,,, It's not my own back up...
    How can I trust this file ? It says it's for my phone, but is there any way to check the full integrity of the .md5 file before flashing ?
    T989DTLKJ3_T989DTLKJ3_TLS.zip
    //inside the zip:
    SS_DL.dll
    T989DTLKJ3_T989DTLKJ3_T989DTLKJ3_HOME.tar.md5

    I know that this file will be under PDA in odin3 v1.85
    But the SS_DL.dll file ???
    What I do with this one ? Where It goes ?

    Ok thanks
    GalaxDon
  11. Atma

    Atma Well-Known Member



    Hi GalaxDon. :ciao:

    Do you have the Galaxy S2 SGH-T989D Telus phone? That looks like the stock rom for that phone.

    No, the only way to change the IMEI is for someone with the right equipment to electronically program it into your phone. Rom's will not do that.

    You can check md5's with MD5 Checker. Install it on your PC then just copy & paste in the MD5 number and then select the file you want to check.

    I have seen the SS_DL.dll file in some zips but you don't need it. Just select the .tar you want to flash.
    GalaxDon likes this.
  12. GalaxDon

    GalaxDon Member

    Hi Atmazzz

    Thanks a lot !

    Yes ! I have a telus sgh-t989d.
    When you said: (( That looks like the stock rom for that phone. ))
    How do you sure ? Is there any software to see inside the .md5 file ? And realy see Telus inscriptions inside... ?

    Oooh... I don't know how to find the md5 number for cut and paste it ?
    Last one please ?

    Thanks
    GalaxDon
  13. Atma

    Atma Well-Known Member


    I recognized the file name as the stock Telus rom. :)

    I'm sorry, I've looked around and can't find a link for the Telus with an MD5. I would suggest downloading it from this thread, Telus Galaxy S2X (T989D) Ultimate Root and Optimization Guide with Steps Scroll down and you will see the link for it. Notice it also has a password you will need to enter when you extract the file.
  14. GalaxDon

    GalaxDon Member

  15. Atma

    Atma Well-Known Member


    Hi GalaxDon. Sorry it took so long to answer. Busy day at work.

    Yes, if you look through that Telus thread you will find people who flashed it without problems.

    Which rom are you using on your phone now? Are you having some kind of problem with it?
  16. GalaxDon

    GalaxDon Member

    Hi Atmazzz

    LoLLL... SInce ICS 4.0.3 Update via Kies official...( I've tried wipe and reset but still the same.)
    My phone is slower and freezed some times in web browser and youtube... Wifi lower range... Wifi connect problem, need to shut down Wifi and then reactivate to make it connect at home or anywhere... More RAM use... My favorite keyboard app, latency playing, is now 108ms instead of 56ms... Email notification sometimes frezze the phone...

    I don't know if I need to find some more, and it's only 1 1/2 month I'd updated...
    I'm still on wanranty.

    Samsung or Telus don't want to help me... They said, I need to ROOT my phone, now the waranty will be void...

    But, when I read here,in this forum, that I can go back with out rooting my phone...
    Does these tech. from Samsung and Telus are realy got the knowledge of all phones ?
    That's the question...
    Maybe they want to sale me another phone ?
    No way !!!!

    I don't understand why they decided to tell all unsatisfied Telus client, like me, SORRY SIR YOU CAN'T GO BACK TO GB 2.3.5 WITH OUT ROOTING AND IT'S YOUR
    RESPOSABILITY THAT YOU'VE MADE THE CHOICE TO UPDATE, EVEN AN OFFICIAL UPDATE. ((((( No piracy !!!! ))) Hey !!!! The phone getting whorse with this update and you advertised: Update the software on your smartphone !!!
    Keep your smartphone running efficiently by using the latest available software.

    No one will help me now ??? That's what I'd said at this moment at the phone with Telus or Samsung...

    So I'm here to find a way to get my phone same as I'd bought it the first day...
    But, I'm little bit scared because I'd never done this before...

    Ok, I talk to much... LOL...
    I will try the downgrade verry soon I think...

    Many thanks
    GalaxDon
    SGH-T989D
    SLOW ICS 4.0.3
    Dreaming of GB 2.3.5
  17. GalaxDon

    GalaxDon Member

    Ok Realy GOOD GOOD GOOD !

    I made it !!!

    So easy to return to GingerBread 2.3.5

    Thanks a lot Atmazzz and every one who wrote about my phone on this forum.

    GalaxDon
    SGH-T989D
    GB 2.3.5 WoW !!!
  18. Atma

    Atma Well-Known Member

    You're welcome. :)



    Glad you got it to work. :congrats:
  19. edub28

    edub28 New Member

    I followed your directions, but when I select start, it fails. When you say-
    browse to the stock UVLDE file you downloaded and extracted. Select it.- I select it (the MD5 file) from the folder I created on my desktop, press start, wait and get a fail every time. Should I be selecting more things like Pit? Im on the t989. Help I HATE ice cream!!!
  20. Atma

    Atma Well-Known Member


    Welcome to the forums edub. :hello:

    No, you don't need to select anything but PDA, the file and Start.

    Do you have Kies installed and does it recognize your phone?

    Do you have UBS Debugging checked in settings > developer options?

    Is your phone in download mode when you press start?

    Reboot your computer and phone and try again.

    Try plugging in a different USB port on your computer.
  21. Captain Mal 78

    Captain Mal 78 Well-Known Member

    Thanks for the easy directions. it's a shame that the bugs haven't been worked out on the Galaxy S2. My wife has a HTC Amaze and it runs on ICS with no problems at all. My phone was slow after the update. A factory reset made it run fast again, but I experienced a few app crashes and said the heck with ICS. My phone is running like new on Gingerbread.
    Atma likes this.
  22. Atma

    Atma Well-Known Member


    Welcome to the forums Captain. :shakehands:


    You're welcome and enjoy your new phone. :)
  23. Captain Mal 78

    Captain Mal 78 Well-Known Member

    One more question. When I was on ICS, I read about how to disable Carrier IQ. Does Gingerbread 2.3.6 have the Carrier IQ rootkit? If so, how do I disable or remove it?
  24. Atma

    Atma Well-Known Member


    Captain, its been a while since I used GB but I believe it has CIQ. One way to check is install this app, Lookout Carrier IQ Detector. You can also look and see what apps you have running. CIQ will be System Manager Application (com.carrieriq.tmobile).

    The only way I know to stop it is to be rooted and using Titanium Backup Pro to freeze it. You could also uninstall it but freezing is probably the safest.
    Captain Mal 78 likes this.
  25. Captain Mal 78

    Captain Mal 78 Well-Known Member

    Thanks. Yep, Gingerbread has it. One of the few nice things about ICS is that you can easily disable Carrier IQ. Thinking about trying the darkside custom kernel.

Share This Page