1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Guide: How to root the Flytouch 3


  1. mutari

    mutari Well-Known Member

    By Poweruser77

    Hi all, I have made some tests on how to root the flytouch 3 and finally I found a solution. I'm going to share it here:

    http://thebelv.altervista.org/Flytouch3/rooting/rooting_flytouch3.html

    Please don't look at the poor graphics because I really have no time so I put everything into a word file and just exported it as a web page

    Hope it helps anyway
    Regards

    From mutari:
    Lets give thanks to Poweruser77.

    I tried this method and it worked. I had to figure out an alternate way because the screens didn't come up in the order specified.
    Once i figure out what i did, I'll post a step by step guide.

    Here are the steps that worked for me:
    1. LauncherPro
    2. Menu
    3. Add
    4. Shortcuts
    5. Activities
    6. Settings
    7. Development
    8. Development, OK
    9. Development, Check USB Debugging
    10. z4root.1.3.0

    Advertisement
  2. mixterz

    mixterz Well-Known Member

    get an overclocking/underclocking app

    hmm well if you can still use everything as before get back to us, see if flash works for youtube etc thanks
  3. mixterz

    mixterz Well-Known Member

  4. mutari

    mutari Well-Known Member

    Working: Titanium Backup, Rom Manager, Root Manager, z4root.

    Not Working:SetCPU for Root Users 1.5.1a
  5. MrSmith317

    MrSmith317 Well-Known Member

    SetCPU isn't going to work without an overclock kernel... so you either need to find a compatible kernel or no overclock for this device. Basically if you feel like playing with it look for one of the custom kernels (like Chevy's) that supports this ARM'ish processor.
  6. mixterz

    mixterz Well-Known Member

    got tot he point of enabling usb debugging and it said scroll to 'development ' option in setting to create shortcut but theres no option to indicate this or half the options from the screenshot ?
  7. MrSmith317

    MrSmith317 Well-Known Member

    Mixterz, in launcher pro the tutorial should say choose activities NOT shortcut. Go under activities then settings and you will find "Development"
    jimbouk1977 likes this.
  8. mixterz

    mixterz Well-Known Member

    ha cheers MrSmith317 finally found it :)
    many thanks!
  9. elge

    elge Member


    I'm a novice in this area. I read a lot about rooting the flytouch 3. What does it mean if a Flytouch is rooted and what's the advantage (and what are the risks)?
  10. MrSmith317

    MrSmith317 Well-Known Member

    Welcome to the forum elge. Rooting is basically going to allow you to do a few things you couldn't otherwise, such as use titanium backup to backup your apps and data, or use metamorph to change your system icons. To put it simply you can get more out of your system because it's rooted. The biggest risk is bricking your tablet, or if you're not careful about the apps you install, you could install malware on your tablet and have to do a factory reset. You can still install malware without root but you're opening pandora's box basically. With Z4root, you can temporarily grant root access which is very nice and probably the best option until you get comfortable with everything. If you have any other questions, feel free to ask.
    nikkithumper, Woodyandroid and elge like this.
  11. android05

    android05 New Member

    I'm a newbie, too. How do you do a factory reset on a Flytouch 3?
  12. MrSmith317

    MrSmith317 Well-Known Member

    Factory reset is easy, just power off the tablet. Then power it back on holding power, menu and back(the big circle) wait a moment and you'll see a message indicating that you're in recovery mode and 5 minutes later you're back to factory.
    Tejaljay and elge like this.
  13. elge

    elge Member

    Hi mr Smith, I tried Z4root but the app says I have to do usb debugging in settings/applications/development but on my flytouch I don't have the menu option development. Is there another way for usb debugging I also tried launcher pro but couldn't open that app. Please advice.
  14. jannoi

    jannoi Member

    Woodyandroid likes this.
  15. MrSmith317

    MrSmith317 Well-Known Member

    Elge. I posted in the root thread about this. But to answer your other question, after you download launcher pro, hit the home button. You'll be prompted with which launcher you'd like to use, choose launcher pro. Follow the rest of the instructions and bam you're rooted baby
    wwelsh and Woodyandroid like this.
  16. MrSmith317

    MrSmith317 Well-Known Member

    Also can we sticky this thread??? Mods....anyone???
  17. simon.caan

    simon.caan New Member

    Just install UniversalAndroot v1.5.3 and press root DONE! if it doesn't work remove sd card try again.

    Then download root check to see if you have root or titanium backup

  18. wilkins73

    wilkins73 New Member

    I did my flytouch 3 but i add 3 asyteather enable app
    wwelsh likes this.
  19. julesnokea

    julesnokea New Member

    Hi, I have a major problem. I already rooted my flytouch 3 using button savior, launcher pro and z4root with success. Finally I got it done. The button savior will give you the option to enable usb bugging. Anyways it froze last nite so I did a factory reset and all was good. Today it froze a little. For some odd reason, I went in and uninstalled launcher pro. Now the flytouch is messed up. I can power up and unlock but I can't do anything else. A message saying "Infomtic Home Launcher is not responding. Can you or anyone else out there help me to get it going again. I would greatly appreciate it very much. Thanks
  20. inderthind

    inderthind Member

    Hi friends i just purchased flytouch 3 and it arrived today. When i pressed the power button it just vibrates and does not powers on. Please help me what to do as i am very tense as this is my first android tablet...... waiting for your reply.
  21. Woodyandroid

    Woodyandroid Well-Known Member

    It just needs a long charge
  22. inderthind

    inderthind Member

    i have charged it properly....... after charging for few minutes it starts vibrating continously and does not stop. when i press the reset button it stops vibrationg.. after that i try to power on the tablet it again vibrates for 1 sec and then nothing.......... kindly help me
  23. Woodyandroid

    Woodyandroid Well-Known Member

    Leave it plugged in and try turning it on, with no TF card in the slot.
  24. woop

    woop novacane (OFWGKTA) VIP Member

    Stickied
  25. queensoft

    queensoft Member

    Hi, I have a problem with the battery (draining very quickly), so I want to root my FlyTouch 3 and delete the battery stats.
    But, is the root operation 100% safe?
    I bought my tablet from China and I really don't want to screw it up completely.
    I was thinking of using temporary root, delete stats file, go back to normal use (not rooted).
    Is this 100% safe? In case of problems, is there a recovery procedure?

Share This Page