[GUIDE] How to Root the HTC One V


  1. iamlegend19

    iamlegend19 Member

    Thanks!

    I am currently downloading the RUU and it takes quite a while. Will update you of the progress. Thanks again :)
  2. iamlegend19

    iamlegend19 Member

    I cant stress this enough but you have saved my me,my phone and my friends life!! both you and ckpv5 on xda dev forums saved me! :)

    now my SU app is gone, can I just download it again on google play? I assume im still rooted and still have CWM recovery right? :) I can make a backup again right? :)
    shipingli likes this.
  3. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    Run the revised steps 4 & 5 above and you'll be done in 10 minutes. Glad it worked out for you ;)
    iamlegend19 likes this.
  4. iamlegend19

    iamlegend19 Member

    I did this and it said on cmd prompt that sending failed. I forgot to tell you but when I got soft bricked the **UNLOCKED** statement above became **RELOCKED**

    what should i do to unlock it again?
  5. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    Sending what failed, the command to unlock the bootloader or flashing the Recovery?
  6. kssshhh

    kssshhh New Member

    Guys, I hope someone can help me.

    I did all the steps above and after I unlocked the bootloader the phone went off.

    So I turned it one, but I forget to turn it one by the volume down and power button so it was booting normally.. Then it asked me for my pincode so I pressed the power button to turn it off. Thinking it was off I then pressed the volume down and power button, but it was still on and was going to reboot in 3 second..

    After that : NOTHING.. now I cant turn it on anymore.. so I thought maybe the battery is low, and plugged it in the charger but even the led light isn't burning right now. What can I do? I can't acces the bootloader aswell..
  7. iamlegend19

    iamlegend19 Member

    Oh do i have to unlock the bootloader again? I thought you said steps 4 and 5 which is referring to installing the recovery and rooting the phone. So i have to unlock bootloader again? Which step should i resume from?

    Thanks
  8. iamlegend19

    iamlegend19 Member


    Successfully rooted but i cant download anything..it only says *downloading* but no exact percentage like before. Ill have to test it more and see if it is a problem.

    *No I just had to reboot it again* it works fine now! Thank you very much! the rooting process was much easier than before :)


    another question, if i make a backup now UNROOTED and then ROOT it later and then RESTORE it to the UNROOTED backup, will it be UNROOTED? (sorry if its confusing cant think of another way to explain it)

    also, is it possible to change the name of the backup using ES explorer and open ClockWorkMod folders and rename the file? So that i could easily remember what kind of backup it is. If i change the name, will it cause unusual effects on my system?

    What custom ROM are you using on your phone right now? Im sure ur using the best one so i want to use that too. :)
    Thanks! :)
  9. iamlegend19

    iamlegend19 Member

    I dont know how to help you on your problem but i think the instructions said that after UNLOCKING BOOTLOADER it will automatically reboot. So you dont have to turn it on yourself.
    CafeKampuchia likes this.
  10. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    This should be true. I don't have to restart mine; it does so itself.

    Kssshhh, try holding the power button down for 10 seconds and see if it comes on or at least goes into bootloader. If it does, plug it in immediately. The phone is savable and you can flash the stock ROM through an RUU.

    If not, you'll probably have to take it to an HTC service center.
  11. iamlegend19

    iamlegend19 Member

    Bump :)
  12. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    Yes, I was confused about this. If you restore an unrooted nandroid backup the phone will be unrooted again.

    Just rename the folders inside clockworkmod/backup. That's what I do.

    I'm not using a custom ROM because there is nothing but Sense 4.0 with minor tweaks. When CM9 is out, I'll surely be trying it out. But I think Sense 4.0 is so good, I'll probably stick with until I'm bored.

    What I really want is a full Sense 4.0 port from the One X/S and I've already asked the devs at XDA for that. So far nobody's bit.
  13. xinweittm

    xinweittm New Member

    I keep having to re-login on htcdev.com, anyone else has this problem? Can someone help me please?
  14. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    I've heard of others having that issue. Try clearing your browser's cache and cookies. If that doesn't work try a different browser.

    Hope that helps!
  15. rhotic

    rhotic New Member

    Would the Chinese version of the HTC One V be the international version? Also would rooting my Chinese HTC One V allow me to install the google play market on it and get me access to the uncensored and complete version of the market? Sorry for being another noob here.
  16. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    Rhotic, welcome to Android Forums :hello:

    If it uses a sim card, then it is the international version. And yes, after rooting you will be able to install Google apps including Play. But app availability in Play varies by region so I can't guarantee what you'll have access to. I would think you should have access to most things, especially if free. Hope that helps!
  17. quikmcmuffins

    quikmcmuffins Well-Known Member

    got a bit of trouble /: ive unlocked my bootloader but when i try to flash the cwm recovery via comand prompt it says this:
    sending 'recovery' (5628 KB)...
    OKAY [ 3.682s]
    writing 'recovery'...
    OKAY [ 1.716s]
    finished. total time: 5.398s

    aterward i try to reboot the recovery via comand prompt but to no avail and when i do reboot into recovery its the same as befor /: p;ease help .....
    NEVER MIND I FIGURED IT OUT LOL
  18. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    I know that feeling all too well :stupido::rolleyes:
  19. chefleon

    chefleon New Member

    Thanks for the guide; it's been incredibly clear and easy to use, which is especially nice for a first time Android owner and rooter.

    I'm stuck at step 5C however: I get to the recovery, and I can use my volume up/down buttons to get to the "install zip from sdcard" option, but when I press the power button to select that option it only clears the screen of everything besides the Clockworkmod logo.

    Any help would be greatly appreciated.
  20. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    Chefleon, welcome to Android Forums :hello:

    I'd first like to confirm that you installed the correct recovery for your device as they are not interchangeable. If your phone uses a sim card (international version) you should have flashed recovery-clockwork-5.8.4.5-primou.img. If it doesn't (US Cellular/Sprint/Virgin Mobile US) then cwmrecovery.img.

    If you have the correct recovery on the device, try reflashing recovery.

    Hope that helps!
    chefleon likes this.
  21. Ssscrudddy

    Ssscrudddy Well-Known Member

    Hi, I'm a total newbie, never used android before. But for what it's worth I've been building & installing PC's since Windows 3.1, written a few Access databases in my time, & once wrote a spreadhseet that reduced a job from 80 hours to 4 hours per week.

    I'm ok up to & including step 3, unlocking the bootloader

    I was getting confused at 4. Install ClockworkMod Recovery
    What is this? Is it a program? If it is, where do I install it, on my phone or PC?


    Anyway, I eventually worked it out that I just needed to put the image file in the same place on my PC as the flashboot.exe (instead of trying to install a program anywhere)

    Regarding the SDK Tools for Android, I let it put itself where it wanted to, but then when using CMD I couldnt find the correct place...

    I got the message something along the lines of "fastboot is not a command"

    where you say "c:android-sdk-windows or c:Android", I had to go to

    \Android\android-sdk\platform-tools
    (full path for me on Vista c:\Program Files\Android\android-sdk\platform-tools)

    Step 4.4) Reboot the phone back into bootloader using the following command: Code:
    fastboot reboot recovery


    This didnt appear to work for me, the phone did nothing, & CMD came up with

    usage: fastboot [ <option> ] <command>

    commands:
    update <filename> reflash device from update.zip
    flashall flash boot + recovery + system
    flash <partition> [ <filename> ] write a file to a flash partition
    erase <partition> erase a flash partition
    format <partition> format a flash partition
    getvar <variable> display a bootloader variable
    boot <kernel> [ <ramdisk> ] download and boot kernel
    flash:raw boot <kernel> [ <ramdisk> ] create bootimage and flash it
    devices list all connected devices
    continue continue with autoboot
    reboot reboot device normally
    reboot-bootloader reboot device into bootloader
    help show this help message

    options:
    -w erase userdata and cache
    -s <serial number> specify device serial number
    -p <product> specify product name
    -c <cmdline> override kernel commandline
    -i <vendor id> specify a custom USB vendor id
    -b <base_addr> specify a custom kernel base address
    -n <page size> specify the nand page size. default:
    2048


    Anyway I rebooted the phone by doing power & volume down instead.

    1 final thing, where you say to get the file CWM-SuperSU-v0.92.zip

    it was actually CWM-SuperSU-v0.93.zip - I guess it's been updated since you wrote this guide.

    Anyway with all that ^^ said, it did actually work for me after all... So,

    Boot loader - UNLOCKED
    Phone - ROOTED

    Backup - I got the message "Could not mount sd-ext... skipping backup of sd-ext"

    does this ^^ mean it didnt back up my SD card? If so not a problem as its backed up on my PC anyway, or is it more serious?

    Thanks :)
    CafeKampuchia likes this.
  22. chefleon

    chefleon New Member

    I've got the correct recovery and reflashed it. I'm getting the same thing in CMD as Ssscrudddy at 4.4 where the command "fastboot reboot recovery" brings up that help list. Maybe that's where my issue is?
  23. CafeKampuchia

    CafeKampuchia Well-Known Member Developer

    Chefleon, yes, in his case it seems that he didn't set the environmental variables as part of the SDK tools guide step 10 so cmd wasn't able to find fastboot. My guide assumes that you've done this.

    Welcome to Android Forums and Congrats on rooting your phone :thumbup:

    Thanks for the heads-up on the version number. I've changed it 3 times already so I'll just get rid of it.

    The sd-ext error isn't a big deal. You can ignore it.
  24. chefleon

    chefleon New Member

    I had to modify the location in the same way he did when setting the new environmental variables, such that it looks like this:

    ...;C:\Program Files\Android\android-sdk\platform-tools\;C:\Program Files\Android\android-sdk\tools\

    Still no dice. I followed the SDK tools guide, so that should all be in line. Any suggestions?
  25. Ssscrudddy

    Ssscrudddy Well-Known Member

    @ Chefleon, once the 4.4 thing didnt do anything, I took the phone off the usb & rebooted it & then powered the phone down.

    I turned the phone on normally (as if I was going to use it). I had to use the "back" key to get out of setting it up (it was like a new phone wanting email accounts & passwords etc) & plugged it back in to the USB, & put it into "Mount as disk drive" mode (as oppose to charge only)

    I then moved the CWM-SuperSU-v0.9x.zip from my PC to the memory card on the phone. Unplugged the USB again (properly, I put it back into charge mode & then ejected the drive on my PC)

    Then I followed the instructions again from & including 5c
    CafeKampuchia likes this.
Loading...

Share This Page