[GUIDE] How to Root the HTC One V


Last Updated:

  1. happybana

    happybana New Member

    Joined:
    Aug 10, 2012
    Messages:
    4
    Likes Received:
    0
    Ah! Worked. Thanks for the tip!
     

    Advertisement
  2. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    Cool
     
  3. Prinny

    Prinny Resident Linux Nutcase

    Joined:
    Apr 15, 2012
    Messages:
    3,679
    Likes Received:
    1,137
    Question: Would this work on linux? I really don't want to put windows on my PC just to root a phone >.>
     
  4. scotty85

    scotty85 Guides Guide

    Joined:
    Jul 25, 2010
    Messages:
    11,139
    Likes Received:
    7,418
    sure. as long as you install the sdk on your machine and are able to use adb and fastboot in a terminal window,you could do it with linux. on windows the unlock_code.bin must be in the same folder as adb/fastboot but on linux im not sure.

    hopefully someone can give you some tips on getting that set up and running,as i have no idea :eek:

    you will find frequent uses for adb and fastboot when playing with a rooted device(espeically an s-on one) so having that working and ready to go will be to your advantage,even after rooting :)
     
  5. agentc13

    agentc13 Daleks Über Alles VIP Member

    Joined:
    Aug 31, 2011
    Messages:
    7,916
    Likes Received:
    5,482
    Like scotty said as long as you have the sdk installed. I believe the only differences from windows is that you just need to have "./" before whatever commands are in the guide and the directories would be different as well.

    Edit: actually the commands may be slightly different as well, let me see if I can find a link.
     
    Prinny likes this.
  6. Prinny

    Prinny Resident Linux Nutcase

    Joined:
    Apr 15, 2012
    Messages:
    3,679
    Likes Received:
    1,137
    I'll do some more research on commands after work. Thanks for the tip though :D
     
  7. Prinny

    Prinny Resident Linux Nutcase

    Joined:
    Apr 15, 2012
    Messages:
    3,679
    Likes Received:
    1,137
    So I can't seem to find anything about the exact commands, but I have found ones implying that I need to do ./ for the commands. so I might give it a go. Worst case scenario, I have spare VM phones over on my bookshelf, because I don't like not having a spare.
     
  8. djel

    djel New Member

    Joined:
    Aug 27, 2012
    Messages:
    2
    Likes Received:
    0
    Why after i pick Recovery, then press power there is no Backup/Restore menu ???
     
  9. djel

    djel New Member

    Joined:
    Aug 27, 2012
    Messages:
    2
    Likes Received:
    0
    Re-edit, the problem solved:D
     
  10. yshaka

    yshaka New Member

    Joined:
    Aug 27, 2012
    Messages:
    1
    Likes Received:
    0
    on step recovery, the screen only shows HTC's legal term (htc quietly brilliant This build is for development purpose only Do not distribut outside of HTC with out HTC's written permission. Failure to comply may load to legal action). and it cant be turn off unless i take out the battery. try with factory reset, same thing happened, shows htc's legal term.on hboot, it shows
    UNLOCKED
    PRIMODD_CT PVT SHIP S-ON RL
    H-BOOT-1.27.0000
    RADIO-1.00.50.0607
    eMMC-boot
    Jun 8 2012, 10:20:08


    -- I got it fixed using VC-Recovery-cn. It's in chinese :(
     
  11. los panda

    los panda Well-Known Member

    Joined:
    Aug 28, 2012
    Messages:
    92
    Likes Received:
    4
    there is no reason i can't root my htc one v before i activate service, right?

    i should have the phone in a couple of days, but i don't plan to activate service until about 3 weeks from now. i plan on testing it/playing w it using wifi on my personal network.
     
  12. Prinny

    Prinny Resident Linux Nutcase

    Joined:
    Apr 15, 2012
    Messages:
    3,679
    Likes Received:
    1,137
    Rooting SHOULD be okay. But I would suggest no ROMs or anything until its activated, due to the activation.apk is usually removed in custom ROM's.
     
  13. agentc13

    agentc13 Daleks Über Alles VIP Member

    Joined:
    Aug 31, 2011
    Messages:
    7,916
    Likes Received:
    5,482
    ^I think this is correct.

    Usually the activation issue is only on different ROMs. Unlocking the bootloader and rooting should be fine.

    Is there a RUU available just in case? If so you could always run that to restore it to stock if there were to be an issue for some weird reason.
     
  14. Leslie Ann

    Leslie Ann Well-Known Member Developer

    Joined:
    Feb 13, 2011
    Messages:
    1,427
    Likes Received:
    893
    A stock based rom should still have all of the activation system in it and therefore all you should need.
     
  15. los panda

    los panda Well-Known Member

    Joined:
    Aug 28, 2012
    Messages:
    92
    Likes Received:
    4
    how can i find out if a ruu is available?
     
  16. ipwnmice

    ipwnmice New Member

    Joined:
    Sep 2, 2012
    Messages:
    2
    Likes Received:
    0
    I think I may have bricked my HTC One V. When it starts up it shows the normal HTC white screen, but then after a few seconds the entire screen turns grey and nothing happens. I downloaded the RUU from the link you gave me
    RUU_PRIMO_DS_ICS_40A_hTC_Asia_TW_1.59.709.3_Radio_1.05.34D.29_20.21.30.23U_release_264969_signed
    (the phone was bought in taiwan) and followed all your steps (go to fastboot, connect usb, run RUU) but when i try to update it says ERROR [155]: UNKNOWN ERROR the ROM Update Utility cannot update your android phone.
    Please get the correct ROM Update Utility and try again

    help?
     
  17. ipwnmice

    ipwnmice New Member

    Joined:
    Sep 2, 2012
    Messages:
    2
    Likes Received:
    0
    I just found out my radio 3831.18.00.282
    any idea on how i could get an ruu for that radio?
    thanks
     
  18. Curtis1973

    Curtis1973 Well-Known Member Contributor

    Joined:
    Jul 1, 2012
    Messages:
    2,188
    Likes Received:
    1,655
    ok im stuck at flashing the unlock bin file from htc. when i enter the command to do so,i either get "waiting for device" if phone is fully booted up. or if im in hboot>fastboot it says its pushing the unlock bin file but just sits at 0kb and never does anything else. read a little on other forums that it could be a driver issue. i have htc sync installed,android sdk,and am fairly handy with adb,etc so im stumped. im running xp pro sp3. never got any error from htc during creation and email of the unlock bin so i assume its ok. i have it located in C:\fastboot along with adb,fastboot and required dlls.
     
  19. CafeKampuchia

    CafeKampuchia Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2011
    Messages:
    2,543
    Likes Received:
    2,787
  20. Curtis1973

    Curtis1973 Well-Known Member Contributor

    Joined:
    Jul 1, 2012
    Messages:
    2,188
    Likes Received:
    1,655
    well an update. did manage to get boot loader unlocked. but definitely off track of how the guide suggests. had to open two instances of fastboot to get it pushed,rooting happened easily,trying to install either recovery causes my pc to reboot. but i think im experiencing a hardware issue. ill stick with root until i can change out the hardware or simply replace the pc.
     
  21. cad2blender

    cad2blender Active Member

    Joined:
    Aug 30, 2012
    Messages:
    28
    Likes Received:
    3
    I get a clockwork mod logo right after I select "install zip from sd card" Maybe I dragged and dropped the SuperSU.zip file in the wrong place? I tried moving it to the "removable sidk K" that shows up in windows 7. I also made sure I flashed the primoC and not the primoU files, I'm using WM-Recovery v5.5.0.4 I also noticed that the screen clears away and shows the orange logo for several options such as reboot system now,mounts and storage,advanced... etc.
     
  22. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    If that happens on other selections also then you may just have to enable the power/select button by going from top to bottom and back up a couple of times

    Sometimes cwm's power/select button is disabled when you first install. What you described sounds like the case.
     
  23. cad2blender

    cad2blender Active Member

    Joined:
    Aug 30, 2012
    Messages:
    28
    Likes Received:
    3
    I'm finally rooted! I used another recovery, the alternative one that is offered in this tutorial and it worked. Thanks again on writing a good tutorial, you too dobbs69
     
  24. dobbs69

    dobbs69 Well-Known Member

    Joined:
    Oct 16, 2011
    Messages:
    184
    Likes Received:
    38
    I'm using Twrp also , great recovery.
     
  25. cpolasek

    cpolasek Member

    Joined:
    Sep 18, 2012
    Messages:
    5
    Likes Received:
    0
    i am in hboot and have followed your directions exactly. but every single time it put in the fastboot command it says ''fastboot' is not recoginzed as an internal or external command, operable program or batch file.'
    i am located in C:\Users\Caroline\Android> ...
    I tried the environment variable thing but again the same thing happened.
    i don't know what i am doing wrong..
     

Share This Page

Loading...