1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Guide] How to root the Wildfire S with S-ON


  1. Caro332

    Caro332 Well-Known Member

    Use the HTC Asia India RUU.
    bhardwaj918 likes this.
  2. CafeKampuchia

    CafeKampuchia Well-Known Member

    Congrats!

    Yes, this ROM is under development with no firm completion date. The developer is working on this in his spare time. I suspect it will be a few months.

    [ROM][WIP] CM9-marvel-UNOFFICIAL [UPDATE: April 20th]
  3. Caro332

    Caro332 Well-Known Member

  4. CafeKampuchia

    CafeKampuchia Well-Known Member

    Please refer to this paragraph from section 3B of the guide:
    The most important thing is that the RUU matches your phone's type. You must match the phone's model number (under the battery) with an RUU in the list at htcdev.com. Assuming that you have a PG7600, Caro's advice is correct:
    bhardwaj918 likes this.
  5. CafeKampuchia

    CafeKampuchia Well-Known Member

  6. bhardwaj918

    bhardwaj918 Member

    thanx 4 ur rply mine is pg76100
    my android version is 2.3.3 is it ok or do i need to update it to 2.3.5
    n how can i backup my original rom so tht if any problm occurs i can restore my rom i mean in case of softbrick
  7. CafeKampuchia

    CafeKampuchia Well-Known Member

    Android version is not important otherwise I would have said so in the guide. It is unlikely that you'll softbrick the device updating the bootloader as long as the RUU matches the model type. You cannot backup your ROM until the device is rooted, but you can reinstall a stock ROM, so nothing (other than data) will be lost. But I doubt anything will happen if you follow the guide carefully.
    bhardwaj918 likes this.
  8. bhardwaj918

    bhardwaj918 Member

    ohk got that
    means it will not create any serious problem to my device as it is not in warranty
  9. CafeKampuchia

    CafeKampuchia Well-Known Member

    It doesn't matter anyway as the unlock process voids a valid warranty. We're all in the same boat.
    bhardwaj918 likes this.
  10. shazub

    shazub New Member

    Hi,

    I have successfully unlocked and able to confirm the below details before I proceed to run supertools v3.

    *** UNLOCKED ***
    MARVEL PVT SHIP S-ON RL
    HBOOT-1.09.0099
    MICROP-0451
    RADIO-7.53.39.03M
    Feb 8 2012, 18:29:31

    But when I ran supertools its not showing me the menu, it opens a popup warning window saying C:/windows/system32/findstr.exe is not a valid win32 application. I click on okay and gives me a cmd prompt window with following text in it


    @eFrigid on Twitter for updates
    ___________________
    MENU
    ___________________



    Make a choice or hit ENTER to quit:



    I am unable to input the the values 1 then 3, as entering any values takes me back to the above text page. Appreciate if you could help me with this error. I am using windows 7.

    Attached Files:

  11. jcthelight

    jcthelight Active Member

    Hi! I have a wildfire from virgin mobile and my Hboot is 1.06.0000 and i want to root it I tried using the root step if your S on which it is but it didn't work. Any ideas what I need to do? Thanks.
  12. I have run into a problem with step 3b, I followed the instructions and everything seemed to go fine, no errors or anything, but when I check it still says:

    *** LOCKED ***
    marvel pvt ship s-on rl
    hboot-1.09.0099
    microp-0451
    radio-7.54.39.28m

    What am I doing wrong?

    Edit- model PG76100, used the HTC EU 2.13.401.3 RUU
  13. CafeKampuchia

    CafeKampuchia Well-Known Member

    It sounds to me like the HTC Supertool has some kind of conflict with your Windows setup. Try using this rooting method instead, starting with step 2:

    [Guide] How to Root the Wildfire S
  14. CafeKampuchia

    CafeKampuchia Well-Known Member

    Please confirm that your HBOOT shows ***UNLOCKED ***. If so, try step 2 of the link posted just above this post.
  15. CafeKampuchia

    CafeKampuchia Well-Known Member

    Did you have any problems getting the file ("Unlock_code.bin") from HTC and flashing it to your phone (step 3C)?
  16. weerab1981

    weerab1981 New Member

    i would like to start with a big thank you for the guide, im a total noob and managed it on my wfs, i used the Alquez's CyanogenMod 7.2 port
    only a couple of niggles though,
    1, when i change my theme for one of the ones pre-installed the wallpaper wont change unless i do this separately.
    2, i use facebook quite alot but if i want to open an friends album (which has over 1000 photos) an error appears to tell me unable to load album, although i can on my wife's untouched wfs.
    3, its also a little slow in scrolling whilst on FB or internet, is there a cache that i can make bigger which i think could be the problem?



    thank you again guys
    CafeKampuchia likes this.
  17. CafeKampuchia

    CafeKampuchia Well-Known Member

    Congrats, and I'm glad that the guide was helpful. I'm sorry that I can't help with your questions as I neither use facebook or cm7 at the present.
    weerab1981 likes this.
  18. On attempt number 4, I have managed to get it rooted, no idea what I was doing wrong? Thanks for replying anyway.
  19. Thank you very much for the guide!!

    I have used the rom recommended and my internal storage is appalling, the reason I did this was to try and get rid of the apps I don't need/want, anybody have any tips for freeing up internal storage?
  20. Caro332

    Caro332 Well-Known Member

    Titanium backup will allow you to delete bloatware apps. But make sure you don't delete the wrong ones.

    And before you do, I suggest you make a backup with either Titanium backup or make a nandroid backup first.
    In case you run in a problem, you can always restore.


  21. I used titanium but the more apps I remove the lower my internal storage gets???
  22. Caro332

    Caro332 Well-Known Member


    Make sure your back up is being saved on your SD card and not internal memory.
    I suggest you install link2sd. This will ensure you never have internal memory problems
    saintnefarious likes this.
  23. shazub

    shazub New Member


    I was able to run the command after I copy fastboot.exe to the location where I have dloaded the image along with other dll's. A million thanks !!! Not upgraded the ROM as well... All izzz well !!!
  24. Thanks problem solved :) That app should be in the top ten!
  25. zeesixxtee

    zeesixxtee New Member

    ok im total noob & i'm still attempting to try this. everything was going ok until i got the step 14 of the android sdk download. when i connect my phone via usb the drivers don't install automatically as said & when i continue on down the steps to find the problem under the device manager the adb driver is not listed although it is on my pc. help please :(
Loading...

Share This Page