[Guide] How to root the Wildfire S with S-ON


Last Updated:

  1. CafeKampuchia

    CafeKampuchia Well-Known Member

    ADB won't show up in device manager since it's a set of command line commands, not a program or a driver.

    Make sure that you've installed HTC Sync since the Wildfire S USB drivers come with it, but shut Sync down in Device Manager as it causes conflicts.

    Make sure the phone is in Charge only mode (NOT disk drive mode) and that USB debugging is enabled (Settings > Applications > Development > USB debugging).

    That should do it.

    Advertisement
    zeesixxtee likes this.
  2. zeesixxtee

    zeesixxtee New Member

    ok maybe my htc sync is the issue because it doesn't recognize my phone when i connect it to the pc, which is an issue i've had before with it. so what can i do to get my phone to connect to htc sync? i've done the whole usb debugging so i don't know what else it could be unless something went wrong during my install.
  3. CafeKampuchia

    CafeKampuchia Well-Known Member

    Please note that I said you should make sure HTC Sync is not running. If you've followed the directions in my post above (including installing the latest HTC Sync) you may need to try using a different computer.
  4. papasimon001

    papasimon001 New Member

    Great instruction and all sorted in a couple of hours :):):)
  5. CafeKampuchia

    CafeKampuchia Well-Known Member

  6. joystiq55

    joystiq55 New Member

    i have updated my bootloader and i 've followed the guide in htcdev but when i type fastboot oem get_identifier_token it says "waiting for device".What im doing WRONG??Sorry for bad english...:)
  7. CafeKampuchia

    CafeKampuchia Well-Known Member

    If you are sure that sdk tools is properly installed, then check the following:
    1. The device is in charge only mode.
    2. USB debugging is enabled.
    3. HTC Sync is installed (along with the drivers) but isn't running in the system tray or background.

  8. CafeKampuchia

    CafeKampuchia Well-Known Member

    Nope. All you need is the unlocked bootloader.

    joystiq55 likes this.
  9. Caro332

    Caro332 Well-Known Member

    Hilarious:rofl::rofl::rofl::rofl::rofl::rofl:
  10. joystiq55

    joystiq55 New Member

    i think i rooted my phone(supertool says ROOTED!!!) but i downloaded an app called "root checker basic",which says that i do not have proper root access!What's going on???
  11. jimhwin

    jimhwin Member

    I've been trying to root a WFS with an unlocked bootloader with HBOOT-1.09.0099 and tried to use the HTC Supertool without luck.

    But one question I have is that when you connect the phone to the PC, it asks what USB default connection to use - charge only, HTC Sync, Disk Drive, USB tethering or Internet pass-through.

    Which should I use -0 or does it not matter?

    BTW - my Windows is XP on a Macbook using BootCamp. Hopefully Bootcamp is not an issue.

  12. CafeKampuchia

    CafeKampuchia Well-Known Member

    The best thing is that they don't even know that I'm making fun of them :D
  13. CafeKampuchia

    CafeKampuchia Well-Known Member

    Did you install the SuperSU app in step 4C? If not, install it and reboot the phone.

    If you still don't get root, try the rooting method found here:
    Tutorials, Roms, Team MarvelUSc -- EVERYTHING YOU NEED

    It will also root Marvel.
  14. CafeKampuchia

    CafeKampuchia Well-Known Member

    First, just confirm that your HBOOT screen shows *** UNLOCKED ***.

    The connection should always be Charge only. I know that's counter-intuitive, but it's correct. If it still doesn't work, make sure that you have USB debugging enabled (Settings > Applications > Development > USB debugging).

    As for the Mac issue,
  15. joystiq55

    joystiq55 New Member

    I have installed SuperSu but when I open it it says "there is no binary installed and SuperSU cannot install it" and when i open ROM Manager it says that i must root my phone for ROM Manager tofunction.It says also that superuser was not found at "\system\bin\su" or "\system\xbin\su"...

    What i 'm doing wrong?
  16. Caro332

    Caro332 Well-Known Member

    Unfortunately some people do have problem with that method. But I found that WFS manager can root most of those who have problem. Try it out
    http://androidforums.com/wildfire-s-all-things-root/532951-wfs-manager.html
    joystiq55 likes this.
  17. mikeasia

    mikeasia New Member

    I have unlocked my boothloader but still on S-on

    proceeded to rooting my WFS phone and I just get stuck on "loading root script"... after trying both steps on 4b, using htcsupertool v3

    Can anyone help me out please? :confused:
  18. Caro332

    Caro332 Well-Known Member

    Your phone will remain S-on even after rooting. Try downloading Superuser and check to see if you are properly rooted. If it works, then great. If not , try using the WFS manager I posted just above
  19. joystiq55

    joystiq55 New Member

    THANKS it worked!!!!!!!!!!
  20. Caro332

    Caro332 Well-Known Member

    Congrats on rooting your phone!!!
  21. Samkuiper9

    Samkuiper9 Member

    Hey,
    First of all many thanks for setting up this manual, i have rooted and unlocked the boatloader. Installed the recovery.

    But now when i try to back up my rom with CWM 5 it asks to fill in the name of the back up, i push ok and the phone shuts down.
    After a while i had to remove the battery to restart the phone. It wanted to send a report about a weird recovery.

    What can i do to make it work? Is there any other ROM back up methode?

    Update: After trying a second time i see that there is a backup when i open manage and restore backups. Don't know if it is a broken file...
  22. CafeKampuchia

    CafeKampuchia Well-Known Member

    Try re-flashing the recovery and make sure you have the right version. Let me know that doesn't fix it.
  23. leeham1874

    leeham1874 New Member

    I'm having problems at the Super Tool. It comes up saying "ROOTED" then I type in reboot, but nothing happens.
  24. CafeKampuchia

    CafeKampuchia Well-Known Member

    Did you also install SuperSU and reboot?
  25. Spanked

    Spanked Well-Known Member

    Using the super tool would never work on my phone. Instead I just flashed CWM 5.0.2.8 and then the custom rom that was linked here. I planned on using a different rom anyways so it worked out best for me. TY for the post but if any other people have a problem with the super tool just do what I did.

Share This Page