[Guide] How to root the Wildfire S with S-ON

Last Updated:

  1. Samkuiper9

    Samkuiper9 Member

    Tried it no change.
    I reflashed it, i have a pg76100 Wildfire S A510e. So i figured out that i would need the "recovery-clockwork-" file to flash. This worked fine. Downloaded ClockworkMod ROM manager, which also showed: Current Recovery: ClockworkMod

    When tried to backup my rom, SuperSU aksed to give acces, i did and after 2-3 secs the phone buzzed, i saw a white screen with HTC on it, and after a while it disapeared and only the 4 buttons on the bottom where lighted. I could push those and the phone also buzzed. I waited for 5 min , nothing changed so i removed the battery.

    After reboot, when i look in manage backups it shows that it made a backup.

    Is there anyway that i can test this backup if it is a good file? Is this how it is supposed to go?

    btw: I had the usb connected to my laptop and debugging was on, not shure if that could make a difference.

  2. deborabr

    deborabr Member


    I rooted my phone following the instructions on the htcwildfiresblog and apparently was successful. I downloaded rom manager but i get an error "Rom manager says you must root your phone for rom manager to function superuser was not found at "/system/bin/su or"/system/xbin/su". Use google search tofind rooting instructions. After a few attempts the message disappeared and I could click on Flash CWM but now I get a message "An error occurred while attempting to run privileged commands!" How should I proceed? Is my phone rooted after all???How I can confirm that??

    Also I just did the root steps again and I realized that although appears ROOTED when I read through the log this is the message I get:

    Loading root script......
    pushing BusyBox...
    changing permissions...
    mount: permission denied (are you root?)
    /system/xbin/busybox: cannot open for write: Read-only file system
    Unable to chmod /system/xbin/busybox: No such file or directory
    Unable to chmod /system/xbin/busybox: No such file or directory
    /system/xbin/busybox: not found
    adb server is out of date. killing...
    * daemon started successfully *
    mount: Operation not permitted
    Pushing su...
    adb server is out of date. killing...
    * daemon started successfully *
    changing permissions...
    Unable to chmod /system/bin/su: No such file or directory
    Unable to chmod /system/bin/su: No such file or directory
    rm failed for /system/xbin/su, Read-only file system
    link failed Read-only file system
    Pushing Superuser.apk

    Does that means is not rooted at all????
  3. CafeKampuchia

    CafeKampuchia Well-Known Member

    I wouldn't trust that backup. By the way, I never backup from ROM manager. Boot into HBOOT, go into Recovery and do the backup from there.
  4. CafeKampuchia

    CafeKampuchia Well-Known Member

    Deborabr, try following the guide, step 4.
    deborabr likes this.
  5. deborabr

    deborabr Member

    I could check that I already unlocked the bootloader on my S-ON phone and could not find out why the rooting with Supertool is not working....any advices?!!?
  6. deborabr

    deborabr Member

    I guess it worked now because I got a message asking for permission to access an app. Now I have to follow step 5 and I wasn't sure what I had to download here: "Download the official image at Index of /recoveries/. Make sure you choose the right one for your device whether Marvel or MarvelC" I know mine is MarvelC but there's 4 different files and I wasn't sure which one I have to download???

    recovery-clockwork- 02-Mar-2012 01:12 4530176
    recovery-clockwork- 02-Mar-2012 01:13 94
    recovery-clockwork- 02-Mar-2012 01:13 2062561
    recovery-clockwork- 02-Mar-2012 01:13 102

    Also I have both SuperSU and Superuser installed on my phone but seems I cannot uninstall Superuser... do you know how I can uninstall that I just want to keep SuperSU because is what Iam using now.

  7. CafeKampuchia

    CafeKampuchia Well-Known Member

    Congrats! You're almost there!

    Use recovery-clockwork- or .zip and stick with SuperSU. You don't need both, and SuperSU is the better of the two apps.
    deborabr likes this.
  8. deborabr

    deborabr Member

    Im sorry for being such a noob but I could not figure out how to type the commands. Here you say "Type the following command: fastboot flash recovery [image name.img]. For example:
    D:\> fastboot flash recovery recovery-clockwork-
    If you have downloaded the MarvelC image, the image name will be slightly different."

    I tried different ways and didn't work. This is the folder I saved the image file
    how should I write in the windows prompt?
  9. CafeKampuchia

    CafeKampuchia Well-Known Member

    The guide assumes you've installed Android SDK tools. If you have, move the img file to the folder where you installed SDK and try the command again.
    c:\{folder where you installed sdk tools}\fastboot flash recovery recovery-clockwork-

    If you don't have Android SDK, try this instead:
    Wildfire S Manager Auto-Installer

    deborabr likes this.
  10. deborabr

    deborabr Member

    You are so helpful thank you so much!!! I never done this kind of stuff before but I was so tired of cleaning cache everyday hope I can make it to the end!!! =)

    I had the mini SDK installed so I decided to use the auto-installer instead and apparently it worked. I also downloaded CWM5 and created a backup and rebooted, did the factory data reset, cleared the cache but now I dont know to restire the backup. Do I have to download CWM5 again?

    I only did factory reset I did not delete what was on the SD Card.
  11. CafeKampuchia

    CafeKampuchia Well-Known Member

    If you restore the backup, the phone will return to it's exact state when you did the backup, cache and all. It seems like that is not what you want to accomplish. But to restore a backup, boot into HBOOT (turn the phone off, pull the battery for a couple seconds and replace, hold down volume and press power) and go into Recovery. You'll see the Backup/Restore menu in there.
  12. govindravish

    govindravish New Member

    hlo mate the guide seems to be helpful bt i can't get step 3c how to use adb commands.
  13. CafeKampuchia

    CafeKampuchia Well-Known Member

    Please refer to this: SDK tools for Android

    Also, make sure that HTC Sync is installed on your computer, but not running. Open Task Manger and kill it if you see it. You only need it installed to get the USB drivers for the Wildfire S on your computer.
  14. uxolo

    uxolo Member

    i cant understand i cant see this thing rom_02.zip i tried to unlock my boot loader it says its successful then after a while there is a thing popped up in my window it says that ruu not installed properly reinstall the ruu then i tried to do it again then it appears 191 eror rom not supported i used this thing (hTC Asia WWE 2.14.707.2 PG7610000 Download) can you please help me? tnx
  15. Samkuiper9

    Samkuiper9 Member

    Thanks, i tried this but same thing happend.
    The moment pushed Recovery in Hboot it gave the white screen HTC screen, after a few sec this disappears and the screen goes black. The buttons on the bottom stay lighted as before.
    This time the is no back up visable in ROM manager - manange back ups
  16. CafeKampuchia

    CafeKampuchia Well-Known Member

    You need to do this:
    uxolo likes this.
  17. CafeKampuchia

    CafeKampuchia Well-Known Member

    This is totally erratic behavior. I don't know what else to tell you. :( See if you can get support from the ClockworkMod website or maybe over at XDA.
  18. uxolo

    uxolo Member

    i can't find the rom_02.zip what ruu should i choose?
  19. deborabr

    deborabr Member


    I am almost there. =)
    So I did not understand should I restore my backup or not?? Here you say "You just boot into CWM5 Recovery, do a factory reset and clear cache (including Dalvik) and do a restore."

    Also how I clean Dalvik cache?

    After this step I have to download and flash a custom ROM. I tried reading through he guide of better ROMs but I didn't understand. I have a virgin mobile MARVELC phone do you have any idea which one would work better??

    Thank you so much again!

  20. uxolo

    uxolo Member

    1) Run the RUU again and look for the temp folder it created, I something like C:\​Users\​[YourLoginNameHere]\​AppData\​Local\​Temp​\​{82B23FCD-D5D0-45CA-A3A2-5350D3926551}
    2) Find rom_02.zip
    i cant find this thing.plz help tnx
  21. Caro332

    Caro332 Well-Known Member

    Try a different RUU which starts the HTC (and has the same No PG7610000)
  22. uxolo

    uxolo Member

    feb 8 2012,18:29:31

    thats my bootloader
  23. Caro332

    Caro332 Well-Known Member

    Ok...try skipping updating the RUU part. It has worked for some
  24. CafeKampuchia

    CafeKampuchia Well-Known Member

    It looks like you already have an unlockable bootloader. You can move on to step 3C.
  25. CafeKampuchia

    CafeKampuchia Well-Known Member

    If you are installing a custom ROM then there is no need to restore now--only if you have problems with the new ROM.

    The only custom ROM available for your device at the moment is found here:

    It's the link under the text "UPDATE:: 2-21-12"

    Follow the procedure for flashing new ROMs found in step 5C. Clear Dalvik is in Recovery under Advanced.

Share This Page