[Guide] How to root the Wildfire S with S-ON


  1. 5auce

    5auce New Member

    Many thanks for the guide, worked perfectly for a vodafone UK carrier. The only problems i ran into were due to my own stupidity (mistyped commands lol).
    I was only going to root in order to instal a clean version of the stock rom, without all the apps that make me rage by turning on every time i turn on wifi/3g. but i realised it's just as easy to get CM7 so thats what i did.
    one thing that scared me was the cyanogenmod had to be prompted to import contacts from SIM (i thought they were gone for a second :p), which i guess just reinforces the view that i am in control now, not the phone.
    By the way, i realise there has been a clockworkmod recovery released for the wildfire S (which is how i backedup my stock rom), but is there (going to be) a clockworkmod mod manager compatible? as i understand, since there's no wildfire S on the list in the app it isnt compatible so far...
    Thanks again.
  2. siddharthmani

    siddharthmani Member

    hi i rooted my device using the above steps(i was able to get into su using a terminal..)..but i was not able to get s-off on my device...now since i already have root access,is it necessary to get s-off...or does it not matter???
  3. CafeKampuchia

    CafeKampuchia Well-Known Member

    Congrats! Thanks for letting letting us know that it worked!
    That's why I don't see myself going back to HTC Sense, unless it's a modified ROM.
    Actually, Clockworkmod recovery itself is not officially supported for WFS. Eoghan2t7's installer found in my guide is only a port for WFS. Most of this stuff hasn't been supported in the past (even CM7) because before HTC released the unlocked bootloader, the phone wasn't rootable. Why develop and support software that requires root for an unrootable device?
    5auce likes this.
  4. CafeKampuchia

    CafeKampuchia Well-Known Member

    First, thanks for letting us know that you successfully rooted your phone!

    To answer your question, getting S-OFF is not necessary now that the bootloader has been unlocked. In fact, it's not possible at the moment unless you use an XTC Clip.
  5. siddharthmani

    siddharthmani Member

    thanks for ur promt reply....even installed cm7...enjoying root privileges...great thread!!!!!
    CafeKampuchia likes this.
  6. fyerwyer

    fyerwyer Member

    After a quick check I can confirm that mine is the exact same number, 1.08.0099
    CafeKampuchia likes this.
  7. n4pster228

    n4pster228 New Member

    is this reversible?
  8. CafeKampuchia

    CafeKampuchia Well-Known Member

    It depends on what you mean.

    Root is reversible. You can easily unroot a stock HTC ROM. Or if you installed a custom ROM, you can flash back to a non-rooted stock HTC ROM.

    Unlocking the updated HBOOT is reversible. It's not to hard to relock it.

    Updating the HBOOT is reversible. It's not easy, but it's possible to flash an older locked HBOOT.

    Waiving your warranty rights is not reversible. During the bootloader unlock process you are required to upload your phone's oem identifier token to htc's website. They'll know that your phone's bootloader has been unlocked, even if you revert. Your warranty is still broken.

    Like I say in the guide, don't do the procedure unless you are willing to sacrifice your warranty. But once it's done, I don't know why you'd want to reverse it all. The extra control you gain over the hardware is well worth it for a tweaker like me. ;)
  9. Dolphin99

    Dolphin99 Member

    I am stuck on this part of the HTCDev. It doesn't work with my phone.

    untitled.JPG

    I also have no idea what a rom or ruu is. Something about updating the phone? So I skipped that and went down the the bottom of that page where you download bootloader (Hboot or something). And I just put that in my sd card. Could I be stuck because of my "ruu" and "rom"? I get to the bootloader page successfully though.

    Also, if I press the power button on "Bootloader", this is what I get

    untitled2.JPG


    Main question: Every time I try to unlock the bootloader, why do I get stuck at this point? I know some code is supposed to show up instead.
  10. CafeKampuchia

    CafeKampuchia Well-Known Member

    Check out this page for words you don’t know: Terminology - CyanogenMod Wiki.

    The short answer: ROM is the internal flash memory of your phone. All components of the OS reside in ROM including the HBOOT, which needs to be successfully updated to finish the process. An RUU (ROM Update Utility) is a downloadable program that updates the ROM on your phone from a Windows computer via USB cable.

    I think you’ve answered your own question:
    You must update your bootloader by downloading and running the appropriate RUU from htcdev.com. Make sure that you have completely and correctly finished step 3B before trying 3C. Step 3B is the key to the whole process.
  11. Dolphin99

    Dolphin99 Member

    Thank you I understand now.

    So, would this be the RUU that everyone is talking about?

    untitled.JPG

    If so then I already put this in the root of my sd card. The name of it is like "Hboot Marvel" or something. It is what loaded the bootloader. So I don't think it's the RUU. I cannot find the RUU people are referring to. If it is, what am I doing wrong? It could be that my usb is not recognized by my computer, yet I can still access my sd card. And yes I have HTC Sync installed.

    Thank you.
  12. CafeKampuchia

    CafeKampuchia Well-Known Member

    To be honest, I'm really not sure what you are talking about.

    1. Download the appropriate RUU from the list. It looks like you have already downloaded Bell Mobility WWE. Save it on your computer somewhere.

    2. Connect your phone to the computer via the USB cable and enable USB debugging (Settings > Applications > Development > USB debugging).

    3. Run the RUU from Windows and follow the instructions in the wizard.
  13. Dolphin99

    Dolphin99 Member

    Thanks! the HTC super tool said it rooted but it didn't say that on my phone. So I used another method and it worked! I thank you for making this tutorial and helping me root my phone :)
  14. jackuzi13

    jackuzi13 New Member

    I know this may be a bad place for this, but i have more chances in this topic.

    Could anyone send me clean CWM backup which was done after procedure described here?

    My WFS got bootlooped and I don't have backup. Stock ROM woun't flash because it has lower version (2.13.401). My ROM version (after 2.3.5 update and htcdev root) is 2.17.0.0 :/


    //never mind. Figured it out. This can be deleted.
  15. mzpresto

    mzpresto Member

    Sweet!!! I had already rooted with an XTC clip, but just installed CM7 and it's slick! Thanks
  16. darrenf84

    darrenf84 New Member

    hi mate, could you atleast tell me the model you have
    i have A510b PG76120 and it wouldnt load the eu htc ROM
    could you please point me in the right direction that would be very much appreciated.
    some body suggested using the thialand rom but not sure what that would end up like.
  17. CafeKampuchia

    CafeKampuchia Well-Known Member

    I think there is an HBOOT update listed at htcdev.com for PG76120 (Brightstar?). If so, you could try to download it and run it or flash it using this procedure from the guide:
  18. Smokes

    Smokes Member

  19. moustafaatchy

    moustafaatchy Well-Known Member

    That's a very unique guide, thanks so much for it.
    But I have a problem.
    I rooted my device and confirmed it by choosing number 3 in HTC Super tool which showed me the word ROOTED.
    I installed Link2SD and it doesn't have root access and doesn't prompt me to allow it.
    I installed Superuser and there was no apps in the list at all.
    Did I root it right ? or I need S-Off to install Link2SD ??
    Even Rom Manager didn't work "superuser was not found at system bin su or system xbin su" .. I used the installer from the first link
    So it appears I don't have root access at all
    Thanks
  20. CafeKampuchia

    CafeKampuchia Well-Known Member

    Welcome!

    1. Shut down the phone, pull the battery and reinstall.
    2. Restart the phone in recovery (hold down volume down and press the power button).
    3. Scroll down one (volume down) to select RECOVERY and press power button.
    4. Select "backup and restore" and press power button.
    5. Select "backup" and press power button to initiate the backup. The backup will be stored on your SD card under /clockworkmod/backup.

    IMHO, the best ROM for memory management and lack of bloatware is CM7 with Link2SD. There is a great tutorial over at XDA, I think by d33ps1x, on how to install and use Link2SD.
  21. CafeKampuchia

    CafeKampuchia Well-Known Member

    The problem was that Link2SD didn't have root access yet because you didn't install SuperUser first. Try rebooting the phone and seeing if you have SuperUser access after that by opening ROM Manager. If so, then try installing Link2SD.

    If still no joy, uninstall SuperUser and Link2SD, re-run the root step just to make sure, install SuperUser, RE-BOOT, verify root by opening an app that requires it, and if so, install Link2SD.
    moustafaatchy likes this.
  22. moustafaatchy

    moustafaatchy Well-Known Member

    I uninstalled Superuser, Link2SD and other Root apps except Rom Manager.
    Then I rooted the phone and rebooted it.Then installed SuperUser and rebooted again, but there is no change.
  23. CafeKampuchia

    CafeKampuchia Well-Known Member

    What app requiring root have you tried? Are you still getting, "superuser was not found at system bin su or system xbin su"?

    Also, what are your SuperUser settings?
  24. moustafaatchy

    moustafaatchy Well-Known Member

    I tried Rom Manager which still gives me the same message.
    SuperUser preferences are their default.Now I changed Automatic Response from prompt to allow.
  25. moustafaatchy

    moustafaatchy Well-Known Member

Loading...

Share This Page