[GUIDE] How to Root the Wildfire S


  1. mithusan55743

    mithusan55743 New Member

    First of all, I'd like to thank chlinkchlink for finding out about some rooting instructions on XDA.cn. It has been a pain in the nuts to root this thing but it seems like the chinese folks over there were able to crack the thing. I am not the author of the script, I'm just putting all this together for everyone to enjoy. Also, thanks to the people of XDA.cn for their work.

    I know GingerBreak works on some roms, but recent firmware versions have been fixed to not work with GingerBreak, one example is the Bell Canada firmware variant.

    So far this method works on:

    • Stock European ROMs (tested by sammyke007)
    • Bell Canada ROMs (tested by me)
    • Asian ROMs (tested by XDA.cn)
    • Waiting for confirmation on US roms.

    Requirements:


    What does it do?: The script will install the su binary, busybox and superuser on your phone.

    Step 1: Flashing the Custom Recovery UI by XDA.cn

    1. Again, make sure your device is S-OFF.
    2. Again, make sure your memory card is formatted FAT32.
    3. Place the PG76IMG.zip file into your phone SD card.
    4. Turn your phone off.
    5. Hold down the "power" button and the "volume down" button for a few seconds till you see the HBOOT screen.
    6. Don't press anything. The system will scan for some files and it will prompt you for an update. Move the cursor to OK (volume up) to start the flashing process.
    7. After it finishes, press the "power" button to restart the system.
    8. Let Android boot and delete the PG76IMG.zip file from your SD card.
    9. Congrats! Custom recovery has been installed. Process to step 2.

    Step 2: Flashing the rooting script by XDA.cn

    1. Copy the root.zip file into your phone SD card.
    2. Turn your phone off.
    3. Boot into recovery: Hold down the "power" button and the "volume down" button for a few seconds till you see the HBOOT screen. Let it do its thing and then select "RECOVERY".
    4. At the recovery menu, use the volume buttons to select "install zip from sd card".
    5. Then select "choose zip from sd card".
    6. Then find the "root.zip" file on the list.
    7. Select "YES".
    8. Let the script do its thing till you see "Install from sd card completed".
    9. Select "Go Back" on the menu till you find the "power off" option and select it.
    10. Turn your phone back on and let Android boot.

    [​IMG]

    That's it. Superuser will be installed on the phone along with Busybox and the su binary. You will be able allow access to applications needing root permissions now.

    Troubleshooting:

    Q: Superuser force-closes when an application requests for root permissions.
    R: It will not FC when the 1st app requests permissions, but will FC when a 2nd app does. It happened to me on the Bell Canada firmware. It can be fixed by clearing the Superuser application data and then running Superuser from the app drawer. It will request an update of the 'su' binary, and once installed, the error wont ocurr anymore. I guess I could definitely fix this by finding the su binary and packing it into root.zip, but I have no idea of where to find the latest version.

    Source: [TUTORIAL][ROOT] How to root your HTC Wildfire S? - xda-developers

    Enjoy!

    Advertisement
    :
  2. mithusan55743

    mithusan55743 New Member

    It worked perfectly for me it only took me 5 minutes to root my phone
    CafeKampuchia, kace021 and javars like this.
  3. kaykhanittha

    kaykhanittha Member

    Anybody has done it ?
  4. vpwrf

    vpwrf Active Member

    Is there any way of rooting S-ON without XTC-Clip yet?
  5. MadYakker

    MadYakker New Member

    I know this thread is close to a month old since the last activity but I'm wondering if there is a software solution to rooting the Wildfire S yet...

    Any help is appreciated for this Android newcomer.
  6. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    As it stands, it looks as though the only way to root the Wildfire is with Gingerbreak and you need to be S-OFF which is only obtainable with an XTC Clip.
  7. moh.hesham

    moh.hesham Member

    what is meaning of s-off or s-on and how to make it pls?????
  8. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    S-ON is HTC's built in security check which prevents you from rooting the phone or writing to the NAND Partition. S-OFF deactivates the check.
  9. deanshep85

    deanshep85 Well-Known Member

    I know this thread is a how to root and I thought my query would be ok here (sorry if its not)

    but Im looking to ROOT a wildfire S, but what about after when its rooted....is there any custom ROM's about? especially a ROM with a2sd scripting?

    I tried a google search but it just comes up with roms for the original wildfire, unless I'm missing something in my search string.
  10. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    There are a few here you could look at: Wildfire S Android Development - xda-developers

    Unless you're already S-OFF, it's pretty difficult though, sorry.
  11. deanshep85

    deanshep85 Well-Known Member

    thanks El, I wonder why google wouldnt pick that up in results..odd..

    and it will be S-Off, the local phone shop near me has the XTC clip and will do the rooting for me which is good.
  12. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    No problem! "Wildfire S Android development xda" does it. There look to be a couple there which support apps2sd.

    Lucky man, the phone shop in town doesn't have one and I'm not gonna bother paying the
  13. fahadmonster

    fahadmonster Member

    Hello,
    I'm new here and I joined just for this.
    When I HBOOT my HTC Wildfire S,
    It says
    MARVEL PVT SHIP S-OFF RL
    HBOOT- 1.03.0000
    MICROP-0451
    RADIO-7. 46. 35. 08
    JUN 2 2011, 16: 17: 50

    Does that mean my phone is S-OFF?
    Please reply ASAP.

    Thank You
  14. El Presidente

    El Presidente Beware The Milky Pirate! Moderator


    Lol, Yes Sir! :p

    Yeah, that means your phone is S-OFF and you should be able to root etc. :)
    fahadmonster likes this.
  15. fahadmonster

    fahadmonster Member

    OMG Thank You :)
    That was fast.
    OK, once I've done everything in your tutorial,
    How do I install a custom rom?
  16. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    No probs. :)

    It depends what you're looking for. Each ROM generally has its own install procedures (although they can be very similar).

    If yo take a look at some of the ROMs here, that should give you an idea of what they're like. If you let me know what you want, I can have a look and knock up some instructions for you (won't be till later or maybe tomorrow though, I've got a fair bit to get done today).
  17. fahadmonster

    fahadmonster Member

    I don't actually want anything in particular...
    I'm just rooting to move all my apps to SD, because I'm running out of storage.
    You can choose what's best for me :)
  18. fahadmonster

    fahadmonster Member

    It says NO IMAGE! WRONG IMAGE! :S
  19. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Where about are you based and who is your carrier? It only works on some phones by the looks of things.
  20. deanshep85

    deanshep85 Well-Known Member

    a quick google search hasn't helped vastly for me, so I'll shoot it here....

    has the wildfire S yet been cracked with a software root rather than hardware XTC clip?

    I ask because sadly my phone shop guys are not having a huge success rate with the ones they have done so far (test models) EVEN with a registered clip, so they aren't doing it for public yet till the rate is higher. So I'm stuck right now.
  21. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    I noticed something earlier today on XDA, that temp root had been achieved using a method that worked on the HTC Cha Cha. I can't confirm and can't try (my Wildfire S is a work handset), but here's the link: [Tutorial][S-on]Temp root Wildfire s - xda-developers

    Obviously, with temp root what you can do is limited, but at least it's a start.
  22. deanshep85

    deanshep85 Well-Known Member

    so as yet, still no software means to S-Off?
  23. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Unfortunately no.
  24. deanshep85

    deanshep85 Well-Known Member

    damn, but it means that if they are working on software temp roots, then maybe before xmas we might get full root hopefully...

    otherwise means I need to rent an XTC clip then.
Loading...

Share This Page