1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[GUIDE] How to root the ZTE Score M


  1. PlayfulGod

    PlayfulGod Well-Known Member Developer

    This guide will explain how to root the ZTE Score M with the documented backdoor ZTE has put on the Score M. This method will not work once ZTE pushes out the patch to remove it which ZTE has stated they will do soon.

    So now on the what needs to be done.


    Requirements:


    • Need adb working and recognising your phone.
    • Needed drivers for your phone installed. (Windows, listed below)




    Instructions (the following will need to be done from cmd on windows or a terminal on linux:


    1. Download zip (listed below)
    2. unzip zip
    3. navigate to the unzipped dir in cmd
    4. run push.bat (windows) or push.sh (linux) should be able to dbl click it to run too.:
      Code (Text):
      ./push.bat or ./push.sh
    5. type:
      Code (Text):
      adb shell
      or
      Code (Text):
      ./adb shell
    6. type:
      Code (Text):
      /system/bin/sync_agent ztex1609523
    7. type:
      Code (Text):
      mount -o remount,rw -t yaffs2 /dev/block/mtdblock2 /system
    8. type:
      Code (Text):
      cd /data/local/tmp
    9. type:
      Code (Text):
      busybox cp su /system/xbin/su
    10. type:
      Code (Text):
      busybox cp Superuser.apk /system/app/Superuser.apk
    11. type:
      Code (Text):
      busybox cp busybox /system/xbin/busybox
    12. type:
      Code (Text):
      chmod 755 /system/xbin/busybox
    13. type:
      Code (Text):
      chown root.shell /system/xbin/su
    14. type:
      Code (Text):
      chmod 6755 /system/xbin/su
    15. type:
      Code (Text):
      ln -s /system/xbin/su /system/bin/su
    16. type:
      Code (Text):
      /system/xbin/busybox --install -s /system/xbin
    17. type:
      Code (Text):
      exit
    18. then from term or cmd type:
      Code (Text):
      adb shell "rm /data/local/tmp/*"
      or
      Code (Text):
      ./adb shell "rm /data/local/tmp/*"


    Download:




    Advertisement
    :
    iowabowtech, corbryant and gbiggie like this.
  2. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    oh sure... post working instructions... like no one has ever done THAT before.... ;P
  3. randomphace

    randomphace Member

    I pmd you, this is not working for me on windows 7, these commands do not work the batch file does not work, is the above for linux only, i am really confused, i am not dumb, and have rooted several phones, just cannot get any farther.
  4. danny8360

    danny8360 Member

    Can someone please do a video guide to this?
  5. randomphace

    randomphace Member

    danny how far did you get? the command prompt shit working for you? these instructions are obviously not explained well enough and followable. i thought he may have done this on linux, but i installed ubuntu and attempted this as well.
  6. gbiggie

    gbiggie La patience et le pardon Guide

    I don't have my ZTE -PG still has it:(
    Trying to find another though:thumbup:
  7. danny8360

    danny8360 Member

    I haven't tried yet that's why I'm asking. I want to try it on my gf phone but I want to make sure I do it right so she doesn't get mad if something happens
  8. PlayfulGod

    PlayfulGod Well-Known Member Developer

    in both linux and windows, right click the script n make it executable ;)

    Other than that I had no problems running the cmds as posted. It cant be explained any better than it is ;)

    might need to add ./ the the adb shell cmd like so
    Code (Text):
    ./adb shell
    And a video wont help if you cant follow the writing instructions, not being mean, just stating facts. ;)


    Note: the push script will error copying remount, no biggie I didnt include it ;) and then again on rm /data/local/tmp/ which you can do from cmd like so:
    Code (Text):
     adb shell "rm /data/local/tmp/*"
    or

    Code (Text):
     ./adb shell "rm /data/local/tmp/*"
    I edited the OP for this one. ;)
  9. danny8360

    danny8360 Member

    Untitled.jpg

    yo.jpg

    This is wat i get but i cant even open push with double clicking it just closes right away
  10. corbryant

    corbryant Member

  11. corbryant

    corbryant Member

    Okay... I copied the remount file from the original zip file from the first thread... and that got me past the first error. I guess the remount file wasn't included in the second zip file.

    Now, I opened a command prompt and typed adb shell and got to the 3rd command, but it says

    cp: not found

    This happens for both su and superuser files...

    adb does find my phone and seems to be working, as I can type adb devices and see my phone listed.

    <sigh>

    I even tried creating those directories on the sd-card and manually copying the files over but when I went to chmod it still said no such file or directory so something still ain't right with this... Are we all working with the correct paths here?? Maybe PG's stuff is different from ours or something, but for it to not be working with this many people - it's just not us.....Satan spawned this phone...
  12. randomphace

    randomphace Member

    i have had the same exact problems as corbryant. the original zip from the other thread led me to the # sign, and i could not type into cmd. on this one tried removing $ signs got further, same as corbryant. the batch file needs to be redone. i am desperate for root, and still no luck.
  13. randomphace

    randomphace Member

    changing to executable does not work in windows. PG what os are you using?
  14. PlayfulGod

    PlayfulGod Well-Known Member Developer

  15. randomphace

    randomphace Member

    no luck. :(
  16. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    if this is still too hard for you to do manually then i have two options for ya.

    1) give up
    2) you can click the link in my sig, better had hope PG is around because if im going to walk you through how to root the device step by step or remote in and do it for ya then im gunna charge you for it

    this is the two choices i extend to anyone who either cant follow his instructions or open up the batch script and run the commands manually.
    PlayfulGod likes this.
  17. gbiggie

    gbiggie La patience et le pardon Guide

    Will you unroot mine for free:confused::p
  18. randomphace

    randomphace Member

    ok remote to mine, i already offered to donate to pg if this gets fixed. i have tried it on windows 7, windows 8 consumer preview, and ubuntu linux. text me 1 (817) 382-2806 when your ready.
  19. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    ok told pg a few things that need to be changed, and the commands are

    /data/local/tmp/busybox cp su /system/xbin/su
    /data/local/tmp/busybox cp Superuser.apk /system/app/Superuser.apk
    /data/local/tmp/busybox cp busybox /system/xbin/busybox

    to copy over teh rooting files :)
  20. corbryant

    corbryant Member

    I'll give these new commands a shot tongiht. If they don't get me thorugh it then you can remote in and nail it for me. I certainly don't mind paying ya for your time.
  21. danny8360

    danny8360 Member

    They we edit them from the push file or just put them in the command prompt?
  22. PlayfulGod

    PlayfulGod Well-Known Member Developer

    I edited the OP with the new 'working 'cmds' ;)
  23. corbryant

    corbryant Member

    Thanks! We're still downloading the same ZIP file in this thread I'm assuming?
  24. corbryant

    corbryant Member

    Welp, downloaded the new zip and got started. Got allllll the way to the last 3 commands, and got an error... <sigh>

    $ /system/xbin/busybox --install -s /system/xbin
    /system/xbin/busybox --install -s /system/xbin
    link_image[1934]: 5571 missing essential tablesCANNOT LINK EXECUTABLE
    $

    Is this something happening as a result of all the crap I've already tried throughout all of this?
  25. sahugoni

    sahugoni New Member

    using this guide and with the help with shabby i can confirm that rooting is possible for this phone just takes patience and a lot of manual work cant just one click and done
Loading...

Share This Page