[GUIDE] How to root your Activa 4G


Last Updated: 2013-07-09 22:22:21
  1. PandaHacker

    PandaHacker Well-Known Member

    Rooting this phone isnt something hard. I didn't make the zip file All credit goes to Vadim for actually doing that. I took the update.zip file from the root method of the Huawei Ascend II and flashed it onto my Activa using adb.

    The obligatory "I am not responsible to what happens with your phone and you flash this image at your own risk etc etc.. You all basically know the drill ;P"

    Before starting make sure that you have the Android sdk installed on your computer. (I recommend installing it to the root directory of your hard drive)

    Also install the USB Drivers by auto running the program when you plug in your phone via usb.
    Make sure your phone has USB Debugging enabled

    And now the process:
    1.Download the update.zip via download link below.

    2.Copy the download to the root of your phones SD Card

    3.Hop on over to command prompt and go into the platform-tools directory of the SDK 'cd \whatever.path.to.sdk\Android\platform-tools'

    4.Run 'adb devices' and make sure your device is there, it should say M920

    5. If its there then reboot with recovery. 'adb reboot recovery'

    6. Once booted into recovery then use the volume up and down buttons to scroll up and down and to select press camera button and then press power button. (Not at the same time :p)

    7. Choose update from SD Card.

    8. Choose the update.zip from the root of your drive.

    9. After its done then reboot your phone and its rooted

    Link for Update.zip : Dev-Host - update.zip - The Ultimate Free File Hosting / File Sharing Service

    Advertisement
  2. max25002

    max25002 Well-Known Member

    Yea u go! ;)
  3. MapleBacon

    MapleBacon Active Member

    I will give this a shot when I go home. Big thanks to Vadim for making the zip and to you too Panda for posting this.
  4. PandaHacker

    PandaHacker Well-Known Member

    Stick tight because someone told me the su binary is outdated so im going to make a new zip and update ALL THE THINGS xD
  5. max25002

    max25002 Well-Known Member

    Sup wen u commas send file?
  6. angie1001

    angie1001 New Member

    can ya make a video on how to root it because this shit is so confusing like post a video on youtube
  7. ibugppl

    ibugppl New Member

    Is there any way to back up the stock firmware on this. I have this phone but within in a week of having it it bootlooped and I had to get it replaced and it took forever. I want to be able to restore the firmware myself next time. Does clockworkmod work on this after root, or is there another way?

    Also is this risky I would hate to bootloop it again.
  8. Vyrus69

    Vyrus69 Well-Known Member

    Thinking of getting this phone for my wife. She currently has the Wildfire and its always running out of memory space, which is one thing that worries me about this phone.

    Any of you experiencing that same problem and barely having any space to install apps?
  9. max25002

    max25002 Well-Known Member

    It be good if u have a sd card
  10. solo12849

    solo12849 New Member

    I just ran this root method and every time I try to do a SU function the sofware crashes no matter what type of app im using ( es file explorer mainly ) root checker fails and crashes too. Any ideas?

    SCRATCH THAT, it works. You will need to update the Super User app in the market place before it will function properly. Thanks for the work and guide :)
  11. Bluracing

    Bluracing New Member

    Just did this and it works. Problem is I could not leave well enough alone and tried to back it up with rom manager. I created a flash of the huawei ascend 2 and it said it was successfull. Tried to backup and it crashed. Pulled battery and it works but although I have superuser it won't give titanium backup permission so I can't remove bloatware. I tried rebooting from command prompt into recovery but I get the same crash. Tried rebooting from rom manager and it force closes. Tried root checker and says not root. I think I screwed myself. If anyone has any ideas on how to reverse the damage, please let me know. At this point I'm just happy the phone still works. Thanks in advance.

    Blue.
  12. CJSax

    CJSax New Member

    I am having trouble running the reboot recovery command. Each time I do adb reboot-recovery, a list of all the possible adb commands I can do plus a few others appear, but the phone does not reboot into recovery mode.
  13. Mexjoker

    Mexjoker I'm Not Real, Doris!

    What exactly does it say?
  14. angiefomo

    angiefomo New Member

    Just **** it gotta new phone forget about rooting well thanks anyways
  15. bndfamily10998

    bndfamily10998 New Member

    I have everything that needs to be downloaded, my problem is with this part:

    when i type in adb devices, my phone doesn't show up, i installed the drivers, even rebooted my computer and still nothing. what am i doing wrong? any help wopuld be greatly appreciated.

    i have to type this in:
    C:\Program Files (x86)\Android\android-sdk\platform-tools
    which works just fine, its when i type in adb devices that my phone doesnt show up.
  16. SmellamyyJeann

    SmellamyyJeann New Member

    I just bought the Huawei Activa 4G and trying to Root it. Having trouble with what to put in Command Prompt for the Path.. My SDK folder is in Program Files (x86) so I'm not sure what to put in as the path to sdk. Is there something special I need to do with the program after downloading it before I put in Command Prompt? and The Huawei is 2.3.6 and the SDK only has 2.3.3 so which do I install from there, if any? THANKS :eek:
  17. gbiggie

    gbiggie La patience et le pardon Guide

    Welcome to Android Forums bndfamily10998 and SmellamyyJeann:):wavey:
    The SDK needs to be located on the hard drive(C:\) not within the program files.
    Notice how it appears in the pics below in device manager and the C:\ drive on my laptop:
    [​IMG]

    [​IMG]
    Set it up here with the help of Android Forums - View Profile: nuttmeg and his handy guide here:http://androidforums.com/huawei-ascend/438515-setting-up-adb.html#post3402945
    PM me if you need some help and I'll walk you through:thumb:
  18. gbiggie

    gbiggie La patience et le pardon Guide

    gaazakid876 likes this.
  19. SmellamyyJeann

    SmellamyyJeann New Member

    Ive gotten the sdk part down in the COMMAND PROMPT but theres something going wrong with my Computer I think. Theres a problem with my Win7 64-bit and the ADB interface in the device manager. Something about it missing a signature or something of that sort. Its code 52 for windows 7. Ive tried to troubleshoot it but theres nothing I found to fix it. Any suggestions or advice?
  20. gbiggie

    gbiggie La patience et le pardon Guide

    Found this: Code 52: Windows cannot verify the digital signature for the drivers required for this device
    What drivers are you using? Could be that a program like your antivirus, Windows Defender, ect. blocked it when you downloaded the drivers.
  21. kb423

    kb423 Member

    so i figured out the adb interface but i cant figure out how to do step 3
  22. PandaHacker

    PandaHacker Well-Known Member

    Basically what you want to do is change your directory by using the "cd " command and put the path to where the platform tools are. Working on a video tutorial since people are having a hard time understanding. ^_^
  23. max25002

    max25002 Well-Known Member

    Wen u gonna send the following files :)
  24. PandaHacker

    PandaHacker Well-Known Member

    Give me a sec I'll send them today. I have to dump the ROM again. XD

Share This Page