[Guide] How to setup Gparted/Alpharev (or any .ISO) with VMware Player (updated Jan 2012)


  1. SUroot

    SUroot Well-Known Member Developer

    Many people have issues creating a bootable gparted solution.

    There are 3 common ways to set up Gparted:

    Bootable CD - A CD your computer will boot up from (instead of booting up to windows or whatever). Most modern PC's that have a CD support booting.

    Bootable USB
    - A USB that can be booted from instead of windows. Most modern day PC's will support this too.

    The above 2 are covered here: GParted -- Live CD/USB/PXE/HD

    A VMware Virtual Machine - A VM that lives within Windows, meaning you don't need to create any bootable CD's or USB's

    This is a little more complex, but it will also allow you to never need to create a bootable CD or USB again. See last paragraph

    1) Download and install VMware Player (there are other VM's but this is Industry standard and IMHO the best around).

    https://www.vmware.com/tryvmware/?p=player&lp=1

    You will need to sign up to get an activation. Don't worry about this, this is a proper enterprise solution provider, not some 2-bit, backdoor company.

    2) Run through the installation and activation process if required.

    3) Create a folder called "MyBootableISOs" Perhaps on C: so "C:\MyBootableISOs" where you will keep all your bootable CD images (.iso format). Put your gparted or alpharev ISO in there

    4) Open VMplayer and click "create new virtual machine"

    5) When Prompted, Select "I will install the Operating system later" and press next

    [​IMG]

    6) When prompted what operating system you will install later, Select "other" and again in the drop down. > Next

    [​IMG]

    7) Name the Machine "Bootable CDs" or "ISObooter" or something

    [​IMG]

    8) The machine will take up a small amount of disk space, so ensure you are happy with the location it wants to use. Click > Next to pass this page

    9) Select "store Virtual disk as single file"

    [​IMG]

    10) Set Disk size as 0.5 or something low and press > Next

    11) Select "Customize Hardware" and Highlight the CD Drive in the left hand pane

    [​IMG]

    12) In the right hand pane, select "Use ISO Image" and browse to the folder you created earlier and select the .ISO. Click OK

    [​IMG]

    13) Below the left pane, click Add and hightlight "USB Controller", Click > Next, Finish and OK

    [​IMG]

    14) The machine will automatically start up in a new window. If it does not, you can play it from the main window.

    15) Plug your phone in. You should get get a prompt that tells you how to add the device.

    [​IMG]

    16) Add the device like shown in the prompt.

    [​IMG]

    17) Go to Virtual Machine on the top bar > power > Power off. This will take you to the VMware start page. You are now set up.

    Usage:

    1) Highlight your Virtual machine "ISObooter" or whatever.

    2) Connect the phone in recovery mode and select MOUNT USB MASS STORAGE

    3) Virtual Machine > Power > Play Virtual Machine.

    3) Check the icons on the bottom of the page. Hovering one of them Should say "High Android Phone" or something equally descriptive. You can see if the device is active or not by whether it is greyed out or not.

    You can actually right click on this icon and select change icon. I Personally use the PDA icon


    Now you are ready to partition.

    Either use Lecter's video guide:
    Gparted Video Guide

    Or my step by step in the root memory FAQ:
    If I wanted to, is there a step by step process?

    This process is the same for alpharev. You just change the CD ISO to the alpharev one and boot the machine. It can be used for any bootable ISO. Another good ISO to have is Plop. If you download the plop iso and boot to that, it will allow the VMware machine to boot from USB too, something the VMware BIOS does not support. See attatchment for Plop

    Attached Files:


    Advertisement
    :
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    just to note, i did this last night for the desire sim unlock utility
    usb was not enabled by default
    I had to go settings "add" then "usb" and restart the machine before it would take usb mode



    while it sounds in depth, its piss easy and deffo the way forward
    SUroot likes this.
  3. SUroot

    SUroot Well-Known Member Developer


    I'm downloading the files to my Work PC so I'll go through the entire process again. When I initially set it up on my Linux laptop to write the above, I literally did what was above. But this is Windows..... ;)
  4. Usta

    Usta Well-Known Member

    @SUroot,
    Nice work! Adding this to the Sticky Guides.
    SUroot likes this.
  5. SUroot

    SUroot Well-Known Member Developer

    Thanks Usta. And Rasta You're right. Amended and going to send Screenies to myself now.
  6. Rastaman-FB

    Rastaman-FB Well-Known Member

    yeah no worries, if you build an os based on linux/windows it auto enables usb controller.
    if you build an vm without OS and choose "other" it doesnt enable it.

    good guide mate, should help us out quite a lot and imo ill recommend this over any other method

    hmm wonder if theres pocketvmware :p
    SUroot likes this.
  7. SUroot

    SUroot Well-Known Member Developer

    Ah didn't know that tbh.

    Hahah VMplayer Pocket.

    Yoy know you can run debian on Android phones? Not sure how much functionaility is there though.
  8. AceMathias

    AceMathias Well-Known Member

    Very nice and detailed guide, like the use of screenshots too making it very easy to follow and know if things are going correctly.
    If you could do something similar for flashing alpharev partition tables i would be most grateful as this is the thing i got most stuck on and found the faq on fastbooting, in its current state, a bit tricky to follow.
    SUroot likes this.
  9. SUroot

    SUroot Well-Known Member Developer

    I'll be honest, I don't use them so I would have to leave that to someone else....Plus I can't use fastboot on my work PC and my home one is Linux.

    Thank Rasta for the screenshots idea. I was going to leave it text based ;)
  10. Rastaman-FB

    Rastaman-FB Well-Known Member

    dont need screenshots for that. its just
    fastboot flash hboot customhbootimgname.img
  11. Rastaman-FB

    Rastaman-FB Well-Known Member

    hmm its kinda possible but not worth it

    my thoughts were if you can have a pocket usb version you can just duble the whole thing together and include it on the webhost.
    all they would need to do is extract it double click it and away we go

    alas its not that simple
  12. AceMathias

    AceMathias Well-Known Member

    Ok no probs Su

    I know that's the command to use, but for some reason that didn't work for me, said initially that it said AdbWinApi.dll is missing.
    Maybe it's not setup right. I added the path to sdk\tools to the environmetal variables as suggested, but still wouldn't work :(
  13. SUroot

    SUroot Well-Known Member Developer

    Your issue is a particular issue that I have never seen before tbh. Its not part of teh normal set up so that issue would not be helped with a guide. We need to do some trouble shooting, but if the path is added correctly in environment variables, not sure why its doing that.

    You can always try installing the actual sdk.
  14. Rastaman-FB

    Rastaman-FB Well-Known Member

    redownload the files sdktools files from the mirror instead

    these deffo work as ive used them at work and i made them for suroots dropbox

    do you see that file in the folder?

    if you extracted it to c:\ then it should read c:\android-sdk-windows\tools\
    so the path in your environment variables should be ;c:\android-sdk-windows\tools\;


    i wonder if you have anything else installed like myphonexplorer, fastboot commander, droidexplorer etc that can be interfering with it
  15. AceMathias

    AceMathias Well-Known Member

    Ok will try with those files instead, i already had the sdk folder on the pc from earlier, so maybe its slightly different in the version i got previously, as the file in question was in C:\android-sdk-windows\platform-tools instead.
    I therefore tried changing the environment variable to this location instead, but then it said command fastboot not recognised.
  16. SUroot

    SUroot Well-Known Member Developer

    Ah yes that may be it. Delete that entire folder and download the one from the toolbox thread (that says "mirror")
    AceMathias likes this.
  17. Rastaman-FB

    Rastaman-FB Well-Known Member

    ahhh makes a lot of sense

    uninstall those tools from add remove programs as it seems the install process (where the sdk downloads the tools from the library) are incomplete
    delete the folder
    download and extract the ones we have in the ultimate dropbox (tools/pc)
    set the path as i mentioned above

    job done :p

    this is why we are awesome :p

    EDIT: FU Dan
    AceMathias likes this.
  18. AceMathias

    AceMathias Well-Known Member

    Cheers guys will try that tonight.
    Also am going to try the ManU kernel and setcpu tonight as mentioned in the Redux battery life thread, as mine could do with a bit of improvement. Although i do like watching youtube on the phone before work and at lunch so am not surprised that this hammers the battery life.
  19. O-LAmdroid

    O-LAmdroid Well-Known Member

    Which one do I choose? Old GParted Live Images (not recommended), GParted Application Source Code or GParted Live CD/USB/HD/PXE Bootable Image?
  20. SUroot

    SUroot Well-Known Member Developer

    Click the link in this thread. Then click "download" then "download stable releases" then download from there
  21. O-LAmdroid

    O-LAmdroid Well-Known Member

    Okay, thanks. Something I've been meaning to confirm but kept forgetting about is, will the partition allow me to move apps from the "Move to SD" option, and will it work in ANY (Including Froyo) ROM?
  22. O-LAmdroid

    O-LAmdroid Well-Known Member

    Guys, I just tried it and no result. Everything's still on my SD card too... I couldn't find "MOUNT USB MASS STORAGE" on recovery mode, but found "mount usb storage" chose that, and it gave me options "unmount" and "go back", I chose "unmount"... The second time I tried it it just gave me the option "unmount" which I chose... Still nothing.
  23. SUroot

    SUroot Well-Known Member Developer

    When you're in that screen, it is mounted. Choosing unmount or leaving the screen unmounts.

    Go into mount usb storage and stay there until you've done what you need to then ummount
  24. O-LAmdroid

    O-LAmdroid Well-Known Member

    Okay, thanks.
  25. how long should the process take on virtual machine to resize and format to ext3...have been at it for some time now...

    PS...a big thanks to you and others on this forum to help me get my desire on redux 1.2..
Loading...

Share This Page