[GUIDE]How to Unbrick/Upgrade/Downgrade Your SGA (GT-S5830)

Is this thread helpful and should be made sticky?

  1. Yes

    11 vote(s)
  2. No

    1 vote(s)

Last Updated:

  1. Ryuinferno

    Ryuinferno Well-Known Member

    What is a soft-brick?
    Your phone boots up but gets stuck at the Samsung logo. Still able to boot into recovery (Home+Power) and download mode (Volume Down+Home+Power). In that case, you are still able to revive your phone using this guide.

    What is a hard-brick?

    Your phone won't boot up at all. It will not even charge. Not able to get into recovery or download mode. Possibly you used ROM Manager, which should NEVER be used on SGA. If you are still able to boot into download mode using a USB jig, then you still stand a chance. If not, sorry, your phone is dead. Take it to Samsung and act dumb. :p

    Guide to unbrick GT-S5830
    1. Download these files
    - Samsung USB Drivers: Hotfile.com: One click file hosting: SAMSUNG_USB_Driver_for_Mobile_Phones_v1_3_2300_0.zip (if you already have Kies installed, skip this)
    - ODIN v4.38 from here: ODINv4.38.rar | by ryuinferno for Galaxy Ace
    - Firmware from here: samfirmware.com (choose any according to your region)

    2. Extract the firmware package downloaded from samfirmware.com. If it has a single .tar or .tar.md5 file then see Step A. Otherwise, if you have got two or more (usually four) .tar or .tar.md5 files see Step B.

    Step A:
    a. Launch ODIN v4.38.
    b. Check One Package, Auto reboot and Protect OPS check boxes.
    c. Click on OPS button and Load Cooper_v1.0.ops file on it.
    d. Now go to the bottom and click on One Package button.
    e. Load the single *.tar or .tar.md5 file in this field.

    Step B:

    a. Launch ODIN v4.38
    b. Check Auto reboot and Protect OPS check boxes. (Note : Do not check one package option, use this option only when you need to flash a complete rom in one package.)
    c. Click on OPS button and Load Cooper_v1.0.ops file on it.
    d. Click on BOOT button and Select .tar (or .tar.md5) file with APBOOT in the name.
    e. Click on PDA button and Select .tar (or .tar.md5) file with CODE / PDA in the name.
    f. Click on PHONE button and Select .tar (or .tar.md5) file with MODEM in the name.
    g. Click on CSC button and Select .tar (or .tar.md5) file with csc / csc-multi in the name.
    h. Leave EFS blank.

    3. Turn off your phone.

    4. Boot into recovery mode (Home+Power simultaneously).

    5. Navigate using the volume buttons, select wipe data and confirm with Home button.

    6. Once done, unplug the battery.

    7. Reinsert the battery and boot into download mode (Volume Down+Home+Power simultaneously).

    5. Connect your phone to your PC via USB cable.

    6. Once connected in download mode, Odin will say Detected! (see the image below) and then you may press Start button

    6. Wait for the process to complete (It will show "PASS" as in the image below)

    7. Disconnect your phone and wait for the reboot to complete.

    Guide to upgrade/downgrade GT-S5830
    Basically the steps are all the same, but just skip step 4,5,6. A data wipe is not required for this.

    That's all. Hopefully this will help to solve most of your problems. ;)

    References: How To Flash Official Stock Firmwares On Samsung Galaxy Ace GT-S5830 Using Odin.

  2. ayush29k

    ayush29k Well-Known Member

    Nice guide mate, i am sure it'll help a lot of people. :)

    Mate, you forgot to edit the recovery mode key combination in the 'What is a Soft-Brick?' section, its only Home + Power button for S5830.
    Ryuinferno likes this.
  3. Ryuinferno

    Ryuinferno Well-Known Member

    Whoops...forgot to correct that...thanks! :)
  4. wadbongo

    wadbongo New Member


    I need some help with this. Managed to soft brick my wifes old Ace, probably from following the wrong guide somehow. Anyway, I've read this guide, downloaded the files and all. But when I try to load the tar.md5 file in Odin, it crashes (see pic)

    Any ideas? I'm running Windows 8 if that matters.


    Attached Files:

  5. ayush29k

    ayush29k Well-Known Member

    Its been a long time since i did this but i think you have to rename that firmware file to .tar, and remove .md5 from behind, i may be wrong though.

    Also try with a xp or win 7 system, the drivers might not work with win 8.
  6. wadbongo

    wadbongo New Member

    According to the guide, the tar.md5 should be fine. I'm thinking the W8 is the more likely problem. Will have to try on another computer.
  7. TimLalahi

    TimLalahi New Member

    "Your phone won't boot up at all. It will not even charge. Not able to get into recovery or download mode. Possibly you used ROM Manager, which should NEVER be used on SGA. If you are still able to boot into download mode using a USB jig, then you still stand a chance." This is me, in a nutshell, in starting in download mode, I get stuck on the downloading screen. I downloaded CWM and then tried to install jellybean onto my froyo phone. Is there help for me?
  8. ayush29k

    ayush29k Well-Known Member

    What do you mean you are stuck on downloading screen?
    If you can get into download mode then flash a fresh stock firmware via Odin, its your only hope.
    Read the Guide To Unbrick S5830 for flashing procedure in the first post.
  9. ptrmodeler

    ptrmodeler New Member

    My phone was stuck at the Samsung logo, after trying to install Jelly bean.
    I followed the steps in the first post.
    My phone was still stuck at the Samsung logo.
    I booted into recovery mode (Home+Power simultaneously) again and did a
    wipe data/factory reset.
    My phone is working now :)
    Thanks to Ryuinferno
  10. andysuth

    andysuth New Member

    I managed to brick wife's phone at lunchtime trying to upgrade it to Ultimatum Rom.

    Your instructions needed a few improvisations to get them to work but I wouldn't have been able to do it without your guidance.

    Thanks also to other poster who gave the tip of wiping cache and Factory Resetting.

    This thread is so much more useful than debricking threads where the most useful comments are "Why do you Noobs try to install custom roms, live with it....."

    Thanks for your help.

    scary alien likes this.
  11. scary alien

    scary alien not really so scary Moderator

    Thank you for the feedback and the reply, Andy--and welcome to our AndroidForums! :)

    Kudos to Ryuinferno for creating this thread. I'm also guessing they and the other readers might be interested in any improvs you might have used that could benefit others if you're willing to share.

    Cheers and thanks again!

  12. HadesPlutão

    HadesPlutão New Member

    Made it and all works perfectly. :)

    Does anyone knows how to upgrade Gingerbread to JellyBean? On Galaxy Ace GT-S5830. Is it possible?

    scary alien likes this.
  13. ayush29k

    ayush29k Well-Known Member

  14. xenishere

    xenishere New Member

    Thank you sooo much! It saved my samsung galaxy ace!!! Thank you thank you!!!! Omg! I am sooo happy now...
    scary alien likes this.
  15. egestrella

    egestrella New Member

    Hello all. I am trying to follow these instructions for my Samsung Galaxy Ace GT-S5830. After factory resetting my phone it is on a boot loop (I think that's what it's called) and will not completely start up - it boots up but gets stuck at the Samsung logo. I have downloaded everything listed, but when I go to "One Package" in Odin and try to load the .tar.md5 file nothing happens and I can't get any further then that step. I tried downloading a different firmware also, but neither work. (S5830XWKTQ_S5830OXXKT4_S5830XWKT8_HOME.tar.md5 AND S5830BGKT4_S5830XECKT4_S5830XWKT8_HOME.tar.md5).
    Now, after changing the file name and removing ".md5" the firmware loads, but the program will not recognize my phone and says it's not connected ("Please connect phone!!"), even though it is in download mode and says "downloading..." in small yellow letters on my samsung. I have wiped data/factory reset, wiped cache, and yet my computer and Odin will not connect to my phone.

    Please please help me, I have been reading for hours online and cannot seem to fix my phone. I'm new to all of this so please, plain English would be much appreciated. Thank you so much! =)
    scary alien likes this.
  16. egestrella

    egestrella New Member

    I figured it out finally! I honestly read and tried so many different things I'm not even sure what made the difference - I finally tried plugging my phone into another USB plug on my computer and it automatically searched for the phone's driver (even though it was already installed on my computer). Anyway I followed the rest of the instructions and it worked!
    scary alien likes this.
  17. snail112

    snail112 Member

    [FONT=&quot]Ryuinferno, thanks for this guide. I was able to safe my Ace.[/FONT]
    scary alien likes this.
  18. matdim

    matdim New Member

    thank you very much for your help. i have some problems until the phone to start but now is fine. thank you again. continue the good work!
    scary alien likes this.
  19. daithidearg

    daithidearg Active Member

    What is this USB jig? Is this the USB cable or is this something else?

    My phone installs drivers when it's plugged into USB but I don't see it as an external drive anymore. Sound up/down + home + power doesn't react at all and screen stays completely dead. Am I fubarred or is there anything I can do?

    May not make a difference to me but the hotfile site and the samfirmware sites are no longer valid.
  20. ayush29k

    ayush29k Well-Known Member

    USB Jig is a hardware device that is used for recovering bricked devices, it does not always work but so far is its the last option. Before that you can try to flash fresh firmware via Odin if you can access download mode.

    Vol down+home+power button starts up the phone in download mode. You don't seem to have any idea what you are talking about, you are mixing up several things, read a bit more, there is lots of information material around, it'll help you sort your phone out.

    A dead phone cannot show up on system as an external device, even a live one needs to be plugged into usb and then the user have to start the storage mode from the phone, only then does the card shows up on the computer.
    If you only want to access your sd card then you can use a card reader.

    Samfirmware shifted to sammobile.com a couple years ago, try that.
  21. daithidearg

    daithidearg Active Member

    I can't access download mode with vol down+home+power. The phone is completely dead.

    I never said that it was showing up as an external device. I just said it was detected.

    It sounds like that USB jig is my only other option.
  22. Trilo

    Trilo New Member

    i have a samsung galaxy ace gt s5830 dat i tried to install jellybean on but i made a mistake by installin CWM in recovery mode before i remembered it was unrooted so i factory reset it to uninstall d CWM but afta d factory restore d fone boots n gets stucked at d samsung mobile screeen. i cnt go to d recovery mode again too but i can go to d download mode..plsssssss anyone can help!!!!!
  23. JKordero

    JKordero New Member

    Hi. Im new here!
    My problem is this
    The code is not showing options.
    Usb charge but not connect to pc
    In recovery mode is not detected the usb port
    In download mode the usb is not detected
    I have try many cables and won't work
    Cclean the port and not luck
    I bought 2 usb ports from ebay hopping this solve the problem.
    Any ideas?

Share This Page