1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[GUIDE]How to update HTC Wildfire S/Marvel/A510e/GSM to Software Version 2.3.5


  1. CafeKampuchia

    CafeKampuchia Well-Known Member

    As indicated by the thread title, this guide is for the Marvel / A510e / GSM version of the HTC Wildfire S. You can check this by going into bootloader as follows: Turn the phone off, pull the battery for 5 seconds, replace the battery, hold volume down and press the power button. You will see a white screen giving the details of your phone's hardware and software. DO NOT TRY THIS GUIDE IF IT SAYS MARVELC / A510C !!!

    It may work if you have an A510b, but it will de-brand your phone and change the model number to A510e. User Realaa was able to do it. Others have bricked their phones. Your call, but I'm not responsible for the results.

    Also, I'm assuming that you're here because you've already tried using HTC's FOTA (Firmware Over The Air) by going to Settings > About Phone > Software updates > Check now with no luck--you're still stuck with 2.3.3.

    Note: You need to have HTC Sync installed but not running. Open Task Manager and make sure it's not there. If it is, kill it. The reason we need HTC Sync installed is for the Wildfire S USB drivers that come with it. Also, make sure that the phone is in USB Debugging mode (Settings > Applications > Development > USB Debugging).


    Some important info and disclaimers:
    1. You must backup your phone's data if it matters to you, as you will be doing a factory reset which erases all user data and cache.

    2. There is a possibility that you could "brick" or bootloop your phone. There are two types of brick: soft (recoverable) and hard (non-recoverable). With a soft brick, the phone will not boot or keeps rebooting ("bootloop"), but it can be started in bootloader mode which allows repair of the ROM. With a hard brick, the phone won't even boot into bootloader after holding the power button for 10 seconds and the phone must be returned to HTC for service.

    Since we're talking about flashing a stock HTC ROM, the odds are slim that you'll brick the phone, but it's possible. Ironically, flashing a stock HTC ROM to a non-rooted phone for which that ROM was created occasionally causes a hard brick. I've seen it happen by running the HTC RUU from Windows as well as flashing manually. I can't tell you the odds. All I can tell you that they are slim. You can minimize the risk by making sure that you do not attempt to flash a ROM not intended for your device (ie, following this procedure with an A510e/MarvelC device).

    3. You proceed at your own risk. I cannot accept responsibility for what you do with your phone.

    Here we go!


    Procedure 1: Try flashing the 2.3.5 ROM normally using the Official HTC RUU

    At this point, we'll be trying to flash a generic/unbranded version of the latest European 2.3.5 from using an official RUU or ROM Update Utility.

    A. Go to JMZ's collection of Marvel ROMs and download RUU_Marvel_S_HTC_Europe_2.26.401.3_Radio_47.23e.35.3038H_7.57.39.10M_release_261695_signed.exe, currently the latest generic European ROM from HTC.

    B. Verify that HTC Sync is installed but not running in the background. Connect the phone to your computer with the USB cable and select "Charge only." Also, make sure that the phone is in USB Debugging mode as indicated above.

    C. Run the RUU...exe downloaded above from Windows.

    D. If the RUU returns errors (and you carefully followed the instructions above), proceed to Procedure 2 below.


    Procedure 2: Flashing the ROM from the SD Card

    Before running this procedure, make sure that your phone's battery is charged above 50%!

    A. Run the RUU...exe again but don't try to update. Instead, find the temporary folder it created to extract the files needed for the install. It will look something like C:\Users\​[LoginName]\​AppData\​Local\​Temp​\​{82B23FCD-D5D0-45CA-A3A2-5350D3926551}. To get there quickly, open Explorer and type %temp% in the navigation bar, then open the folder with the long file name.

    B. Copy rom.zip from that folder to another location on your hard drive and rename it PG76IMG.zip. You can close the RUU wizard now.

    C. Move PG76IMG.zip to the root folder of your phone's SD card.

    Note: If you have a branded phone
    , you must create a "Goldcard" first, and then flash PG76IMG.zip from the Goldcard as follows:
    D. Boot the phone into HBOOT (turn it off, pull the battery for 5 sec. and replace it, hold down volume and press the power button). Once in HBOOT, the phone will find PG76IMG.zip and try to install it. Follow the directions on the screen.

    E. Do a factory reset and reboot.

    If this procedure fails and you ran it with a regular SD card, try running it again using a Goldcard. If that doesn't work, move on to Procedure 3 below.


    Procedure 3: Flashing the ROM manually from a command prompt using fastboot

    Before running this procedure, make sure that your phone's battery is charged above 50%!

    Warning: This is is the riskiest of all the procedures. Be careful to follow the directions precisely and never try this if the ROM you are trying to flash is not for your phone (ie, it's not a Marvel / A510e)!

    Note: For this step you'll need to have Android SDK tools installed.

    A. Run the RUU...exe again but don't try to update. Instead, find the temporary folder it created to extract the files needed for the install. It will look something like C:\Users\​[LoginName]\​AppData\​Local\​Temp​\​{82B23FCD-D5D0-45CA-A3A2-5350D3926551}.

    B. Open rom.zip in that folder with a zip utility as Windows Explorer won't open it. Extract the two files called boot.img and system.img into the folder where you installed Android SDK tools on your hard drive. You can close the RUU wizard now.

    C. Boot the phone into HBOOT (turn it off, pull the battery for 5 sec. and replace it, hold down volume and press the power button). Once in HBOOT, use the volume rocker to mark FASTBOOT and the power button to select it, and attach the USB cable.

    D. In Windows, open a command prompt and navigate to the folder where you installed SDK tools.

    E. Type the following commands:
    Code (Text):
    fastboot flash boot boot.img
    fastboot flash system system.img
    F. After the two files have successfully flashed, go back to the phone (still in HBOOT), do a factory reset and reboot.

    Wallah! [​IMG]

    Any questions or problems, let us know!

    Credits:
    JMZ for his collection of Marvel ROMs
    Lt. Win's tutorial at XDA, [TUTORIAL-UPDATE][S-ON][GSM] Upgrade to 2.3.5
    Theq86's post #194 in the same thread
    D33ps1x's tutorial at XDA, [ROM][HTC][WILDFIRE S A510e][EUROPE][2.3.5][PG76IMG.ZIP] To Flash From Hboot

    Advertisement
    :
    sam22001, rajanzm, yoyoteng and 8 others like this.
  2. quietmoth

    quietmoth New Member

    Hello !..

    ... and thanks for the well written tut'.

    Unfortunately, I've tried every which way and just can't seem to get through to my Wildfire S (Marvel) from Orange France. Sim is unlocked and my actual provider is Free France. I really thought I could switch to a generic ROM and not have that Orange splash screen and those Orange apps, now obsolete...

    First two ways, no luck straight from the start.

    Third way I believed would do it... but nope. This is the message I got :

    [​IMG]

    So, well... so much for that. At least, I didn't break anything...

    Thanks anyway.
  3. CafeKampuchia

    CafeKampuchia Well-Known Member

    Uggghhh. That's brutal. :eek: I've read elsewhere that Orange is really hard to crack.

    All I can recommend is that you try to unlock your bootloader. There is an updated bootloader for Orange FR at htcdev.com (2.14.73.1), so I can't imagine that it won't flash. Once that flashes, the new ROM might flash too.

    + You'll be able to root and upgrade your phone and install a custom ROM if need be to get rid of Orange branding.

    - You'll lose your warranty

    Guide here: [Guide] How to root the Wildfire S A510e GSM with S-ON (finally!)
    quietmoth likes this.
  4. dennis88

    dennis88 New Member

    I tried this for my HTC Wildfire S A510e.
    It was not rooted or anything, and the system update based on check for updates didnt work.
    So I killed the HTC sync first and went into procedure 1.
    I ran the RUU_Marvel_S​_HTC_​Europe_​2.13.401.3_​Radio_47.23 c.35.3037_​7.54.39.28M_​release_236989_​signed.exe.
    It seemed to be working: there was a HTC logo on the screen while it was updating. It finished the operation, said it was successful.
    Then when it was finished it was stuck rebooting.
    I cant go into HBoot either.
    I tried removing the battery, SD card and sim card. Then reinserting the battery.
    But when I tried to start it while holding volume down and the power button, it only flashes the grey screen for 1 second every 3 seconds and doesnt go past it.

    Any ideas / solutions?
  5. CafeKampuchia

    CafeKampuchia Well-Known Member

    Try holding the volume down and pressing the power button for 5 secs. If it boots into HBOOT, you still have hope. Post again and let me know so we can try to get another ROM on your phone successfully. Also, let me know the software version of the last ROM on your phone, if you have it.

    If it won't go back into HBOOT, it's a brick. It's clearly not your fault since the ROM is made for your phone and it updated through HTC's RUU which verifies the software version with the hardware. You should definitely be covered by warranty, especially since you didn't root your phone.
  6. Discocat

    Discocat New Member

    With no sign of an update from Tesco Mobile on my O2 uk A510e I stumbled upon this thread. Method two worked flawlessly. The goldcard was easy to make, and the update has given me nearly 40 megs more to play with!

    Thanks so much for the time spent in putting this guide together.
  7. 974kiki

    974kiki New Member

    I have bricked my phone.

    Does it existe a solution to unbricked it

    HTC Wildfire S

    Thx
  8. CafeKampuchia

    CafeKampuchia Well-Known Member

    Yes, if you can get into bootloader (turn phone off, pull and replace battery, hold down volume, press power button) then there is still hope.

    Tell me what kind of Wildfire S (GSM or CDMA) and what you were doing just before the phone bricked.
  9. Nanoverb

    Nanoverb Member

    Hey, I am new member :)

    Thanks for the well written guide, but I have a couple of questions.

    I have a T-Mobile UK branded WFS and there is still no sign of the update. If I update using this latest ROM from HTC will I lose the branding and will it void my warranty?

    Also I don't have a SD card reader, is there another way of creating a GoldCard?

    Thanks in advance.
  10. CafeKampuchia

    CafeKampuchia Well-Known Member

    Thanks, and welcome to Androidforums!

    I don't know about that and don't want to guess. You might want to call them and find out first if you want to keep the warranty.

    No there isn't. The phone can't do it, nor can you do it with the phone plugged in by USB. Can you borrow one or use someone else's computer? It only takes about 10 minutes to create.
    Nanoverb likes this.
  11. arnie2012

    arnie2012 Member

    Hi their all, I am trying to update my HTC wildfire s on o2 network through the over the air feature, but it just restarts my mobile and the android man and exclamination mark in a triangle appear.

    So i came here but i cannot find that latest rom i need to download, i go onto that website but cannot find it, the numbers are not right or not their

    can anybody hlep please
  12. CafeKampuchia

    CafeKampuchia Well-Known Member

    If your phone is a Marvel/A510e and you are willing to de-brand the phone, the ROM in the guide will work fine.
  13. pattyo321

    pattyo321 New Member

    Hey man,

    Firstly, thanks for the guide.

    I'm having the same issue as dennis88 - said it installed fine but when I tried to reboot it the screen flashed grey every 3 secs. The same thing happens when I try to turn it on again, and I can't get into HBOOT either. I'm using a HTC Wildfire S A510b, I can't remember what software version ROM I had on it before (1.5xx?). Anyway to fix it, or is it bricked?

    Cheers
  14. Zoodroid

    Zoodroid New Member

    My Htc Wildfire S kept saying "variant system software" when I tried to install the latest software update, so I followed the procedure and downloaded "RUU_Marvel_S​_HTC_​Europe_​2.13.401.3_​Radio_47.23 c.35.3037_​7.54.39.28M_​release_236989_​signed.exe"

    I killed HTC Sync and all other app's on my pc and started to install and I could follow the process on my HTC as well as on my pc. When finished appered "Update successful" on the display.
    Then I tried to turn on my HTC, but my screen is blinking and that's the only thing my phone will do!!!!

    Dead telephone!

    Any suggestions?

    What did I do wrong? - and can it be fixed?
  15. Calomax

    Calomax Well-Known Member

    USB SD card readers are extremely cheap from places like Amazon. You can get one for micro SD cards, or a standard one and an adaptor.
  16. CafeKampuchia

    CafeKampuchia Well-Known Member

    Two questions:

    (1) Before you updated, were you certain that the phone is a Marvel/A510e?

    (2) Can you get into bootloader (turn phone off, pull and replace battery, hold down volume, press power button)? If so, then there is still hope.

    I've never heard of the "variant system software" warning. When did it happen?
  17. CafeKampuchia

    CafeKampuchia Well-Known Member

  18. yellowcrown

    yellowcrown New Member

    Hi, I joined the Android Forums to reply to this. First, I had trouble with the RUU.exe as it had the apostrophies, so the PC read the file as ' .exe' '. I had to rename the file to '.exe'.

    I must admit, at step 2A I just updated the phone anyway, the process of updating was fine... but after the 'Congratulations...' etc as I tired to boot the phone all it does is blink grey light every time. Is that bootloop or did I brick my phone? Also, Volume Down+Power buttons won't do any difference either! :/

    Edit: Same problem like dennis, I hadn't rooted yet and rom was version 1.x
  19. Nanoverb

    Nanoverb Member

  20. weerab1981

    weerab1981 New Member

    hi ive got wfs o2 uk. branded pay as you go, heres details from hboot screen
    marvel pvt ship s-on rl
    hboot-0.90.0000
    radio-7.53.39.03m
    apr 8 2011,17:45:10



    tried all steps above but cant get the temp folder anywhere on pc. i have usb debug on but no icon appear on phone when conected to pc. also on charge only.
    can someone upload temp folder please, not sure why it hasnt been already,
    i rooted my wfs with no probs.
    any help please it is slowly getting to me that it wont work as simple as mine...


    thank you
  21. CafeKampuchia

    CafeKampuchia Well-Known Member

    The temp folder is much to big to upload--something like 300MB. You're going to have to find it.

    1. Find your temp folder. ie, C:\Users\[yournamehere]\AppData\Local\Temp\. The AppData folder is hidden so you might have to change settings in Explorer or type it in manually (case sensitive).

    2. Delete everything out of your temporary folder to make the RUU temp files easy to find.

    3. Run the RUU...exe and wait until it has extracted all the files and the wizard comes up.

    4. WHILE THE RUU IS STILL RUNNING, go back to the temporary folder. It will have created two folders. One of them runs the wizard, one is the ROM.

    Hope that helps.
    weerab1981 likes this.
  22. CafeKampuchia

    CafeKampuchia Well-Known Member

    I don't see any compelling reason to try it because I'm rooted with an unlocked bootloader and don't want to go through the entire process of doing all that again.

    But, if you aren't rooted and don't plan too, there is no reason not to upgrade.
    Nanoverb likes this.
  23. CafeKampuchia

    CafeKampuchia Well-Known Member

    Can you confirm that your phone is a Marvel and not a MarvelC? You can tell by booting into bootloader: Power down the phone, pull the battery and replace, hold down volume and press the power button. Let me know all the data on the top of the screen.

    If you can still get into bootloader then the phone is soft-bricked and can be recovered.

    Edit: Also tell me what software version you upgraded from if you can.
  24. irishstevo

    irishstevo Member

    When I click the link to downlaod "RUU_Marvel_S​_HTC_​Europe_​2.13.401.3_​Radio_47.23 c.35.3037_​7.54.39.28M_​release_236989_​signed.exe", I get:
    [​IMG]
  25. CafeKampuchia

    CafeKampuchia Well-Known Member

    Yeah, that happens from time to time. Google the filename and try to get it from another source.

    RUU_Marvel_S​_HTC_​Europe_​2.13.401.3_​Radio_47.23 c.35.3037_​7.54.39.28M_​release_236989_​signed.exe
    irishstevo likes this.
Loading...

Share This Page