[Guide] Move more (most) apps to SD without root (Simplified)Tips


Last Updated: 2014-08-27 19:37:56
  1. SUroot

    SUroot Well-Known Member Developer

    Internal memory will still go down.

    Advertisement
  2. DesireMe

    DesireMe Well-Known Member

    Ah man! Am i being a ****** here. I set this up to force to SD months ago without issue. I now can't seem to resort back to normal, prior to rooting.

    Says:
    > Daemon starting. Error: Cannot find device.
  3. DesireMe

    DesireMe Well-Known Member

    Think i need to come back to this tomorrow. Nothing is working and i've hardly any hair to pull out anyway. I start HTC Sync and connect the phone via USB, select HTC Sync and it wont connect. :(
  4. SUroot

    SUroot Well-Known Member Developer

    you dont need to run htc sync. It just needs to be there for the drivers. Ensure you dont have any other applications running that use adb (Myphone explore for example)
  5. DesireMe

    DesireMe Well-Known Member

    I removed all widgets and closed all programs and it magically worked! Install set back to 0....rooting here we go! :)
  6. sheddie

    sheddie New Member

    works for me , thanx alot , will think about rooting now
  7. D-X69

    D-X69 New Member

    I just bought a HTC Chacha with the android ver2.33.. Does this works on 2.33??
  8. SUroot

    SUroot Well-Known Member Developer

    :p
  9. D-X69

    D-X69 New Member

    what does that imply? The TS only mentioned it doesnt work for 2.1 and it should work for most 2.2.. what about 2.3?? or does the + means 2.2(above)?
  10. SUroot

    SUroot Well-Known Member Developer

    Yes 2.2+ means 2.2 and anything newer.

    Like a restaurant would only take table bookings for 6+ people.
  11. Good Old Bakes

    Good Old Bakes Well-Known Member

    Thanks SUroot. It worked a treat. :cool:

    Pity that Maps and Flash can't be moved but never mind...
  12. BigRichG

    BigRichG New Member

    "Double click the zip file once downloaded and drag the "android-sdk-windows" folder (contained within) to your C: drive"

    I can't find that folder in the downloaded zip file. Anyone able to help?
  13. SUroot

    SUroot Well-Known Member Developer

    Youre downloading from the dropbox link? What is in the .rar file?
  14. SUroot

    SUroot Well-Known Member Developer

    Maps and flash are not taking up space, except their updates. Unfotunately there is nothing that can be done about this unless you want to root.
  15. BigRichG

    BigRichG New Member

    There are 20 files - 9 .exe, 2 x .txt, 2 x .dll, 6 x .bat and 1 x source.properties file.
    No folders.

    Not sure how to do a screenshot, otherwise I'd add it here?
  16. SUroot

    SUroot Well-Known Member Developer

    Dont know what you're doing wrong, but I just downloaded it from link 2 and is the .rar file.

    Inside the .rar is then 1 folder called android-sdk-windows and 1 txt file called readme.txt

    Inside android-sdk-windows is another folder called tools. Inside there is what you describe. Are you using winrar?

    To do a screen shot, just press print screen.
  17. bbkpro

    bbkpro New Member

    Aah! worked like a charm! i've gone from having 45mb free to having 125mb!

    thanks a lot for this guide ;)
  18. jimmy jones

    jimmy jones Member

    Any solution to accessing SUroot's drop box? At the moment all I get is "
    Error (509)

    This account's public links are generating too much traffic and have been temporarily disabled! "


    Need to free up some space on my phone and struggling a bit at the moment.

    tx
  19. SUroot

    SUroot Well-Known Member Developer

    Just got to wait 3 days until the links come available I am afraid.
    jimmy jones likes this.
  20. jimmy jones

    jimmy jones Member

    For an impatient person, that's a long time :), but many thanks for the reply and I'll give it a whirl on Monday.

    Tx
  21. jimmy jones

    jimmy jones Member

    Accessed today and after a bit of head scratching and pushing in the right direction the end result was achieved.
    SUroot likes this.
  22. Smantha88

    Smantha88 New Member

    after i type adb shell and enter it says error: device not found
    azabagaak33 likes this.
  23. breffniboy

    breffniboy New Member

    Yep...same problem for me, it doesn't matter what mode I select to connect to the PC with, I still get the device not found message.

    I have also tried it with USB debugging both ticked and unticked, it makes no difference I'm afraid.

    Edit: I got it working just now, I had made a bit of a bags of the htc sync part. All is well now. Thank you so much SUroot, I've moved some games to my SD and can take full advantage of my 32gb card now!
  24. simon1

    simon1 Well-Known Member

    OK - I am trying to do all this but I obviously need help. I need to point out that I am doing this on a Mac which is running Windows within a virtual environment (Parallels). Does this make a difference?

    All of the following were done on the "windows" machine:

    I installed HTC Sync

    I extracted the rar files and moved the folder named android-sdk-windows into the C drive

    I am NOT running HTC Sync - as recommended in an earlier post.

    When I plug in my phone, I connect it to the Virtual machine ("windows") and not the Mac, and this machine does see the phone.

    I get the same problem of "error: device not found" when typing in adb shell.

    BTW - I followed the instructions in the readme file and changed the path. I have no idea what it has done but I still need to use cd when typing in "cd c:\android-sdk-windows\tools" and I have no idea what all the other stuff means about adb and fastboot. It's all Greek to me.
    azabagaak33 likes this.
  25. simon1

    simon1 Well-Known Member

    Right - problems all sorted and it works!!

    I THINK the reason I was having problems was that although I had closed HTC Sync, I noticed that it was still in the system tray on the bottom right. I closed this, then ejected my phone, restarted it to make sure everything was reset from scratch again and then went thru the instructions one more time. This time, instead of the 'device not found'. I got the $ sign and now I have moved stuff across with no problem. I now have 37mb free after flirting around the 15mb stage for ages.

    I can't thank you enough!! This has given my phone a new lease of life without rooting, which I am far too scared to do and only thought about it to allow me to move these things to the SDcard. :);):D:D:D

    Just a note for others, if you do this then you will need to restart manually certain apps that would normally restart when you restart the phone. In my case things like Swype and the Battery Indicator have to be manually restarted however since I hardly ever switch the phone off it's not a problem.

Share This Page