[Guide] Move more (most) apps to SD without root (Simplified)Tips


  1. SUroot

    SUroot Well-Known Member Developer

    These apps should be moved back to phone.
  2. simon1

    simon1 Well-Known Member

    Well, the way I found your guide was to Google about Swype and it not being able to be installed on the SD Card. It and the Installer are quite large files. So I don't want to put them back! It all works fine the way it now is and I turn my phone off maybe once every few weeks so no huge problems.
  3. SUroot

    SUroot Well-Known Member Developer

    All I'm saying is technically, as the sd card mounts last in the android boot sequence, any apps that run automatically on start up or have lockscreen widgets should remain on NAND.
  4. simon1

    simon1 Well-Known Member

    Good point and I have moved a couple of small apps back as they didn't like the SD card.
  5. hecass

    hecass Member

    I have successfully done this. It took 2 attempts. Worked great!
    If you have any problems and you are using Windows and Android version 2.2:
    1)You have downloaded and installed the Android SDK (you may be prompted to also download and install the Java SE Development kit)
    2)Run the SDK manager program, find in the left column Android 2.2 (API 8), check mark SDK platform, then "click" install packages on lower right.
    3)Make sure you have enabled USB debugging.You can turn this off when you are finished.
    4)The new path to adk is C:\Program Files\Android\android-sdk\platform-tools (this is the default setup path to the adk)

    Hope this helps anyone who has had problems.
    Radar10 likes this.
  6. SUroot

    SUroot Well-Known Member Developer

    You really shouldnt need anything out of the SDK that isnt provided here.
  7. ritanguyen167

    ritanguyen167 Member

    Hi
    This works on HTC Wildfire S, but I still cannot move Facebook, Yahoo Messenger to SD Card (I can move Google Reader, Google Docs, etc.). Any advice?
  8. yalnet

    yalnet New Member

    This has put new life into my Desire, worked perfectly... Thanks for the info.

    If it would give anymore room for programs, is there anyway to move the cache onto the SD card with a non rooted Desire running 2.3.3 off the HTC dev site.

    Just trying to squeeze as much as possible into the phone !!

    Cheers

    Phil
  9. SUroot

    SUroot Well-Known Member Developer

    Yep, read the title of the thread ;)
  10. SUroot

    SUroot Well-Known Member Developer


    App cache?
  11. Radar10

    Radar10 Member

    I just finished working my way through the 12 pages of the thread which lead to this one, and now through these two pages. I noted that several times Mac users asked how to do this on a Mac and, with the exception of the Mac user who used a Windows emulator, no one responded.

    Nevertheless, I downloaded the Mac versions of the SDK and the separate folder that contains adb, and I tried repeatedly to follow the instructions in Terminal on the Mac, using what I believe to be the Mac syntax. I think I used the right path to get adb to run, because all the adb examples pop up in the Terminal window, but then nothing happens to my connected LG Optimus to change anything.

    I have USB debugging turned on, but even when I run adb devices as a test, nothing happens, suggesting to me that my Mac is not seeing the connected LG, which runs 2.2.1.

    Any help or advice would be greatly appreciated, as I spent last night and all afternoon trying this over and over out of determination to succeed, and am feeling defeated at this point.
  12. SUroot

    SUroot Well-Known Member Developer


    Cant help much with macs as I hate them with a passion but Mac Os is loosley based on Linux (which i DO use)

    In Linux you would drop the adb file (attached) into /usr/bin. Then from a terminal, you dont need a path to type "adb devices". How compatible this adb file and instruction is with mac, I dont know.

    Also, FYI on linux, if I type "adb devices", I still get:

    Code (Text):
    1. dan@laptop02-Ubuntu:~$ adb devices
    2. List of devices attached
    3.  
    4.  
    Then just a blank line where no devices are listed. So if you're not getting the words "list of devices attached" I dont think adb is working properly.

    Hope this partly works. If not, try using a proper computer ;)

    Attached Files:

    • adb.zip
      File size:
      156.6 KB
      Views:
      3
  13. Radar10

    Radar10 Member

    A suggestion to eliminate any confusion caused by the change in where the tool folders are located:

    If you want to be absolutely sure you've got the path right, open up the folder contain the adb icon, then copy the path. If on a Mac, use Command-I to get the info window and select and copy the full path up to and including the folder in which adb resides, then paste it into the Terminal window.

    On a PC, which doesn't accept pastes, just keep the folder/window containing adb located above the DOS cmd window, so you can look directly at the url above as you type it into the cmd window.

    Also, look at the directory location already in the cmd window before typing. If it already contains the C drive, leave that off after typing cd to change the directory. Don't send it back that far.

    Just my take.
  14. SUroot

    SUroot Well-Known Member Developer

    I actually supplied windows files with this guide that eliminates the issue on windows by giving you the original folder structure and also the instructions to add it to environment variables, which also means path is irrelevant.

    If you want to supply me known working adb and fastboot files, I could host and link to that too...
  15. Radar10

    Radar10 Member

    Yes, that was a great thing for you to do. But many people are coming to your thread from other subforums here on Android Forums (in my case the LG Optimus V subforum) and they have already downloaded the Android SDK etc. files to their computer but are still stuck (as I was).

    They won't necessarily re-download from your package, but may start off in the middle of your instructions.

    If you think it is better to avoid concerning oneself with the path issues created by Android having moved the location of the adb file and enclosing folder after threads elsewhere were started, perhaps you might want to consider revising your instructions to begin by telling them to delete all the SDK stuff they already downloaded based on advice in other threads and subforums; and start from scratch. Otherwise, many are likely to pick up your instructions from where they left off following advice received elsewhere. Just human nature.
  16. SUroot

    SUroot Well-Known Member Developer

    It's five steps. You should see the older threads.
  17. cansoko

    cansoko New Member

    doesnt work

    I followed the steps and i entered all the command prompts and got to the final part where it shows the " $ " from there nothing happened.

    when still connected. i tried to move apps with apps2sd and nothing showed up even thow i know there are apps on my phone that i installed that cant move to sd card which i was told could be moved

    also tried to install monopoly classic which only installs to the phone and it would let me install to SD card.

    anyone know why this program doesnt work?
  18. mobiletech88

    mobiletech88 New Member

    My phone is HTC desire version 2.2 , I've been using it for a year. Finally found this solution, Yes, I just follow the 5 steps and it's done. Awesome, able to increase memory from 15mb to 35mb. Thank you very much.
  19. SUroot

    SUroot Well-Known Member Developer

    Nope. You've supplied zero useful information or screenshots.
  20. SpecBxl

    SpecBxl Member

    Well, I tried it today after struggling with approx. 20 MB of memory for months, I didn't have any problem with the CLI (or at least I didn't receive any errors, my device was recognized etc), I turned my phone off and back on but when I tried to install something from the market it just installed directly to the internal memory and I had to manually move it to the SD.

    I tried the procedure once more, I downloaded a couple of apps but still the default install location was the phone memory.

    My phone is an one-year old unrooted HTC Desire, running 2.2.2 after the latest official OTA update (2.29.405.14). Could this update (quite a long shot I think) be a reason for my status?

    As for the phones in which the trick actually works, when a new app is installed does it still takes a big chunk of internal memory (essentially the same part as if it would be installed to the phone and then moved to sd) or it's much smaller?
  21. SUroot

    SUroot Well-Known Member Developer

    Its the same amount of space as if you manually moved it. What would be interesting is to fi9nd out apps you couldn't previously move can now be moved. Maybe worth downloading apps2sd from the market to see how many apps it finds. to be honest, this trick is a bit crap. Rooting is a much better solution.
  22. cliff0796

    cliff0796 Well-Known Member

    Wont let me put a screen print on here saying it's to many letters??

    Anyway I have got trough the 1st command prompt ok but when I put adb shell it says

    Error device not found.

    What am I doing wrong cause it has excepted the 1st prompt so I must have downloaded the winzip file ok..

    Thanks in advance.
  23. SUroot

    SUroot Well-Known Member Developer

    device not found means your phone is not being recognised. Check the usb connection. Does HTC sync recognise it?

    Not sure what you're on about screen prints and letters. You would need to upload it to photobucket, imageshack etc and paste the link from there into the post. But we dont need it for this anyway
    cliff0796 likes this.
  24. cliff0796

    cliff0796 Well-Known Member

    It was connected but not HTC Sync, connected it and it worked fine, thanks for your help.

    Can this also been done on a Archos 101 Tab?

    Happy New year folks.:):)
Loading...

Share This Page