[GUIDE] Re-flash stock ROM (RUU) after bricking a rooted device


Last Updated:

  1. CafeKampuchia

    CafeKampuchia Well-Known Member

    Before you start, you will need to set up your computer to properly recognize the phone. You probably did this when rooting originally, but just in case... Install SDK tools for Android, Java runtime, and HTC Sync.

    About HTC Sync: The only reason you need HTC Sync installed is for the USB drivers that come with it. But the program itself has been known to cause conflicts. Make sure that HTC Sync is not running in the background by opening Task Manager in Windows and killing it if you find it lurking in there.

    Here we go:

    1. Download the correct RUU (ROM Update Utility) for your device from androidfiles.org. Make sure you download a Primo_C RUU for a CDMA device (no sim card) or a Primo_U RUU for a GSM device (uses a sim card)!! Also make sure you get the correct RUU for your carrier.

    2. Charge the battery above 50% or for at least one hour. If the battery dies during the flashing process, you could hard brick the phone!

    3. Run the RUU until the wizard comes up. While the RUU wizard is open, find the temporary folder it created. (Open Explorer in Windows and type %temp% in the navigation bar.) There will be two folders with long encrypted names. In one of them you will find ROM.zip. Open it with 7zip and extract recovery.img or recovery_signed.img. Put it in the location were you've installed Android SDK tools. This is the stock HTC Recovery and it is needed to run the RUU.

    4. Boot the phone into bootloader (power off, hold down volume and press power) and highlight FASTBOOT using the volume rocker and pressing power. Then connect the USB cable. You should see FASTBOOT USB.

    5. Open a command prompt in Windows and navigate to the folder where you installed Android SDK tools. Flash the stock recovery extracted in step 3 above using the following command:
    Code (Text):
    1. fastboot flash recovery recovery.img
    or
    Code (Text):
    1. fastboot flash recovery recovery_signed.img
    6. Relock the bootloader using the following command:
    Code (Text):
    1. fastboot oem lock
    7. Re-run the RUU. It will restore the device to it's original condition, locked (though *** RELOCKED ***) and unrooted.

    Once the install is done you'll have unlock the bootloader again using the token you already have from the first time, reflash CWM Recovery and re-root. All this will be 10x easier than the first time.

    If you do re-root your phone, be 100% you backup the stock ROM in ClockworkMod Recovery before making changes!

    Advertisement
  2. antraz101

    antraz101 New Member

    Noob question but how do i know what ruu to use my bootloader says
    Primou pvt ship s-on rl
    hboot-1.16.0000
    radio-3831.15.00.19_m
    emmc-boot
    mar 13 2012,20:17:28

    EDIT: figured it out thanks for all the help
  3. andruoid

    andruoid Well-Known Member

    There 'could be' a potential issue with Telus users. It could also be me as well so let me know. ;)

    Coming from stock without the resent OTA (34MB) update I was able to unroot and apply the Telus RUU. Software version: 2.08.661.1

    The OTA updated the Software version to 2.22.661.2. When I did try to unroot after applying the OTA I got a message on the bootloader screen;

    RUU
    Hboot Version is older!
    Update Fail!


    My hboot was 1.17.0000 and is now 1.18.0000

    Any work around for this?
  4. freakyfreak

    freakyfreak Member

    Okay i'm on Alltel and have the HTC One V CDMA, so if I wanted tyo perform a unroot and relock and all that, what RUU from the one link on page one will I need?
  5. CafeKampuchia

    CafeKampuchia Well-Known Member

    You can wait for the next full RUU to be released or try flashing the boot and system images manually.

    Before trying this, make certain that the RUU is right for your phone!

    Run the RUU...exe again but don't try to update. Instead, find the temporary folder it created to extract the files needed for the install. It will look something like C:\Users\​[LoginName]\​AppData\​Local\​Temp​\​{82B23FCD-D5D0-45CA-A3A2-5350D3926551}. To get there quickly, open Explorer and type %temp% in the navigation bar, then open the folder with the long file name. You'll find a file called ROM.zip in there. Open it with 7-Zip (Explorer won't open it) and extract boot.img and system.img.

    Then flash them manually as follows:

    Code (Text):
    1. fastboot flash boot boot.img
    Code (Text):
    1. fastboot flash system system.img
    Hope that helps!
  6. CafeKampuchia

    CafeKampuchia Well-Known Member

    Freakyfreak, welcome to Android Forums :hello: I moved your post to a thread more relevant to your question.

    If there is no Alltel RUU, you might be able to flash an RUU for another CDMA carrier like Sprint. But you'll get the special features and bloatware for that carrier.
  7. andruoid

    andruoid Well-Known Member

    Thanks for the instruction CafeKampuchia however, this is what I get when trying to flash the system.img

    C:\fastboot>fastboot flash system system.img
    sending 'system' (817148 KB)...
    FAILED (remote: data length is too large)
    finished. total time: 0.013s
  8. andruoid

    andruoid Well-Known Member

    Also tried grabbing the ROM.zip, renaming it to PK76IMG.zip and putting it on the SD card. Still no luck,

    RUU
    Hboot Version is older!
    Update Fail!

    re-applying the RUU doesn't seem possible unless I'm missing a step somewhere.
  9. freakyfreak

    freakyfreak Member

    Okay, I've done a bit of research, and the SPrint RUU has different Radios than Alltel, Alltel uses radios ending in .524_2 and Spring uses .521, both are similar radios, but are not the same, so how will this affect my device?
  10. CafeKampuchia

    CafeKampuchia Well-Known Member

    It looks like the RUU you are trying to apply is not right for your phone. I'd double check.

    It's hard to tell from the numbers what is different, hardware, software or both. I'd be hesitant to try until I knew.
  11. andruoid

    andruoid Well-Known Member

    It's definitely the right RUU as it worked before. The reason it's not now is because I unrooted, applied the same RUU, applied an official OTA update (34MB), then unrooted as there was no major difference, then unlocked again, applied a custom ROM and wasn't happy with it so I decided to lock it back up and run the RUU again.

    I noticed that the HBoot was 1.17.00 before the OTA update and now it's 1.18.00.
  12. jtragna

    jtragna Well-Known Member

    Can you do this to working phones or semi-bricked devices...such as mine...please....please help me....please......
  13. CafeKampuchia

    CafeKampuchia Well-Known Member

    Jtragna, if you can boot the device into bootloader it should work for you. What state is your device in?
  14. davidedavide96

    davidedavide96 New Member

    hello, can i do these operation also if my one v is bricked with a custom rom or only if it's bricked when he has an original rom?????? thank you
  15. nannycrick

    nannycrick Well-Known Member

    Thanks LOADS for this guide. I soft-bricked (bootlooped) my baby trying to fix a bad flash of a kernel to go with my rom, JMZOneV v4. Had issues with the WIFI anntenae that wouldn't work. I'm going stock odex (rooted) from here. I owe you my thanks again!!


    p.s After factory reset, go back into HBOOT recovery, then into HTC Dumblock (in recovery under Advanced). restore orig boot.img & restore recovery. Flash both.
    (not at the same time). re-install stock rom odex. or deodex. flash that. go back to
    adb to re-lock bootloader. Once relocked, go back into HBOOT. choose fastboot.
    (it will enable the USB connection).
    Run this RUU per instructions. (locking the boot stopped the bootloop. re-entering HBOOT Fastboot to enable the USB connect will give RUU a chance to do it's magic). Keep a copy of the stock rom on your sd card in case your restores don't work for you. This is how I did it. (remembered to do ALL software updates before unlocking again). Love this forum!!!
  16. andruoid

    andruoid Well-Known Member

    RUU_PRIMO_U_ICS_40A_TELUS_WWE_2.22.661.2 is now available at FileFactory Folder View - Primo

    If you installed the official OTA update on the Telus One V it also upgraded the HBOOT from 1.17 to 1.18. If you rooted after applying the above there was no way to unroot and go back to factory, until now. 8)
  17. Zombie591

    Zombie591 Well-Known Member

    Okay, I bought my HTC One V Friday. I got it stuck in a bootloop, so I flashed my reovery that I made right after I rooted. Now it won't boot past the HTC screen, and to fully power down I have to shut down through the boot loader. I Have no idea if it's charging (I know it won't in the boot loader or recovery. it's off right now and plugged in but my light isn't on? My LG had a light that stayed on. never charged this off, so idk) So, anyway I'm kinda scared about trying this right now... Any suggestions? And my CMW is saying ext_sd.img is missing?
    Any suggestions?
  18. Zombie591

    Zombie591 Well-Known Member

    Also, my phone downloaded and booted a kernel right before this problem started. (This was not me) but yeah, could that be the problem? I'm new to all this and trying to learn...
  19. Zombie591

    Zombie591 Well-Known Member

    I got it all working right now.
  20. MarkyMac

    MarkyMac New Member

    I cannot get RUU to run at all.
    Original problem is after unlocking & rooting & running for a month, I tried putting CM10 on it.
    Now it loops upon boot.

    Virgin Mobile HTC One V
    HBOOT 1.53.0000
    RADIO 1.00.00.0928

    I see ADB device but only when unlocked, when I lock & try to use the RUU it fails with USB error, everything USb works, flashing boot, recovery, oem lock, unlock, etc.
    I have spent the last 2 FULL days on this, I would even go back to stock if it doesn't reboot :-(.
  21. Zombie591

    Zombie591 Well-Known Member


    The RUU is gonna put you back at full stock anyway. I had the same problem when I had to run the RUU when I bricked my phone. Let it start running then minimize it. Open file explorer on your desktop and find the folder the program made. Search recovery when you open file explorer (instructions on here say \data\ but that didn't show it for me.) The file will be recovery_signed.IMG and you're gonna need to flash that via fastboot for the RUU to run properly.
    fundriod likes this.
  22. Zombie591

    Zombie591 Well-Known Member

    If I remember correctly lol I haven't messed my phone up since around Christmas. But the directions above are all right. It's just hard to find that recovery IMG.
  23. jaredl45600

    jaredl45600 New Member


    the 1.00.00.0928 radio is causing the bootloops. you need to run the ruu to get a different radio version then you can custom rom all you want.
  24. Zombie591

    Zombie591 Well-Known Member

    Today was the third time I've had to use this... TWRP 2.3 wouldn't read my sd card after a full wipe... So I had no OS and no way to flash without that card... CWM Wouldn't read it either... :/
    I Just wanna say thank you again for these links and the amazing help I've gotten from some of the guides here in the past!
    CafeKampuchia likes this.
  25. eloreche

    eloreche New Member

    i think my phone is brick. because after i install custom rom it loops on boot up screen.

    here's the detail of my phone

    PRIMO PVT SHIP S-ON RL
    HBOOT-1.18.0000
    RADIO-3831.19.00.120
    eMMC-boot
    jul 2 2012, 20:51:45

    what is the right RUU for me because im confused i cant see HBOOT with Radio no. in the List of RUU.... please help...thanks alot

Share This Page