[GUIDE] ROOT and CWM Recovery for Impulse 4G


  1. waterduffalo

    waterduffalo New Member

    ROOT for AT&T Impulse 4G (Huawei u8800-51)

    NOTE: I take no credit for SuperOneClick, or the actual guide. I simply found it, simplified it, and reposed here. Thanks goes to CLShortFuse for SuperOneClick, and all the members at XDA-Developers, specifically in the Huawei Ideos x5 forum.

    Also, I am not responsible for any bricked devices, loss of data, zombie infections, Rage fits, or thermonuclear warfare caused by this guide. Oh, and also, if you succeed, your warranty is now void. PLEASE follow the instructions to a T.


    This guide is for Windows PCs. I don't have any guide for Linux or Mac, sorry.



    This guide will teach you how to root and install ClockWorkMod Recovery your AT&T Impulse 4G, also known as the Huawei Impulse 4G.

    PRE-ROOT REQUIREMENTS:
    Put the device in ADB mode (Settings\Applications\Development\check USB Debugging)


    STEP 1
    Plug device into computer and let the drivers install.
    CHECK to make sure the ADB driver installed (Right click "Computer" and click Manage, and click Device Manager) If 'Ideos' is in 'Other Devices', you will need to start at Step 2. If 'Android Composite ADB Interface' shows up in 'Android Phone', you are good to go to Step 3)

    STEP 2 (Ideos in Other Devices)
    When the device was plugged in, 'CD Drive (E:\) Mobile Partner' should have popped up for AutoPlay. If it did not, check 'Computer' to see if it has. If it hasn't, unplug the device and plug it back in. Once it shows up, go back into Device Manager from Step 1 and right click 'Ideos' in 'Other Devices' and select 'Update Driver'. Click on Install Driver Manually instead of Searh Online and browse to E:\drivers. This will install the ADB drivers needed to root.

    STEP 3 (ADB Drivers Installed, now to root)
    Now that your device has ADB drivers installed and working, download SuperOneClick v2.1 from http://forum.xda-developers.com/attachment.php?attachmentid=674200&d=1312258565
    Extract all the files into a folder, and run SuperOneClick with Admin permissions (right click SuperOneClick, select Run as Administrator)
    After SuperOneClick opens, simply click the 'Root' button on the top.
    NOTE: It may freeze up a few times, as if it stopped responding. That is normal.
    As it goes through its process, it will eventually stop and tell you 'busybox is not installed. Install?' Hit yes, and yes to all the other prompts. At the end, it will tell you that your device is now rooted. TA-DAAAAA. Reboot your device and the root is complete.

    STEP 4 (CWM Time)
    Download CWM here
    http://forum.xda-developers.com/attachment.php?attachmentid=741968&d=1317928514
    Turn the device off, and press and hold Volume Up, Down and Power buttons simultaneously. The AT&T logo will pop up, and then a pink-purple screen will pop up over it. Plug the device into your computer and let the drivers install. A popup may tell you some drivers didn't install, that's ok. A single, unnamed Removable Storage device will come up; open it. Take the 'recovery.img' file in there and rename it to 'recovery-backup.img', then copy the recovery-clockwork-5.0.2.6-u8800.img' to the storage device. Rename it to 'recovery.img'.
    IMPORTANT: Make sure to 'Safely Remove Device' before unplugging!
    After unplugging, remove the battery and reinsert it, and hold Volume Up and Power buttons to boot into CWM.

    There you have it, Root and CWM. I've begun toying around with ROMs, I will try to port CM7.1 to this device, along with a customized, clean version of the stock ROM. Enjoy!

    WaterDuffalo

    Advertisement
    :
  2. yogi-4

    yogi-4 Well-Known Member

    Rooting worked great!! Thanks. I installed CWM per your directions... all I get is that pink screen. No words no nothing. I'm very formiliar with recoveries and ROMs (I even wrote a how to for the Optimus V) but this is nothing like that CWM. Am I missing something??
    Also, hows that port for CM7.1 coming along??
  3. yogi-4

    yogi-4 Well-Known Member

    Never mind. I read it too fast. Only the volume up and power buttons are to be pressed.
  4. Pneuma22

    Pneuma22 New Member

    Kaspersky says its linuxlooter...Has anyone taken a look at the "superoneclickroot".exe who made it for instance and wheres the code? Linuxlooter is a common linux virus meant to grab banking information specifically... Could be using the same type of code to grab things and take ahold of an exploit but none the less uncool!...
  5. Peluche15

    Peluche15 New Member

    after rooting impulse 4g can be use for a 3g data plan or i still need to get a 4g plan?:D
  6. zgmc4

    zgmc4 New Member

    When trying to update the drivers I can't access E: :eek:

    I first put the phone in debugging mode, then checked the device manager. Ideos was listed under others. I tried to update the driver from E: but it simply says to insert a disc. I checked under my computer and E: never shows Mobile Partners. I disconnected and reconnected phone several times to no avail.

    Am I missing a step?

    Running windows 7

    Thanks
  7. jentrym2001

    jentrym2001 New Member

    After installing the cwm file on the device i pressed up and the power button and all i get is a blue screen. also when i turn on the impulse 4g all i get is the blue screen. Could someone please help with this ;) would be greatly appreciated. Did i do something when copying the file on to the device?
  8. JohnSweat

    JohnSweat New Member

    Ok so I had an android but when I got an upgrade I change to an iPhone. Then I found out you can get somethings on an android without even rooting that you would have to jailbreak to get it on an iPhone. I thought that if I had wifi Id be able to at least connect to the Internet with the phone but with out its service it can't even connect to wifi. Is there any way anyone knows of that will allow me to connect to wifi without having phone service on the android.
  9. Andrew lewis44

    Andrew lewis44 New Member

    I was downloading superoneclick to root my impulse 4g. After it was down loaded my anti-virus deleted cause it contained a virus. it might explain someone else blue screen.
  10. rudyheartless

    rudyheartless New Member

    My computer cashed a few days ago and ive been trying to get the stock img files (recovery) (boot) my friend gingerbread on it and my phone keeps loosing service i cant take it before he did that i had this on it and i want to restore my impulse 4g u8800-51 so i can have this on it again i hope some one can help me m on att and have 4g and i dont want to keep this phone the way it is pleaseeeeeeee help
    you can email me at rudyheartless @ gmail .com
  11. mrsythao88

    mrsythao88 New Member

    mine did the exact same thingcan any help plez????????????????????

    willyb2026 likes this.
  12. twf498

    twf498 New Member

    I've successfully rooted, apparently. I didn't think I'd need CWM. So, I'm wondering if I DO need it, to be able to remove preloaded bloatware, unusable AT&T apps, etc. If I don't need CWM, how else may I accomplish this?
Loading...

Share This Page