1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Guide: Root and install ClockWorkMod custom recovery on LG P690 (Optimus Net / Link / Spirit)


  1. meet5000

    meet5000 Well-Known Member

    As you like :)
  2. GlenNeedsHelp

    GlenNeedsHelp New Member

    I have found another (easy) way of changing the LG P690F Bloatware from Au Telstra by installing Indian Version Rom V10E (requires PC) which is basically all I wanted to achieve. I had no luck performing the series of actions to achieve the mod in this thread, the V10E version is a stock rom and in english so all works perfect.
  3. mephiska

    mephiska New Member

    So I've rooted my LG Optimus Net, and I followed the directions exactly. The MD5 sum checked matched up, and I did the copy/paste steps one by one. Nothing out of the ordinary.

    But I can't seem to get into recovery. After the "reboot recovery" command the phone reboots and seems to hang on the LG logo screen. If I remove the battery and reboot the phone comes back up normally. I downloaded quickboot and tried that, same thing - LG logo, have to remove battery to get out.

    Am I missing something here?

    Edit: So I foolishly tried to just do a factory reset of it - now it can't get past the LG screen at all. Yay!
  4. meet5000

    meet5000 Well-Known Member


    What the hell have you done!?
    I've given a warning: DO NOT use phone's built-in option of factory reset option, as it will brick your phone!
  5. mephiska

    mephiska New Member

    Oh well. I just bought it two days ago so I'll just take it back to the store.
  6. meet5000

    meet5000 Well-Known Member

    That's nice.
    Go but don't tell them about your tweaks!
  7. harishkunal

    harishkunal Member

    @Admin:

    Thanks a lot for this walk-through.. I have successfully rooted my LG-P690!

    But I face several problems with the phone now.

    1. My phone hangs when I get calls (The screen is blank and it takes it forever to display the caller information and the option to answer the call.)

    2. I downloaded DroidSail Super App2SD.. thanks to this app, I was able to generate upto 50MB of free space..
    But it does not always transfer apps. For certain apps, it displays the msg
    "Make sure you have ROOT access and enabled Root Debugging"

    My phone is definitely rooted and the Root Debugging mode is activated, still these apps do not get transferred to the SD Card.

    Can you please help me?

    Thanks.
  8. Dumbastard

    Dumbastard New Member

    Thanks for the work you did on this I followed the instructions and achieved root access. I got a little frustrated with the message the 'Error message' until I read the bit about ignoring that. It worked a treat. I have the LG P690f model.
  9. meet5000

    meet5000 Well-Known Member

    I'm glad that you succeeded using my guide.
    I'd always recommend you to read before doing experiments on your Android.
    Just read, read and read, read as much as you can.

    I also followed some guides over here and on XDA. Then I succeeded and became able to create a proper guide for LG P690 users.

    Best of luck for the future. :)
  10. meet5000

    meet5000 Well-Known Member

    Actually I'm not Administrator, I'm only a junior member :)

    For your first problem, I'm not a full Android expert (for now, but will be).
    Other experts may be able to help you. You can create a Thread on this topic, so everyone can read about your problem. Personally, I've never faced any problem after rooting.

    For the second problem, are you trying to move system apps to the SD Card?
    Have you allowed the Superuser permission to the App2SD app?
  11. meet5000

    meet5000 Well-Known Member

    I think you're trying to move the recovery.img in the Android file system.
    But you have to move it to the SD Card but not in any folder.
    Got it?

    For MD5 Sum, you must use Root Explorer.


    Good luck!
  12. jonathan589

    jonathan589 New Member

    I have followed the rooting procedure and at some steps and things are not going as expected.

    Computer:
    - OS: Win XP SP2

    Phone:
    - LG Optimus Net p690b
    - Android v2.3.4
    - Kernel v2.6.35.10-perf
    - Build # GRJ22
    - Software version : V10i-JAN-19-2012

    Unexpected behaviors:
    Step 6: The phone does not ask to 'Turn on USB Storage'. I don't know if the phone automatically "Turn on USB Storage" or not. On step 5, the "Mass storage only" is already unchecked.

    Step 7: Start button > All programs > Unlockroot (folder) > Unlockroot (app) and as a result, no GUI appeared. After many attempts, once in a while, a dialog box can appear. The text is only squares as if it was unrecognized special characters. If I don't press the ok button the dialog box may eventually disappear.

    I don't know how i can go further from here.

    When searching on google, I have found the Superoneclick 2.2 method.
    "adb devices" shows the device id
    "adb shell" remains stand by without any $ sign.

    I don't know how i can go further from here.

    What should I do to root this phone?
  13. meet5000

    meet5000 Well-Known Member


    Problem 1: USB Storage

    Please, read my guide lines again, I've edited them.
    If 'Mass Storage only' is already unchecked, you don't need to do anything for that.
    "Phone will ask to turn on USB Storage" means this:

    [​IMG]

    If you're not getting anything like that image, that means your phone is not being recognized by Windows because maybe LG Drivers are not installed properly.
    Download drivers using the links that I've given in the guide and try again.



    Problem 2: UnlockRoot

    I've given onther paths in guide.
    If they don't work, download UnlockRoot again and try.

    At the topic of SuperOne Click, It has never worked for me.
  14. jonathan589

    jonathan589 New Member

    There is something special with my phone. The "Usb connected" notification can't show up without the microSD card inserted, so I leave the microSD card mounted, until the "Usb connected" notification shows up before unmounting it.

    I downloaded :
    - Unlock Root of Android
    - LG Android Driver
    - Support for LG P690
    a seccond time and did the mentioned steps, but the results are the same:
    - When unlockroot.exe is executed, there is no GUI except once in a while a dialog box with unrecognized special character shows up.

    Maybe this has something to do with the fact that I play Win XP in a Virtualbox vm.

    I searched google and found out these 2 additional steps required to make the SuperOneClick solution work for me:
    - If playing Win XP in a Virtualbox vm, "Enable USB 2.0 (EHCI) Controller must be unchecked. This allowed the "adb shell" command to show up a $ sign.
    - Install .NET framework 2.0 so SuperOneClick.exe shows up a GUI.

    From then, everything when fine.
  15. honeyxxx

    honeyxxx New Member

    Sir support for lg p690 site doesnt exists.plzzz help.
  16. honeyxxx

    honeyxxx New Member

    Sir support for lg p690 working now....thx
  17. meet5000

    meet5000 Well-Known Member


    That's nice you got your own solution.
    My problem with SuperOneClick was that whenever I opened it, it showed ".NET Framework 2.0 or later required."

    But I had already version 3.5.
    That has never worked for me..
  18. jackv4

    jackv4 Well-Known Member

    what about the gl45c is it the same thing or did i hit a dead end please let me know:confused:
  19. meet5000

    meet5000 Well-Known Member

    LG L45C and LG P690 both are different.
    I have created this guide only for LG Optimus Net P690, not for L45C. :(
  20. jackv4

    jackv4 Well-Known Member

    Looks like this phone will all ways stay unnotice there is no hope :(
  21. marvinmiller

    marvinmiller Member

    Hi !

    Thanks for the easy instructions :D

    I did the first part (didn't install the clockwork mod) because I don't know what it does. All I was after was being able to un-install some factory programs on my phone that don't give you the option to remove them.

    I assumed that 'rooting' the phone would let me do this but some of the un-install buttons are still greyed out.

    How does a person uninstall factory-type apps?
  22. meet5000

    meet5000 Well-Known Member

    Rooting doesn't give you direct benefits.
    You can go here to see how to remove system apps:

    http://jaxov.com/2010/09/how-to-remove-stock-default-android-apps-easily/

    Good luck. :)
  23. meet5000

    meet5000 Well-Known Member

    Notice: Download links of recovery.img and flash_image have been updated on 5th September, 2012. :)
  24. marvinmiller

    marvinmiller Member

    OK, on my LG-P690b I've been able to remove;

    Bell Remote PVR
    Bell Tunes and Apps
    Bell TVRadio
    Bell/LG Self Serve (never worked for me - always busy)
    ZoomPass
    LG World
    LG Remote Call (lgercui.apk) also had to be removed from /data/app
    Google Books (booksphone.apk) also had to be removed from /data/app
    Google Talk (talk.apk & talk.odex)
    Google Play Movies also had to be removed from /data/app
    GPS Navigator: GPS Navigation by BCE/Bell (Also called TeleNav)

    with no issues.

    What I've been doing is going into the /system/app folder and then renaming programs I'd like to remove from .apk to .bak and then re-starting the phone to see if it boots up.

    Questions, so far all is well but what happens if one of the files I rename .bak is required and the fone no longer starts.

    Is it possible for me to 'get into' the phone so that I can rename the file from .bak to .apk and revert back to where I was?

    To me, this is the critical part.
  25. meet5000

    meet5000 Well-Known Member


    Sure. But it is very long process 'indirect' process though.
    But you must have a recovery image installed.
    If you don't have, you can consider my guide to install it.


    1. To boot into recovery, open Terminal Emulator and type:

    su (press enter)
    reboot recovery (press enter)


    2. After booting, select 'Backup and restore'
    (How to navigate: Volume up to scroll up, volume down to scroll down, power button to select.)


    3. Select 'Backup' and wait for a while. It will show the message, 'Backup successful!'. This backup will be stored in SD Card in a folder names 'clockworkmod'.


    Now, whenever your phone does not start, boot into recovery by pressing Voulum up + Power + Home button together and restore the backup you have created.
Loading...

Share This Page