[Guide] Root for Official 2.3.5 With Guide


  1. geeve420

    geeve420 Well-Known Member

    *Please read this thread, an easy to follow guide a couple of posts down*

    Guide is on Post #6

    *Downloads in this post*

    ***Heimdall install instructions now added to the end of the guide post #6, thanks to rbronosky for that!!!*******


    Wanted to share this with you all! Just did my phone and No change other than I am Rooted now :D Enjoy, and thanks to froggy3hope at XDA!!

    Thank you Mods for merging the Threads!!!!

    For those that want to donate, please donate to Susan G Komen for the cure (or any other charity). Then it is a win/win, you get to help and say thanks all at the same time :D


    Geeve

    Attached Files:


    Advertisement
  2. bmoliver

    bmoliver Well-Known Member

    This method just worked for me.
    buceye383855 likes this.
  3. supmag

    supmag New Member

    I was able to root my samsung captivate using super one click. I rooted froyo and have been using it ever since. I use Barnacle and Wireless tether to make the captivate into a wifi hotspot. I also have other apps because of root. If I do a stock update will I loose the ability to use those apps? Specifically Barnacle and Wireless tether?

    Also can some one please post step by step instructions as I am not an expert and was able to do super one click, but I am not sure what people are talking about with most of these instructions. Thank you in advance for your patience and help.
  4. geeve420

    geeve420 Well-Known Member


    Yes if you upgrade, you will lose root. I will try to do a detailed step by step later tonight when I get the little one to bed.

    Geeve
    CraigsWIFE, nafarzen and supmag like this.
  5. supmag

    supmag New Member

    Thanks for the response. I look forward to any help you can give. If you do not have time, thats ok.
  6. geeve420

    geeve420 Well-Known Member

    I was asked for an easy to follow guide on how to do this:

    So I thought I would make a guide. Some of you out there my find this really basic, but I want to make it as easy as possible.

    *You screw up your phone and no one is resposible but you!! Do this at your own risk*

    So here we go:

    First off, update your phone to the official 2.3.5 via kiess, here is how to do that:

    http://www.samsung.com/us/support/SupportOwnersFAQPopup.do?faq_id=FAQ00024051&fm_seq=24219

    (I am not detailing this for you, this guide is for rooting it)

    If you are on 2.2 Official and you are rooted, you will lose root!!! (I am also not going to get into frozen apps, Lagfix, or any other thing here before you update, do the research. if you have any of that, you can figure this out)

    Now the actual Rooting begins:

    ******Edit: Thanks Mods for merging*********

    Download files: can get them from the first post. Once you have them downloaded, you will have to unzip them, but leave the .tar files as .tar, and remember where they are. We will come back to them.

    Open Odin, If you are on Windows 7, right click and run as administrator. It will look like this:

    [​IMG]

    Now put the phone into Download mode. There are 3 ways to do this. (I personally use method 3 and have had the most success with it, I also don't remove my sim, your call on that) Here is how to get into download mode:

    Method 1: ADB - from recovery or normally booted with usb debugging on)
    1.Open a cmd prompt/console/shell
    2.adb shell
    3.adb reboot download

    Method 2: KEY COMBO
    1.Remove the battery, sim card, sdcard if you have one
    2.Insert the battery
    3.Hold Volume Up + Volume Down + Power

    Method 3: KEY COMBO
    1.Remove the battery, sim card, sdcard if you have one
    2.Insert the battery
    3.Hold both Volume buttons
    4.Plug in the USB cable and continue holding both Volume buttons

    Your phone will look like this if you are in Download Mode:

    [​IMG]

    If you used Method 1 or 2 then you need to plug your phone into your computer (with Odin Running). If you used Method 3, you are already there.

    Odin will show it sees your phone and will look like this:

    [​IMG]

    (Your Com number will be different based on what USB port you are using)

    Now click the PDA button and browse to I897UCKF1-AutoRoot-DesignGears.tar and Odin will now look like this:

    [​IMG]

    (I hope I don't have to tell you the path to the file will of course be dependant on where you saved the file)

    Now hit Start. A progress bar will show on both the phone and Odin. When the flash is complete Odin will look like this:

    [​IMG]

    At this point the phone will reboot. You may remove the USB when it is on the AT&T screen. Also hit the Reset button on Odin (right next to Start)

    Go ahead and grab a smoke, drink, whatever you want. We are almost done!!!!

    Let the phone completly boot back up. once it is fully up, shut it off again, and put it back in download mode and connect to computer (of course with odin running)

    Now click the PDA button and browse to KK4_stock_kernel.tar and Odin will now look like this:

    [​IMG]

    (Again, I hope I don't have to tell you the path to the file will of course be dependant on where you saved the file)

    Now hit Start. A progress bar will show on both the phone and Odin. When the flash is complete Odin will look like this:

    [​IMG]

    At this point the phone will reboot. You may remove the USB when it is on the AT&T screen.

    Let it boot back up again, you are now rooted!!! Go to the market and install Busybox, and while you are there Update Super User.

    I had to turn my WiFi back on, but my setting were still intact. That's it, Hope this helps someone! :D

    Geeve


    ********HEIMDALL INSTRUCTIONS********

    Thanks to rbronosky for taking the time to write these up!!

    "I'm pretty much uncomfortable with anything that isn't a command line. I like to know every command that is being run. So, I used the Heimdall CLI 1.3.1 tool on my Mac to root my Captivate.

    The paths below assume you put the contents of the zip files into directories named accordingly, and that your android SDK was expanded right in your Downloads directory...
    Downloads/android-sdk-macosx/platform-tools/adb reboot download
    sudo heimdall flash --pit Downloads/flashing/captivate.pit --kernel Downloads/flashing/I897UCKF1-AutoRoot-DesignGears/zImage
    Downloads/android-sdk-macosx/platform-tools/adb reboot download
    sudo heimdall flash --pit Downloads/flashing/captivate.pit --kernel Downloads/flashing/KK4_stock_kernel/zImage

    That's it. You can get Heimdall from https://github.com/Benjamin-Dobell/Heimdall/ "

    ****The original post for this is Page 3 post #121, PLEASE SHOOT HIM/HER A THANKS FOR HIS/HER TIME!***


    Edit: Thanks to Froggy3hope @XDA for pointing this out, Thanks to Designgears @XDA for the how to on Download Mode and also for the I897UCKF1 - Auto Root kernel, Imran @ithinkdiff.com for the download mode pic (to lazy to take one myself) Not sure who posted and uploaded the KK4 Stock kernel....but thanks to you as well! A huge thanks to my beutiful Wife for having the patience while I took screen shots, messed around with my phone, and typed this up instead of watching "Once upon a time" with her LOL!
  7. supmag

    supmag New Member

    Geeve, thank you very much. I certainly appreciate the amount of time it must have taken you to do this for all of us who are not experts. I know this will help me and I am sure others will also benefit. Thanks again.
  8. supmag

    supmag New Member

    It worked. Took no more than 15 minutes. Able to follow everything the fist time with no problem. Your instructions are perfect. Thank you once again for donating your time.
  9. geeve420

    geeve420 Well-Known Member

    Thanks and no problem! Glad you got it and it worked for you :D

    Geeve
  10. dbwill

    dbwill Active Member

    Geeve240, that was a piece of cake I am in your debt!!
  11. geeve420

    geeve420 Well-Known Member

    No problem! Just point people to the guide if you see anyone needing to know how :D

    Geeve
  12. freakdaddydog

    freakdaddydog Member

    Geeve,

    Thanks for the guide. It worked like a charm and I'm rooted again. THANKS!!!!
  13. geeve420

    geeve420 Well-Known Member

    You are welcome :D that's what I do, when I am doing what it is I do LOL


    Geeve
  14. bolts2

    bolts2 Member

    Please allow me to ask a dumb question. I recently upgraded to the official 2.3.5 and my company from AT&T to T-Mobile about the same time. I really want to keep using my Captivate but it is not unlocked. Do I first need to root my Captivate via this process in order to get it unlocked? Or can I do that without root? Thanks.....

    Edit: Never mind, accomplished via online unlocking service.
  15. PhoneMatt

    PhoneMatt Well-Known Member

    Thanks a lot, man. I'll try this as soon as I get back to my comouter.
  16. hubabuba

    hubabuba New Member

    Hello guys,

    I was following the instructions and did it all, but after putting the KK4_stock_kernel.tar i start having problems with my wifi connection. I tried 2 different routers and had the same results. The phone gets stuck on Obtaining IP address. Can anyone please help me?
  17. geeve420

    geeve420 Well-Known Member


    Hmmmm, weird. I know some folks had trouble if they didn't flash the the KK4 kernal and left the auto root one on there. You can try to simply shut the phone down and reboot, has worked for me in the past. Other than that, you can try reflashing the Kernel and see if it fixes the problem. I will do some research though and let you know what I find.

    Geeve
    hubabuba likes this.
  18. hubabuba

    hubabuba New Member

    Thanks for the quick reply. I tried rebooting and reflashing the phone but it is still the same.
  19. geeve420

    geeve420 Well-Known Member

    K, let's try a couple things here:

    First: (do this in this order, I have had to do it at work after a power surge)

    1)Have phone forget Network (settings-wireless and network-Wi-Fi settings and selct the network you are trying to connect to, select forget)
    2)Turn off phone
    3)Unplug Router
    4)Wait 20 secs.
    5)Plug in router, let it boot back up
    6)Turn on phone
    7)Try to connect again

    The key is to have the phone off, it allows the router time to start fresh and the phone as well.

    If that doesn't work try this:

    1) Open AllShare (it is in Applications)
    2) Hit Settings and Select "Access Point Network" (Note the warning "Changing settings value will restart AllShare" which is exactly what you want!)
    3) Choose your network from the list.
    4) Network should restart and connect.

    Let us know :)

    Geeve
  20. hubabuba

    hubabuba New Member

    I just tried another flashing the kernel before you posted and this time it worked! I turned the phone off, removed the battery, sim and ext sd. I put the battery back in and went into download mode, did the kernel flashing then waited and turned the phone back off, again removed the battery (im not sure but i think i missed that step before) went back in download mode and put the KK4_stock_kernel back in. It did work this time! Thanks again for the fast replies i got scared there for a bit :) This was my first phone kernel flashing...
  21. geeve420

    geeve420 Well-Known Member

    No worries, bad flashes happen! Glad you got it sorted out! You really need to worry when the phone won't even boot LOL!! A bad flash on Bootloaders will ruin your day and your phone. Welcome to the world of flashing, just be careful and take your time :)

    Geeve
    joeltaub likes this.
  22. gweff

    gweff Active Member

    Works like a charm, sir. thanks for the detailed instructions. interesting that i didn't expect was that my gps works great now. i have been struggling with that ever since i upgraded to froyo. wifi tethering also works great. thanks again.
  23. geeve420

    geeve420 Well-Known Member

    No problem, Glad I was able to help :D

    Geeve
  24. fallingleaf

    fallingleaf New Member

    Thanks for this guide. I was able to get this to work with Ubuntu and Heimdall (instead of Odin). I simply untarred the "zimage" files from the files you linked and put them in the "Kernel (zimage)" slot on Heimdall. Heimdall has a PDA slot as well but for some reason the start button was grayed out when I tried to use that. Heimdall doesn't have a reset button so I closed it and restarted it between flashing to make sure I was getting a fresh start.
  25. geeve420

    geeve420 Well-Known Member

    Very cool! I am not real familar with the Heimdall set up. If you can make a step by step for this I will add it to the orignal guide, just in case we have some Linux Folks out there or just folks that prefer Heimdall :) That would be really helpful.

    Geeve

Share This Page