[Guide]ROOTING HTC android 2.2.1 or lower with unrEVOked - Windows (updated 20th December 2012)


Last Updated: 2015-05-21 22:14:52
  1. SUroot

    SUroot Well-Known Member Developer

    cant be long now.

    Advertisement
  2. burnt_toast

    burnt_toast Well-Known Member


    got a link for a guide on how to flash a custom rom? looking into using gingervillain 1.8
  3. SUroot

    SUroot Well-Known Member Developer

    rooting FAQ (not guide) in my sig has info on this.
  4. burnt_toast

    burnt_toast Well-Known Member


    Sorry SUroot, maybe im blind but i didnt see the tutorial from the Rooting FAQ thread.

    I did find a tutorial from unlockr... and again it seems easy enough.but I got a few question.

    when ask to "to Wipe Data, select wipe data/factory reset and then select wipe dalvik cache", all data will be lost right? what is the easiest way to back up? and then how to I restore?

    Thanks.
  5. SUroot

    SUroot Well-Known Member Developer

    Flashing a custom rom AND data backup

    (from the FAQ not sure how you missed it ;) )

    If you didnt see it in the faq, you werent reading th3 faq. You were just looking for something specific. you should read the entire FAQ.

    How do I flash a custom ROM?

    First, find a rom that you want from here:

    Desire Index - Everything Desire is here! [UPDATED: 18/2] [InsertCoin,Cool Z & HD] - xda-developers

    It lists all the good roms. Be aware that you already need to be rooted. If you want to use apps2sd+, you will also need to have partitioned your card first. See the apps2sd+ FAQ in my signature.

    Be aware that you may need to wipe. However, for stock / HTC sense based roms for the desire (not including ports such aas the desire HD ports), you MAY get away without doing a data wipe. AOSP (vanilla) roms will definitely need a wipe

    Its always best to take a nandroid backup of your existing rom. See the Nandroid section further on in this FAQ.

    Also you should backup your apps and data. Titanium Backup is a great app for this. However, I also use mybackup pro for sms and call logs, but there are alternatives out there.

    If you have to wipe, this is due to an incompatibility with system settings from your old rom. See the wiping section, also further on in this FAQ.

    So (based on clockworkmod recovery):

    1) download you chosen ROM onto SD card
    2) Do all your backups
    3) Boot into recovery manually (see recovery section earlier)
    4) Choose "wipe data / factory reset"
    5) Choose "Install zip from SD card"
    6) Once complete, choose "reboot system now"

    It can take 10 minutes to boot up first time, so give it this long before taking further action. If it still has not booted, pull out the battery, but ONLY when the boot animation is on. NEVER during a flashing process.

    If you can obviously see the boot animation looping, this may be due to the lack of wipe. Pull the battery and boot into recovery and perform the wipe.

    Once booted, if you wiped, set up the phone with network and market access and download Titanium again and whatever data restore app you used for sms (if desired).

    If you wiped, be careful which option you choose to restore. You dont want to restore system settings, so "restore missing apps with data" is a good one to choose.

    Now, enjoy setting up and playing with your phone.
  6. burnt_toast

    burnt_toast Well-Known Member

    SUroot, wow I am blind...
  7. SUroot

    SUroot Well-Known Member Developer

  8. mpnuttall

    mpnuttall Member

    Hi guys

    I have an HTC Desire on Orange, and am trying to root it using this guide.

    I'm not seeing what it says I should in the device manager though, as per step 5 of the prerequisites:

    Expand "Other Devices" in the right-hand pain and locate "Android 1.0 device"

    I'm using Vista and don't see an 'other devices' folder. I see one called 'android phone', which contains only a file called 'Android ADB interface', but can find nothing else related to the phone in the device manager.

    There's a further folder called 'portable devices' that has 'E:\' in it, but assume that is just the memory card.

    I'm totally new to this and really scared of frying my phone, so would appreciate any advice.

    Thanks very much
    Mark
  9. SUroot

    SUroot Well-Known Member Developer

    Just to confirm, you're not running android when you are checking are you? You should be in Hboot mode
  10. rob0t

    rob0t New Member

    arent all desires rootable?
  11. mpnuttall

    mpnuttall Member

    Wow, thanks for the fast reply!

    I'm in Hboot mode, as per the guide. it says its plugged in on the phone screen too :(
  12. SUroot

    SUroot Well-Known Member Developer

    HBOOT 1.06 is not.
  13. SUroot

    SUroot Well-Known Member Developer


    It shows in Other devices if there are no drivers. Once you update the drivers, it shows as "Android Phone" which you already have.

    Try updating the drivers on "Android Phone" instead, although it sounds like that step is already somehow complete.
  14. mpnuttall

    mpnuttall Member

    Thanks for that. I spent ages trying to make a goldcard earlier, and downloaded all sorts of stuff as had problems with almost every guide I tried. So maybe it got updated then? Am I risking anything if I proceed past this step if updating the 'android phone' doesn't work?

    I'm so paranoid about breaking the phone and not being able to restore it :(

    Thanks again
  15. mpnuttall

    mpnuttall Member

    Ok, so I can't update the 'android phone' (no option to), only the 'android adb interface' inside that folder. Shall I do that, or am I going to trash it??
  16. SUroot

    SUroot Well-Known Member Developer

    What you could do to be sure, is delete android phone, and start the hboot driver install again.
  17. mpnuttall

    mpnuttall Member

    Thanks for all the help - I (think I'm) now rooted.

    I have an addition for your FAQ, and a couple more queries if you wouldn't mind asisting again:

    1. I can't get terminal emulator to show me my erase size. When I enter cat /proc/mtd I get a 'permission denied' message. Like a fool, I pressed on with running Unrevoked 3.32 from here anyway: How To: Root the HTC Desire (Unrevoked Method) (Updated 1.18.11) | TheUnlockr. It seems to have worked (this guide doesn't even mention erase size, which confused me?!), and I have created and restored a back-up from within rom manager since rooting. Does that mean I'm good to go, or might stuff go wrong still? do I still need to check the erase size? if so, is there another way I can do this other than terminal emulator if so? Sorry, that's a bunch of questions!

    2. I have free access to Orange Maps as part of my contract. I'm worried that if I install a custom ROM I'm going to lose my Orange Maps - I found one thread where someone had tried to re-download it from the market after rooting and it said that it wasn't compatible with their device. And I know Google has its own sat-nav equivalent but, for once, I actually prefer the Orange one!

    3. For info, when I got the 'is your firmware too new?' message during Unrevoked install, I disabled wifi and disabled 'allow installation of non-market apps' and it then worked fine. Can't remember where I found that advice now (been looking at a silly amount of forums and threads), but might be worth sticking in the FAQ in case it helps someone else :)

    Thanks very much
    Mark
    SUroot likes this.
  18. kewlbuddy

    kewlbuddy Well-Known Member

    as you are already rooted, dont bother about erase size.
    and do nandroid backup instead of rom manager backup
  19. mpnuttall

    mpnuttall Member

    Thanks for this. I thought that the ROM backup in ROM manager was powered by ClockworkMod though? Is it not doing the same thing?

    Oh, and how can I check that my goldcard is working? Seems wise to check before flashing a new ROM.

    Cheers
    Mark
  20. SUroot

    SUroot Well-Known Member Developer

    Fixed broken Drop box link, created when re-organising my Drop box.

    Sorry
  21. rossw

    rossw New Member

    Awesome guide (and FAQ too), thanks SUroot. Found it from google and of the many sites I read I came back here because it was the clearest/easiest.

    Mine didn't work with 3.32, but went fine with 3.21

    Now to sort out my storage so my phone doesn't keep filling up with apps!
  22. SUroot

    SUroot Well-Known Member Developer

    Cool. Thanks
  23. stu2402

    stu2402 New Member

    hi i'm a noobie at all this and have been following the vid tutorial to sort out my phone. i'm stuck at when running alpharev and on step three where the pc says that it is waiting for the flashing to complete. its not done anything for twenty minutes unlike the video where it was about ten seconds and more information came up on the desire screen all i have is
    "AlphaRev SPLBOOT version 2.0

    Normal NAND detected. Non-PVT4"

    nothing else has happen. What do/can i do?
  24. Usta

    Usta Well-Known Member

    See the solution here: http://androidforums.com/desire-all...lashing-partition-table-help.html#post2596707
  25. togger161

    togger161 Well-Known Member

    I rooted my phone with the help of SUroot when I first got it. Was asked to do a friends last night as he could no longer install anything due to lack of memory. Followed this guide exactly several times without success. Then the penny dropped - the phones memory was full. We uninstalled some of the larger apps and tried again. Worked a treat. New rom flashed.

    So just to add - if you are having problems check you have some free memory on your phone.

Share This Page