[Guide] S-OFF and ROOT HTC Desire with Revolutionary - Updated

Last Updated:

  1. shauny13

    shauny13 Well-Known Member

  2. existinguser

    existinguser Active Member

    I just really wanted to express my happynes for the root of my HTC Desire, since it was my only phone since my HTC Desire HD is faulty with "!" marks and i cant flash it (happened after it had contact w water) and after cleaning all schemes it wont let me access the flashing... i suppose it had smthn to do w HTC guys after i had it over in their shop to look it up for me and got a no after a month where they figured out it had water. anyways, thanks for all your tips, i mean everybody in this thread :)

    I am trying 1.step to make my desire s-off.
    i run revolutionary.exe, connect the phone and revolutionary keeps on saying waiting for device, then it starts the magic until it says something like:

    enter beta key....
    invalid beta key...



    FIXED THE ISSUE. Beta key generated was correct, i just made a typo for 8 times in a row... duh
  3. zimzee

    zimzee Member

    Ok dudes I will defo try.again 2moz but at the mo I'm wrecked on strongbow and whooping my may at fifa 12 .........hand you so much for your resppnce so far :D
  4. zimzee

    zimzee Member


    i could kiss you you right now lol

    thank you thank you thank you

    and cheers to anyone else that tried to help THANKS
  5. Hadron

    Hadron Well-Known Member Contributor

    I take it it worked then? ;)
  6. zimzee

    zimzee Member

    YES :D now how do i remove apps i dont want .......i would like to flash the rom but after the trouble i have had doing this its put me off lol
  7. Hadron

    Hadron Well-Known Member Contributor

    OK, you've got the custom recovery, so now do the last part and use that to flash the root patch, if you haven't already.

    Once that's done, you have the 2 ingredients you need to just uninstall any app: root access and S-Off. The simplest way to do this cleanly is to install Titanium Backup, select the app you want to remove, clear data then uninstall. What I'd recommend is taking a backup of everything with Titanium first. What I'd actually recommend is not to uninstall at all, but to freeze instead (see below).

    However, before you even think of doing that, please boot into recovery (boot into hboot and select recovery from the menu) and take a backup. This is the "nandroid" backup you'll hear about in all root discussions. The reason is that if you uninstall something that turns out to be critical you may find the phone crashes and cannot boot! If that happens, back into recovery and restore the backup, and you are going again. I always take a nandroid before changing anything in the system (even simple stuff like adding a theme).

    The second bit of advice I'd give is to "freeze" unwanted apps using Titanium rather than uninstall them. You don't gain space by removing system apps, as they live in a different storage partition, so freezing them (removes them from app drawer and stops them running) does what most people want, but is also very easy to undo if you find it causes problems.

    If you find Titanium won't run when you first try (usually the case), there's a "Problems" button in the app. Use that and let it install "busybox" and you'll be fine.
  8. zimzee

    zimzee Member

    i want to have a read of how to install ginger villain but cant seem to find a post on it so is there any chance you could point me in the right direction please.
  9. Hadron

    Hadron Well-Known Member Contributor

    GingerVillain should be fairly straightforward to flash. But there's another question to ask first:

    * Do you want to use the a2sd+ capability to get extra space?

    If you do, you'll need to add an ext-format partition to your SD card, and it's simplest if you do this first. The "root memory faq", linked in the All Things Root Guide sticky post, describes this. GParted is the preferred tool for formatting. Back up your SD card completely (including any files or folders whose name starts with ".", i.e. hidden files) before doing this, then copy the data back afterwards.

    This isn't essential - GV will run without it - but it's worth doing as it gives you a lot more space for apps (especially if you move the dalvik cache to SD, as described near the start of the GingerVillain thread at XDA).

    Whether you do that or not, flashing GingerVillain itself is fairly standard, so the method described in the rooting faq (linked in usual sticky post) will work fine:

    * copy ROM .zip onto sd card
    * back up apps and data (Titanium, plus back up messages with a separate app, check that contacts are backed-up separately)
    * boot into recovery
    * take a nandroid backup
    * do a factory reset
    * install zip from SD
    * reboot

    After installation, restore any user apps and their data from Titanium backup, but do not restore system settings. Restore contacts and messages from their backups (Ti stores them in system data, so you should back these up separately). It'll look a bit different from Sense, and do some stuff differently, so allow a couple of days to get used to things.

    I highlighted the "take a nandroid" bit because as long as you do that, if anything goes wrong you can just revert to where you were. Without that then any mistakes are recoverable, but will be more hassle and may lose some data.

    But don't just rely on this post, read the 2 faqs that I mentioned above. If there is anything you are unclear about, or any other problems, probably best to start a new thread as we're getting off topic for this one :)
  10. zimzee

    zimzee Member

    Ok thanks
  11. dragon181988

    dragon181988 Well-Known Member

    hi guys,

    i first updated my phone with the official ruu to 2.3.3. i like to downgrade my rom now to 2.2.2 again because it i have to much problems with the 2.3.3 system. could any of you tell me how to do this? btw i used this guide as well to get s-off and rooted which i succeded in that. but i only like to downgrade my system and than get s-off and rooted again. so how do i do this?
    thanks in advance. :p
  12. existinguser

    existinguser Active Member

    You just download a rom you like and install it in recovery mode. I had 2.3.3 to. But thanks HADRON, I managed to s-off and root it. So now all is possible
  13. SUroot

    SUroot Well-Known Member Developer

    I'm really sorry I missed this. This would have been an easy fix. Glad its sorted now but a brief explanation of the cause and solution is in order.

    So in Command Prompt, a space signifies the end of a command, program, variable or option.

    In this case fastboot flash recovery C:\Documents and Settings\Gaz\Desktop\recovery-RA_2.0.1.img is:

    program command option variable. The variable in this case is the file path.

    The problem is that the end of the path is identified by the space. Command prompt is looking at the path "C:\documents " because of the space. Essentially everything after the variable for this command (after the space) is disregarded completely. Like if you have a telephone number and its too long, the last digits don't count anyway.

    Obviously this path does not exist so "cannot load" is the result.

    This is probably why after windows XP, user profiles are c:\users\username instead of c:\documents and settings\username.

    In cmd (or in a run command, address bar) a path that includes spaces must be put in quotation marks to be recognised as a single entity. This renders the spaces useless.

    fastboot flash recovery "C:\Documents and Settings\Gaz\Desktop\recovery-RA_2.0.1.img" would have worked.
  14. zimzee

    zimzee Member

    Well at least the next person will know what to do:)
  15. existinguser

    existinguser Active Member

    But this is a great tutorial.
    Like really good
  16. Hadron

    Hadron Well-Known Member Contributor

    Well as I said, most of this guide was written by Matt. I've merely taken over maintenance of it, so the credit really should go to him.
  17. Redswan

    Redswan New Member

    Hello from a newby.

    Thanks to Mattb81 and Hadron for a great tutorial. It allowed me to S-OFF and Root my Desire (almost) without a hitch. I installed 4EXT Touch recovery and have kept my original ROM.

    The almost is because after successfully S-Offing and Rooting, Google Play (GP) prompted me to update Superuser. This I did, via GP, apparently successfully, but afterwards SU rights were unavailable to all apps requiring them, Titanium, etc. After some thought I came to the conclusion that it was the SU update which caused the problem. I booted into recovery, did a nandroid backup - I'll now do this at every change, and reinstalled the original SU zip. Now I had root access back again. After having downloaded the latest SU zip (v3.1.3, bin v3.1.1) and installing it via recovery I still have root access from apps. So my conclusion is that GP is not the right way to go for updating SU?

    A second question is that on starting 4EXT I get the message that it is in safe mode, and that I should format system and if I have changed hboot format all partitions!

    Was hboot changed in this process, I notice that the version is different, but did the partition sizes change? Is the reformatting only required for size changes. I guess I don't really understand what hboot really is:eek:

    I haven't done this as I'm a bit worried about the consequences! Is it really necessary, what can't I do in safe mode. What information is wiped and can it be recovered from a backup, nandroid or Titanium?
  18. Hadron

    Hadron Well-Known Member Contributor

    I have updated SU via the play store with no problems, but do remember some people having hiccups. Will check when on a browser.

    Only time I had that from 4Ext was when I changed partition sizes. S-Off replaces hboot but does not change these. Could see if message still there after a reboot. Otherwise restoring your nandroid should fix it (that formats system in the process).
  19. Hadron

    Hadron Well-Known Member Contributor

    Hmm, I'm using SU 3.1.3, with su binary 3.0.3, and I'm pretty certain I've updated through the market. You could try updating the su binary through the su app, which might fix things.

    Otherwise, keep the su you have (nandroid before trying to update it is simplest solution). It works fine, the only problem is that it's annoying seeing an update in the play store which you don't want to install (but can't tell it to ignore).
  20. Redswan

    Redswan New Member

    Thanks - that did the trick. Made a new nandroid then restored it and rebooted, no more messages. However when I rebooted the rom it took a l-o-n-g time, had me worried for a moment but it got there in the end. I suppose reformatting means some info has to be regenerated. All's well that ends well.

    Off to read up what hboot is all about.
  21. noobi

    noobi New Member

    hi all this is my first post yay lol except its to beg for help cuz i think i bricked my fone its stuck on the bootscreen nd wont load as a normal fone can i reset it to factory default so i can try again? also i have never rooted a fone b4 nor am i very computer savy and as u can tell my gramma sucks but im willing to learn
  22. shauny13

    shauny13 Well-Known Member

    Can we have that in english please, not text lingo.
  23. noobi

    noobi New Member

    lol that's the the second time today i've been told that so ok here goes

    i haven't rooted a phone before and i am not the best with computers but i thourt i could still do it so i tried i didn't understand step 3 very well and just ignored that things weren't going so well because they kinda were i.e pink revolutionary s-off showing but when i got to step 6 everything i tried failed but like i said it still showed s-off like it worked so i tried to unzip the Goo.im Downloads - Downloading su- file but it kept saying it couldn't because it was bad or something then 4ext prompted me to do a system format so i did now i cant use my phone as normal sorry about the cappy details i really don't know what i pressed i just wanna factory reset my phone so i can use it
  24. shauny13

    shauny13 Well-Known Member

    Hmmm, not sure this makes much sense either. Have i got this right? you are s-off and have 4ext custom recovery working? If you have formatted system without a backup you have no working rom. You need to download a rom of your choice and put it on the sd card (not in a folder). Then from recovery (volume down &power) choose install zip from card and select the rom zip you put on there earlier. If it boots ok and all is working well, go back into recovery and choose backup, then backup your phone.
  25. noobi

    noobi New Member

    yes that's kinda it i had ext but its gone after the format now i have android system recovery its 9 options all in green writing i just downloaded dGB_01_28_2012_eng.zip and put that on my sdcard 1 of the 9 options is flash zip from sdcard this is what it said

    install from sdcard...
    finding update package...
    opening update package...
    E:can't open /sdcard/dGB_01_28_2012_eng.zip

    installation aborted

Share This Page