1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Guide] S-OFF and ROOT HTC Desire with Revolutionary - Updated


  1. shauny13

    shauny13 Well-Known Member

    ahh, think you mean you had a 4ext partition, not the 4ext recovery, is that correct? anyway if you still have green writing in recovery that's a custom recovery. Bad means a corrupt download. Try downloading the rom zip again and check the md5 sum. Your the second person we've seen with this, the other user is going to try again tonight.
  2. noobi

    noobi New Member

    sorry i dont know the difference, how do i check the md5 sum and how is it corrupt i only just downloaded it then drag straight to my sd card? i'm checking the forums now for a ROM
  3. pilz

    pilz New Member

    Hi,

    First of all thanks for this update.
    I was already quite surprised I made it all the way to this, but the final steps don't seem to work.

    I have managed to S-OFF with Revolutionary.
    My hboot says:
    Revolutionary
    BRAVO PVT1 SHIP S-OFF
    HBOOT-6.93.1002
    MICROP-031d
    TOUCH-PANEL-SYNT0101
    RADIO-5.11.05.27
    Aug 10 2010....

    I have also managed to download and install SDK tools only. The 'adb service' command found my Desire

    I have downloaded both the 4EXt recovery and the RA recovery (using the latter now). Downloaded the root file (4b) and I have copied the .zip file to my SD card, and also the 2 folders seperatly (after the .zip file didn't seem to work).

    I believe I got stuck at step 5/6. I fastboot the Desire using vol.down+power. connect USB (I see HBOOT USB PLUG)
    In cmd I do:
    cd c:\
    fastboot flash recovery c:\recovery.img (the .img file is in c:\ folder)
    I got the following msg returned:
    "sending "recovery" (3782 KB) ... FAILED (status malformed 1 bytes) finished

    Could you please explain what went wrong and if I missed anything?

    Thanks in advance!
  4. dragon181988

    dragon181988 Well-Known Member

    hi guys,

    correct me if i'm wrong but i think his recovery is corrupted and therefor he can't get it flash well on the phone.

    btw can anyone tell me if i need the hboot with dGB rom to gain more internal storage?
    https://sites.google.com/site/dgbbravo/installation-instructions/downloads
    (allready got an anwer in another tread, thanks shauny).
  5. SUroot

    SUroot Well-Known Member Developer

    You're on the hboot screen. You need to be in the fastboot screen
    androiderer likes this.
  6. pilz

    pilz New Member

    thanks, that was indeed the mistake I made.

    I managed to boot in recovery. Got in the 4EXT menu (last step) and opened the su-2.3.6.3-efgh.signed.zip file as described.
    All went well, the message ended with "install complete. Enjoy! Install from sdcard complete"
    I choose "reboot now", but it gets stuck in the white startup screen with in green "HTC".

    What do I do now?

    edit: I obv forgot to make a backup before the whole operations (noob), I didn't see this step in the sticky...
  7. Hadron

    Hadron Well-Known Member Contributor

    Are your essential data backed up? And what software version were you running? Branded handset or not?

    The easy thing to try is a factory reset, but that deletes your data and may not fix (if there was something wrong with the file you flashed it won't help, and given that you've had one bad download already I can't rule it out). You could try wiping cache and dalvik from recovery - less likely to work, but completely harmless and quick. First boot after wiping dalvik can be slow, but if it takes more than 10 mins it's probably not worked.

    You could try downloading and flashing that file again. You can mount the sd card when in recovery and copy stuff over that way. Bit of a long shot, but not much to lose.

    You can flash a custom ROM, which should fix it, but you generally want to do a factory reset before that, so same problem with data loss. I would recommend a rooted stock rom just to get it going. There is a link to a list of roms in the All Things Root Guide sticky post - I suggest teppic74s rooted stock roms. If you want to try to rescue data, pick the one closest to your current software version and try flashing without wiping the phone first. Sometimes that works. If not then a factory reset is needed.

    Good luck
  8. pilz

    pilz New Member

    Thanks Hadron I appreciate your help!

    I didn't make any backups before (n00b). The desire was bought new a year ago or so in Europe. I believe I was running Sense 2.1.

    My hboot says:
    Revolutionary
    BRAVO PVT1 SHIP S-OFF
    HBOOT-6.93.1002
    MICROP-031d
    TOUCH-PANEL-SYNT0101
    RADIO-5.11.05.27
    Aug 10 2010....

    - I tried downloading the same file again "su-2.3.6.3-efgh-signed.zip", put it on the sdcard, tried flashing it again but same problem - stuck at startup screen.

    - I don't completely understand "wiping cache and dalvik from recovery". I did try to wipe cache - same problems.

    - Tried to download the teppe74's custom ROM, but the download mirror says the download doesn't exist anymore... (it's this one, right?). Any other recommendations?

    Thanks again for your help!
  9. dragon181988

    dragon181988 Well-Known Member

    you should reflash the rom, not the "su-2.3.6.3-efgh-signed.zip".

    you don't need to understand it. you only need to do the wipe before installing a rom again.


    i could recommend the dGB rom from SUroot. :D
    gives you a loot of internal storage and really runs fast.
  10. Hadron

    Hadron Well-Known Member Contributor

    I think you are running Android 2.2 from your radio version, but I can't tell more than that.

    The ROM you link is the Gingerbread version, which will work fine but will erase your data. There are mirror links in that thread, see this post: xda-developers - View Single Post - [ROM] [20/08] Pre-rooted Stock Gingerbread (3.14.405.1) [Optional Mods]

    His Froyo ROMs can be found at [ROM] [20/06] Pre-rooted Stock Froyo (2.29.405.5) [Optional mods] - xda-developers. I think the links there are broken too, but the last post of the thread includes an unofficial link. There's a chance (nothing more) that if you flash this without wiping it will boot and your data can be backed-up. That's about the only chance I can think of.
  11. dragon181988

    dragon181988 Well-Known Member

    i think he would not be able to get the info out of it anymore. i would recommend to cut your losses and install a new rom and set it up again.
    but what do i know? i think that you can better use a stable and fast rom than one that is crashing all the time and is not well recommended. again i would recommend dGB rom. ;)
  12. Hadron

    Hadron Well-Known Member Contributor

    Actually Teppic's ROMs are perfectly stable. I mainly suggested these because there's a chance that the Froyo one would let pilz recovery his/her data: if the data haven't been corrupted, and the ROM is close enough to what was there previously, then flashing without a wipe can get the phone working again without deleting the data. We've rescued a couple of people's data that way before now, but there are never any guarantees.

    If that works then back up everything, then choose a ROM at your leisure. If it doesn't, then all that's lost is the few minutes it takes to flash the ROM and boot.
  13. pilz

    pilz New Member

    Thanks

    However it doesn't seem to work really... I'm a little bit confused after trying so many things... FMI: those ROMs need to be copied to the SD card and then [flash from sd] in 4EXT recovery menu, right?

    And I have some troubles finding a working download for ROM 2.29.405.5 In this thread the links seem seem to be dead... http://forum.xda-developers.com/showthread.php?t=833310&page=23
  14. CharlottesWeb

    CharlottesWeb New Member

    Could some kind soul help me with a few issues I have? I didn't follow this guide, but I did follow a guide for gaining S-off using Revolutionary 0.4pre4 and CyanogenMod. The guide is on the wiki site, so im fairly sure you know which guide I refer to.

    Let me first say, that I am so not very tech minded. To say I have got this far and my phone is still alive is amazing hehe.

    Anyway, I have managed to make a backup of my original phone settings/image or what we call it. I also managed to install the CyanogenMod. This I found really neat. I then managed to restore my phone to its original state. Now, the problem I have is this. My phone is not actually rooted using the method I followed, correct? I notice here that there is a rooting file to use while following this guide. Would this be ok to use to achieve root on my phone?. Also, where and how would I go about the task of making myself some more memory to store apps on? I know it has to be done using the Micro SD card, Of which I have an 16GB installed. But how would I complete this?

    I apologize if I don't make myself clear enough, but I do try. This is all very confusing for someone like me. But I'm determined to succeed in rooting my Desire and increasing the memory. Truth be told, I only wanted to have more space on my phone to install apps and games. I have become addicted to trying these out. Though so little initial memory has left me having to install then uninstall multiple times. Again, I'm absolutely sure you know what I mean.

    So, can you guys help me?.......... Please?
  15. Hadron

    Hadron Well-Known Member Contributor

    So you've used Revolutionary to achieve S-Off and install a custom recovery, did a backup, flashed CWM, later restored to your backup?

    So if you did not do the stages in this guide where you download and flash a small patch to root your ROM then you are now unrooted again (you were rooted when running CWM). So to root you could follow just the bit of the guide where you download a root file and apply it from recovery, or you could flash another custom ROM (all custom ROMs are rooted).

    Since your main objective is to obtain more storage, I don't think rooting your current ROM is that important (unless you want to use something like Titanium Backup to back up apps and data in order to install them in another ROM). The simplest solution is "a2sd+", where you add a linux-format partition to your SD card and then a script which tricks the phone into treating this as part of your internal memory. The alternative is to use a "custom hboot" to shrink the space available to your ROM and give you more for apps and data (provided you use a ROM that fits in a smaller space). You can of course do both.

    So my advice is to look at the All Things Root Guide sticky post in this forum. Inside that you will find a link to the "root memory faq", which describes both of these options. Read that, then ask us about anything that's unclear.

    If you go the a2sd+ route, the main work is adding the partition to your card. Most ROMs that support this already contain the necessary scripts, so you just flash them and they work. One of the few exceptions, where you need to add it yourself, is CyanogenMod, but there are people here who can tell you how to do that.
    CharlottesWeb likes this.
  16. desfirl

    desfirl New Member

    Hi everyone, excellent guide.

    I've managed to get to the part where I "flash zip from sd card", I used the cm-7.2.0.1-bravo zip, but now the phone won't boot.

    Can it be saved?
  17. Hadron

    Hadron Well-Known Member Contributor

    So you decided to flash a custom ROM. Did you take a backup from recovery first?

    Did you do a factory reset before flashing the ROM? If not, that's why it won't boot. But did you back up apps and data before flashing? It's sometimes possible to recover them if not by flashing a rooted stock ROM instead (without a wipe) but it doesn't always work.
  18. existinguser

    existinguser Active Member

    What are your favourite Roms?
  19. Hadron

    Hadron Well-Known Member Contributor

    That's really a question for a different thread. We do have a "what ROM types are you using?" sticky thread in which people posted their preferences (mine can be found there, together with other people's).
  20. Mattb81

    Mattb81 Well-Known Member

    Hello!

    I still lurk from time to time but because no one can seem to port ICS or better to the Desire I kinda stopped twiddling once I used DBs rom.

    Glad someone's taking responsibility for this :)
    Hadron likes this.
  21. Laxie

    Laxie Member

    Hiya. I've just spent all day trying to get my head around the instructions. Struggled for a bit, but got there in the end with a lot of help...or so I thought.

    As soon as I was finished with the last steps (Choose "flash zip from SD card"), I tried to reboot with no joy. I seem to be another one who is stuck on the white screen with green HTC. I can get into the hboot and fastboot menus as well as the recovery thing that was downloaded, but that's it.

    I made sure my contacts/SMS were all saved online before I started this. I'd rather not lose the rest (pics, music, apps), but it's not the end of the world if that's the only option for getting the phone back in order.

    Any help/suggestions would be greatly appreciated! Cheers :)
  22. Laxie

    Laxie Member

    I forgot to mention...I was only trying to s-off and root the phone. I'd done a flash zip of the root file before the re-boot failed. Hadn't even entertained the idea of rom yet.

    Very new to this so apologies if my questions seem silly. I've been reading various threads on the forum since and still not sure what I should do next or if I've even posted enough information for you to work with. :(
  23. desarenezitic

    desarenezitic Well-Known Member

    If you're still struggling then you really need to provide as much info as possible, such as: -

    What have you done so far? (List all the steps/things you have done).

    This way people will be able to offer better advice.
  24. Laxie

    Laxie Member

    Thank you for the reply! Was getting worried I'd upset everyone with my ignorance of all things root. Got there in the end after a couple of frustrating days. S-off & root is sorted and Cyanogen Mod7 rom installed.

    My main reason for doing this was the internal memory issue, but that still seems to be an issue. Sigh. I've done some more research and managed to successfully partition the SDcard last night.

    A2sd+ seems to be what I'm after next. Is it something I install separately? If so, a link to the download would be great. If it's already part of the rom, do I need to re-flash the rom now that the partition has been done?

    Nearly there, but it's been a hard slog getting it sorted. Everything's easy....once you know how. :)
Loading...

Share This Page