[Guide]S-OFF and ROOT HTC Desire with Revolutionary - Windows (published 4th November 2011)


Thread Status:
Not open for further replies.
  1. SUroot

    SUroot Well-Known Member

    ADB and fastboot are two different things. When in fastboot screen, only fastboot commands work.

    If you have fastboot set up, just confirm using "fastboot devices" it sees the phone alright...

    If it does, do "fastboot erase recovery" then try and reflash recovery
  2. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks SURoot. This is what I have tried. Unfortunately getting error message saying "Failed":

    1. Vol Down+Power then using CMD in WinXP, ran this command "fastboot flash recovery c:\recovery.img"
    2. Vol Down+Power then Fastboot and using CMD in WinXP, ran this command "fastboot flash recovery c:\recovery.img"

    As mentioned earlier, have tried Android Flasher but get error message saying that Recovery.IMG already exists ...
  3. SUroot

    SUroot Well-Known Member

    Ok

    Back + Power straight to fastboot

    Code:
    Fastboot devices
    What does the above command return?

    If it doesnt say device not found, try

    Code:
    fastboot erase recovery
    Take a screenshot after doing this command

    then

    Code:
    fastboot flash recovery c:\recovery.img
    (Providing c:\recovery.img exists. Take a screen shot of this too please
  4. 1st_Paladin

    1st_Paladin Well-Known Member

  5. SUroot

    SUroot Well-Known Member

    Hi Matt,

    I have linked to your guide from my UnrEVOked guide (and will do from my FAQ too). It is also in the sticky.

    I have renamed mine to be:

    [Guide]ROOTING HTC android 2.2 or lower with unrEVOked - Windows (updated 11th November 2011)

    Maybe you could rename yours to something similar?

    Suggest:
    [Guide]S-OFF and ROOT HTC android 2.3 with Revolutionary - Windows (published 4th November 2011)

    ?

    Just for ease of use?
  6. Rastaman-FB

    Rastaman-FB Well-Known Member

    couple of things

    make sure the recovery is the right one from our links
    make sure you are booted into fastboot, not bootloader (back+power)
    use your rear usb ports
  7. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks Rastaman. Yes using the back USB ports. Confirmed that the files are from your links. As mentioned, I've tried:

    1. vol down+power
    2. vol down+power, then fastboot

    Hence the multiple entries in the screen capture. What am I doing wrong? When I used Revolutionary to S-Off it install the newer version of Clockworkmod v4 I believe.
  8. Rastaman-FB

    Rastaman-FB Well-Known Member

    its saying the recovery size is 0bytes. either it doesnt exist in c:\ or the file is corrupt
    can you confirm the recovery is in c:\
    which recovery are you using?
  9. SUroot

    SUroot Well-Known Member

    Yeah c:\recovery.img means that you have a file on the root of your c: drive named recovery.img. This must be true. If it is called recovery.img and is on your desktop, you should use

    Code:
    "c:\documents and settings\username\desktop\recovery.img"
    But I don't like having to use " to make up for having spaces in the file path so c:\ is the best location
  10. 1st_Paladin

    1st_Paladin Well-Known Member

  11. SUroot

    SUroot Well-Known Member

    Can you set it to show known file types please? Could be IMG not img? Also confirm what size the recovery.img is on disk?
  12. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks SURoot. Hopefully this is what you mean. http://dl.dropbox.com/u/11071461/Screen Capture.doc

    As you can see the file size 1K and it is an image file. This is the file from your signature recovery_CWM_2.5.0.7.img. I just rename it recovery as the name is quite long.
  13. SUroot

    SUroot Well-Known Member

    The download was unsuccessful then as it should be bigger than that.

    Go back to the ultimate toolbox and download it again.
  14. 1st_Paladin

    1st_Paladin Well-Known Member

    Thanks so much SURoot, Rastaman. It worked! Silly me. Turns out that the file was not properly downloaded. You were right all along. Really learned alot from this experience. Now have Clockworkmod 2.5.0.7 installed.
  15. Rastaman-FB

    Rastaman-FB Well-Known Member

    winner winner...
  16. anwes

    anwes New Member

    Hey I was following this greate guide, but now I have a problem.

    All the first steps when perfect, I installed and uninstalled HTC Sync and then the HBoot Drivers. ADB is installed and finds then phone when it's started normaly.

    Revolutinary was runned successfully and the phone is now S-OFF:ed (did not install the recovery they purposed)

    Heres the problem: When trying to install Recovery manually i boot the phone into fastboot and the phone tell's me fastboot usb. I can see that Windows findes the phone in Device manager. However when starting ADB Shell, it cant find the device.

    A'm I doing something wrong here, should i start ADB Shell first and then fireing upp away the fastboot commands, or is fastboot another win program I should run from the cmd? (Yes have read the ADB and FASTBOOT thread and followed the steps. Also I'm able to ADB Shell to the phone when it's started normally, but not in it's fastboot mode)

    Suggestions anyone?
  17. SUroot

    SUroot Well-Known Member

    Yes, adb doesnt work in fastboot. Only fastboot commands work in fastboot.

    So

    fastboot flash recovery c:\recovery.img

    If thats the location and name of your recovery (c:\recovery.img)
  18. anwes

    anwes New Member

    Thanks for the reply!

    Fastboot.exe was another Android-SDK tool, sorry for not getting that =)
  19. anwes

    anwes New Member

    Acctually one more question, last one I promise =)

    In 7.c, you mention the root file, where exactly do I find this, have browsed the Android Revolution HD - Mirror Site but there is a lot of files there. Can't find any other good reference to a "root file" on google or this forum either.
  20. Rastaman-FB

    Rastaman-FB Well-Known Member

    revolutionary, not revolution HD.
    revolutionary.io is the website for the revolutionary program used to s-off the device
  21. anwes

    anwes New Member

    Thanks for the answer!

    But just so im clear, I have done the revolutionary step and installed the recovery. Now I'm looking for the root file. I assume it's not bundled with revolutionary-0.4pre4 which i got from the revolutionary.io-site.

    But is the root file the zip I get from a ROM like Cyanogen??
  22. SUroot

    SUroot Well-Known Member

    Its just a link on the revolutionary.io site. Its a zip to flash... You only need it if you're not going to flash a custom ROM
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    no its to root your stock rom if you dont want to flash a custom one

    the root file is called super user and is found on their wiki which they tell you to read. public:revolutionary [RootWiki]

    please do some research, you will find yourself a bit stuck if you are not careful
  24. Mattb81

    Mattb81 Well-Known Member

    Added a link for root file. Will format to make sure reading revo site is emphasised when im on a pc
  25. Mattb81

    Mattb81 Well-Known Member

    Hey Dan,

    I originally changed it to what you suggested, then I thought "Hang on, I did this when I was on 2.2, so the title shouldn't imply it's only for 2.3" so I just put for HTC Desire.

    Tell me, what happens if you've upgraded to 2.3 official yet not one of the two HBoots currently supported by Revolutionary? Are you unable to S-Off and root?
    SUroot likes this.
Thread Status:
Not open for further replies.

Share This Page