[Guide]S-OFF and ROOT HTC Desire with Revolutionary - Windows (published 4th November 2011)


Thread Status:
Not open for further replies.

Last Updated:

  1. chaoser

    chaoser Member

    Joined:
    Jan 27, 2012
    Messages:
    18
    Likes Received:
    1
    im not trying to fight here but to respond with a question three exclamation marks seems like your just trying to be rude. obviously i dont know what im doing hints im in the forum! i not reading your answers really? im trying to learn as i go here. if your rude style of helping is not helping me. is not hard to say "hey man you missed a step" get outside a little more maybe you wont get so frustrated!!!!
     

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    So now you're criticising my life because I used 3 exclamation marks to exclaim my frustration that you cannot read a guide (no, sorry - 2 guides) properly? Not knowing what you are doing is one thing. Not reading text in order is another and is a completely different "Skill".

    Good luck, you certainly did a fantastic job of burning your bridge with me.
     
  3. chaoser

    chaoser Member

    Joined:
    Jan 27, 2012
    Messages:
    18
    Likes Received:
    1
    no im criticising you for being on this forum (which I thought was a friendly place) and getting so frustrated you cant help me out man! I have admitted my ignorance here and attempted to state my problem. and as i said earlier i was following a you tube video which drove me a stray. i know this to in my stupidity
     
    jakethe likes this.
  4. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    I am frustrated, I admit that but I DID help you out. I hinted that you revisit step 3 in post 1 which points to my adb and fastboot faq. This solves your problem with fastboot not being recognised. The reason I know it is not recognised is that you didnt follow step 3 in post 1. Hence my 3 !
     
  5. chaoser

    chaoser Member

    Joined:
    Jan 27, 2012
    Messages:
    18
    Likes Received:
    1
    i got it working a few hours ago. thanks for the help i appreciate it! I got it to work with revoked by the way.
     
  6. eteyen1

    eteyen1 Well-Known Member

    Joined:
    Jul 5, 2010
    Messages:
    134
    Likes Received:
    1
    Sorry if this is a dumb question, but I'm new to rooting.

    So I know you said to use cwm 2.5.0.7, but I had trouble getting it from the link above. So I googled cwm and under htc desire, found a new version? 5.0.2.0 which is what I used. That shouldnt be an issue should it?

    Also, you might now want to ammend the guide since there is a newer version out?
     
  7. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    No, we recommend 2.5.0.7 as its the.last official version. We are of course aware there are many newer versions.

    What trouble did you have getting 2.5.0.7? (and please don't say its password related ;) )
     
  8. eteyen1

    eteyen1 Well-Known Member

    Joined:
    Jul 5, 2010
    Messages:
    134
    Likes Received:
    1
    sadly, it is password related :S

    I just tried the link given in post 1, and it asked for a user name and password, neither of which I had. In fairness I didnt look to see if anyone had said something about that or not, I just googled cwm and found their website, which as I said listed a newer version for htc desire. So is this version not official from them even though its on their site?

    Would you therefore reccommend that I flash back to 2.5.0.7? This one I have seems to have worked, but if you say the older version is better, then I'll change to it. Also, how would I access it from the link in the post?

    Thanks

    Edit- presumably if I wanted to change to 2.5.0.7, I would just have to fastboot it and it would replace the version I have? I'm already rooted using the one I have. Changing revoceries wont cause an issue?
     
  9. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Ah see, the link in this guide goes to our download but the download is protected. There password is at the end of the ultimate toolbox thread in my signature.

    If you're not having any issues currently, its up to you.
     
  10. eteyen1

    eteyen1 Well-Known Member

    Joined:
    Jul 5, 2010
    Messages:
    134
    Likes Received:
    1
    so if I wanted to go to the older version, it would just be a case of fastbooting the older one, and it would just replace the one I currently have? Would that affect the root that I already have?

    Your post seems to suggest that there might be issues with the newer versions. If so, what are they?

    Sorry if these are silly questions?

    Thanks
     
  11. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    You can fastboot flash any recovery over another one. Root is in the rom, recovery is nothing to do with root.

    The later versions are not official and are not stable. Cause issues with SD cards and backups...
     
  12. jakethe

    jakethe New Member

    Joined:
    Jan 29, 2012
    Messages:
    4
    Likes Received:
    0
    Hi I am struggling to get the cmd prompt to work even though I have gone through all the faq and tried everything but I still get the same error " fastboot is not a recognized command". I have changed the settings in the Enviroment variables but still no joy. Anyone willing to help out. I have the sdk-tools on C:\ and have managed to complete the s-off process.
    Info on Desire
    Android 2.3.3
    software no. 3.14.405.1
    hboot-6.93.1002
     
  13. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    Did you use our sdk tools from the ultimate root thread? What's the full path of the adb.exe file? Can you browse there? Is what you put in environment variables the same path.

    One of these is wrong. That's why its not recognized
     
  14. jakethe

    jakethe New Member

    Joined:
    Jan 29, 2012
    Messages:
    4
    Likes Received:
    0
    Just going to check all that you mentioned-Thanks
    I got the sdk-tools from the faq thread
    In the environment path I entered ;C:\android-sdk-windows\tools as stated. Still no luck
     
  15. jakethe

    jakethe New Member

    Joined:
    Jan 29, 2012
    Messages:
    4
    Likes Received:
    0
    So I have the recovery-RA_2.0.1.img on my c:\
    also the rdk-tools are on the same c:\
     
  16. jakethe

    jakethe New Member

    Joined:
    Jan 29, 2012
    Messages:
    4
    Likes Received:
    0
    Managed to get it sorted now just need a good rom to have a play with any ideas anyone? As to why I was gettings issues ????? I went back and coppied and pasted the path into the environment and the cmd and it worked!!
     
  17. Hadron

    Hadron Well-Known Member Contributor

    Joined:
    Aug 9, 2010
    Messages:
    16,825
    Likes Received:
    9,499
    If cut and paste fixed it then there was probably some subtle problem in what you were typing. Sometimes you really need to go character-by-character to spot these, as I know from experience.

    ROM preferences are very personal. I suggest browsing the "what ROMs are people using" sticky at the top of this forum for ideas. The big question is whether you are after Sense, AOSP or Miui style?
     
  18. Mattb81

    Mattb81 Well-Known Member This Topic's Starter

    Joined:
    Sep 6, 2011
    Messages:
    209
    Likes Received:
    56
    I've added info on how to find the username and password.
     
  19. alex01

    alex01 Well-Known Member

    Joined:
    Jun 13, 2010
    Messages:
    119
    Likes Received:
    2
    hi,

    when i try the rooting process and i select "flash zip from SD card" the file is not showing. could it be because it's not a zip file?

    any advice please...
     
  20. Hadron

    Hadron Well-Known Member Contributor

    Joined:
    Aug 9, 2010
    Messages:
    16,825
    Likes Received:
    9,499
    Could you tell us exactly what you are doing?
     
  21. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,302
    ..and what steps you have completed so far.
     
  22. alex01

    alex01 Well-Known Member

    Joined:
    Jun 13, 2010
    Messages:
    119
    Likes Received:
    2
    that's the problem, i haven't a clue what i'm doing - if there was a prize for making the most amount of mistakes whilst rooting a phone i'd win outright. i've managed to do it now thanks...


    Hi SUroot, completed rooting at last. could you please tell which is the most suitable version of your rom for me and where to download from?

    thanks.
     
  23. Bradden

    Bradden Well-Known Member

    Joined:
    Sep 1, 2010
    Messages:
    233
    Likes Received:
    8
    Goo-inside.me Downloads - Downloading su-2.3.6.3-efgh-signed.zip

    I've read through this thread and can't see what the purpose of putting this on the SD card.. there doesn't seem to be any instruction to run it?

    I'm rooted already so I'm only s-oof'ing to install touchrecovery 4ext instead of clockwork.

    I don' think I need this file but I'm not sure as I've no idea what it is.

    Thanks
     
  24. Hadron

    Hadron Well-Known Member Contributor

    Joined:
    Aug 9, 2010
    Messages:
    16,825
    Likes Received:
    9,499
    That's the patch for rooting your ROM after you S-Off with revolutionary. So as you correctly deduce, if you are already rooted and just using revolutionary for S-Off, you don't need it.
     
    Bradden likes this.
  25. Bradden

    Bradden Well-Known Member

    Joined:
    Sep 1, 2010
    Messages:
    233
    Likes Received:
    8
    Thanks.. I couldn't see any reference to doing anything other than copying it to the SD card so I just wanted to be sure.
     
Thread Status:
Not open for further replies.

Share This Page

Loading...