Guide to flashing your Orange San Francisco / ZTE Blade with a custom ROM


Last Updated: 2012-11-16 03:30:10
  1. BurnCK

    BurnCK Well-Known Member

    You could try re-copying the update.zip file to the sd card and then give it another go.

    Advertisement
  2. rogdog

    rogdog New Member

    Update to my predicament:Now got things back working again with an Orange ROM....

    This is what I did:

    Downloaded the standard Orange ROM file for my OLED model - file called OUK_P729BV1.0.0B05

    Renamed it to update.zip.

    Copied this to a different micro sd card (because I couldn't read the one in the phone).

    Ran the ClockworkMod update again with the new ROM.

    Restarted - and the orange branding appeared. :D

    Put the old micro SD card back (the original).

    Now we're working again - so that's a relief.

    Need to have another go at loading a custom ROM. I'll checksum the file this time, as I have a feeling that perhaps that was the cause of the issue.

    Al
  3. patanas

    patanas New Member

    this is the only way to get 2.2 on the san francisco?, why wont it not update itself?
    i bought my phone thinking it would do so

    am i gonna have to do this for every android update there is?

    can it even support firmware versions beyond 2.2 later on?
  4. rogdog

    rogdog New Member

    Successfully flashed with my unbranded ROM now - yippee!

    Thanks BurnCK for your suggestion.

    Al
  5. BurnCK

    BurnCK Well-Known Member

    There is no official 2.2 release for this phone yet although I believe there will be one at some point. Highly unlikely that it will get anything beyond 2.2 though. At least nothing official anyway...
  6. w0bbl3r

    w0bbl3r Well-Known Member

    Has anyone done this on a Mac?

    Downloaded the fastboot files, put the clockwork image in same folder, opened terminal, ran the command and keep getting command not found :(
  7. w0bbl3r

    w0bbl3r Well-Known Member

    wow, lot of googling later of course it was head smackingly easy.

    Mac users have to add "./" (without quotes) to the start of the command.
  8. squitten

    squitten Well-Known Member

  9. JR866Gooner

    JR866Gooner Well-Known Member

    How do we change the lock screen wallpaper on this rom??
  10. Renniks

    Renniks Well-Known Member

    How would I do this Via a Mac
  11. shooey

    shooey Member

    Tried rooting my phone using the guide in this thread and everything seemed fine... now the phone wont unlock and the only way to switch off the phone is to remove the battery. Cannot get access to my phone - HELP!
  12. shooey

    shooey Member

    The touchscreen is completely unresponsive... but the power button works.
  13. BurnCK

    BurnCK Well-Known Member

    I'm guessing you didn't read the instructions properly, as the problem you described is due to your phone having a TFT screen, and this particular ROM doesn't support that screen.

    Download the updated ROM from here :

    [ROM] 23/Dec r8: de-orangeated ROM for ZTE Blade / Orange San Francisco [eclair] [OLED+TFT] - Android @ MoDaCo

    Rename it to 'update.zip' and put it on your memory card. Boot the phone in ClockWorkMod Recovery mode (turn on phone with Volume Down held), then select 'Wipe data / factory reset' and then 'apply update.zip' again.

    It should then work ok.... :)
  14. Eris Ed

    Eris Ed Well-Known Member

    You could try changing the Windows setting so it can see hidden files:

    Windows Explorer > Tools > Folder Options > View > Show hidden files
  15. shooey

    shooey Member


    No I did read the instructions (spent a while reading them over and over again to be obsolutely sure). I checked beforehand, its an OLED screen.

    The phone was working fine for around an hour+. Then suddenly i went to unlock the phone and there was no response.

    I cant get ClockWorkMod Recovery mode on - only recovery mode (i.e. I can only get to the point where the Android logo stays on constantly).

    I cant mount the SD card via USB either.

    :confused:
  16. BurnCK

    BurnCK Well-Known Member

    Apologies then if you did read that bit properly :rolleyes: It's just that the symptoms you described are the exact same ones that you get when trying to flash a TFT version with this ROM.

    Don't know why you can't get back into ClockWorkMod Recovery again. Even if your phone doesn't boot you should be able to get back into it. Try removing the battery for a few seconds, replace it, then hold Volume Down whilst turning the phone back on (hold Volume Down for a few seconds after turning back on).

    If it still doesn't go into ClockWorkMod Recovery then you could try re-installing it again using the initial fastboot method.
  17. shooey

    shooey Member

    I can only think that this is one of those phones that is an exception. I read somewhere that people have been reporting their phones as TFT desite all the checks suggesting its an OLED.

    As for re-installing ClockWorkMod recovery then is there a particular version you can suggest or shall i just stick with the latest that i can find?
  18. shooey

    shooey Member


    Tried re-installing ClockWorkMod recovery but it just does exactly the same thing. The screen just continuously flicks back and fourth between the green android logo and a small piece of upside-down text that says android. Its almost as if its trying to load ClockWorkMod recovery but cant?
  19. BurnCK

    BurnCK Well-Known Member

    Strange one that, people have had issues with ROMs before, but they've always been able to get back into ClockWork Mod. I suppose you could try a later version of ClockWorkMod Recovery (version 2.5.1.3). I only used 2.5.0.9 because at the time I posted it there were some issues with 2.5.1.3 which have probably been sorted now.

    2.5.1.3 will be available for download over at Modaco forums.
    shooey likes this.
  20. shooey

    shooey Member


    Oh dear! I am using 2.5.1.8... why do I get the feeling that this phone has been bricked? :eek:
  21. BurnCK

    BurnCK Well-Known Member

    Wouldn't worry just yet. It's quite possible that the issue is 2.5.1.8 then.

    I, and others, haven't had any issues with 2.5.0.9 so I'd try installing that one with fastboot instead. If it still doesn't work, then I'd recommend posting over at Modaco forums and see if anyone there can help you as I wouldn't know what else to suggest.
    shooey likes this.
  22. shooey

    shooey Member


    Yeah i tried that already. :(

    Thanks anyway BurnCK! :)
  23. shooey

    shooey Member

    I just simply CANNOT get my phone into clockworkmod recovery mode! [​IMG]

    So far i have tried every trick in the book (even StevenHarperUk's hungarian update)!

    I think its finally time to throw in the towel and take it to my local phone shop to see if they can just get the phone working again... gutted! All that hard work, stress and headache for my phone to end up back normal again. [​IMG]
  24. BurnCK

    BurnCK Well-Known Member

    Did you try Modaco forums ? Android @ MoDaCo
  25. shooey

    shooey Member

Share This Page