Guide to Rooting Without a Computer


  1. mkbkr1

    mkbkr1 Well-Known Member

    Here is a guide to rooting and installing a custom recovery on your Optimus V without using a computer. All steps are performed using the phone only.

    READ THIS ENTIRE GUIDE FIRST AND MAKE SURE YOU UNDERSTAND ALL THE STEPS BEFORE STARTING.
    Before we get started, be aware that rooting does void the manufacturer’s warranty. Although this guide is as complete as I can make it, you do this at your own risk and I accept no responsibility for damage to your phone, sd card, or mental stability.

    First, you will need to install Terminal Emulator from the market. The files you will need to download are linked at the bottom of the post. After you download them, move them to the root of your sd card (just on the sd card, not in any folders). You will find: Gingerbreak.apk (the root app), flash_image (which you will need to install the recovery), IHOrecovery.img, and xioniarecovery.img (xionia cwma recovery version 1.2518.6). Before starting, go to setting-applications make sure unknown sources is checked, this will allow you install Gingerbreak from you sd card, then click on development and turn on usb debugging.

    1. Click on Gingerbreak and select install.

    2. - Open the Gingerbreak, press the root button
    - Wait a few minutes. If there are no problems, the device will reboot (note that the reboot itself can take like 10 minutes due to cache wipe)
    - Make sure the Superuser app is installed(look in the app drawer to make sure it is there)
    - Install BusyBox from Market (I personally prefer the stericsson installer)
    - Optional: Uninstall GingerBreak, you don't need it on your phone anymore
    Note: Sometimes it takes a few tries.

    Note: Before starting the next step you can rename the recovery you plan to use to recovery.img so you don't have to remember the whole name when typing it into the code.
    Hint: You can rename the Xionia recovery to Xrecovery.img, and the recovery for the CM-7 ROM's to IHOrecovery.img. When you get to that part of the code all you have to type in is either Xrecovery.img for the Froyo ROM's or IHOrecovery.img for the CM-7 ROM's.
    3. Open Terminal Emulator and type the following commands (spaces are red)

    su(return)
    mount_-o_remount,rw_-t_yaffs2_/system_/system(return)
    cat_/sdcard/flash_image_>_/system/bin/flash_image(return)
    chmod_755_/system/bin/flash_image(return)
    flash_image_recovery_/sdcard/recovery.img(return)
    reboot_recovery(return)

    (return) means to just hit the return key, do not type this in.
    Note: Make sure you enter the name of the recovery exactly as it appears on you sd card in place of "recovery.img"
    If you get any error's in the code do not enter the last line, instead start over. If you try to proceed after getting an error you will be stuck in the fastboot screen when you type in the last line.

    4. This should bring you to your new recovery menu with the following options:
    reboot system now
    apply sdcard:update.zip
    wipe data/factory reset
    wipe cache partition
    install zip from sdcard
    backup and restore
    mounts and storage
    advanced

    5. BEFORE YOU DO ANYTHING ELSE, MAKE A BACKUP. IT WILL SAVE HOURS IF NOT DAYS OF HEADACHES IF YOU MAKE A MISTAKE. Using the volume up and down to navigate and the camera button to select, click on backup and restore. Select backup and let it do its thing. Once the back up is complete it will take you back to the main recovery screen, then select reboot system to take you back to your android system.

    6. Congratulations, your phone is now rooted and ready for you to find and flash any of the custom roms designed for the Optimus V. This is crucial, only use roms specifically designed for the Optimus V. Roms for other phones either will not work right(at the least) or brick your phone(at the worst). DO NOT USE THE FACTORY RESET FOUND IN THE PRIVACY MENU TO REST YOUR PHONE. THIS WILL RESULT IN A BRICK.

    These methods have been in many different forums, but scattered around and not in a concise form. I take no credit the steps involved; all I did was bring them all together in one place. If anyone spots any mistakes, typos,or has more info to add please feel free. I will edit this post any helpful tips.

    Thanks to Chainfire for the Gingerbreak.apk
    Thanks to jerryscript for posting terminal emulator commands


    I recommend using the xionia recovery to flash the 2.2 roms and the IHO recovery for the various IHO ROMS(Backside, MiRaGe, Bobzhome). These recoveries have been updated to work on both the older and new screens to avoid the black screen of death.

    Edit: Sorry guys, I have upgraded to a Sumsung Exhibit II 4g with TMobile. I will still try to check in here occasionally, and I will keep the downloads available on my Box account for those who wish to use this guide. I'm sure there are plenty of good people here who will be able assist with questions or problems you may have.

    xioniarecovery.img - File Shared from Box - Free Online File Storage
    IHOrecovery.img - File Shared from Box - Free Online File Storage
    GingerBreak-v1.20.apk - File Shared from Box - Free Online File Storage
    flash_image - File Shared from Box - Free Online File Storage

    Advertisement
    :
    in5idiou5, g33kgrrl, Trip9 and 17 others like this.
  2. darkside

    darkside Well-Known Member

    where are the zip files?
  3. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Well alllriight mkbkr1 Good job! Thats what I'm talking about. I was just discusing this very idea with another member. You did a fine job of presenting all the facts and giving clear direction toward accomplishing the goal as stated. You also did a fine job of letting them know what they were getting into and the possible consequences for taking said action. You did an outstanding,and my hat is off to you. well done.EDIT:eek:ops! maybe might want to edit and give download links.
  4. mkbkr1

    mkbkr1 Well-Known Member

    Sorry guys, for some reason the upload didn't go through the first time. lets hope it works this time.
  5. DoomyGIR

    DoomyGIR Active Member

    Right on!
  6. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    One thing I thought I would mention: when I first used this method not to long ago I had problems changing the permission of the flash_image file to rwxr-xr-x(chmod 755) with the terminal emulator(it was either me or the emulator I downloaded) so I used SuperManager which has that option in it's tool bar in the File Explorer section
  7. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Hey,mkbkr1 I just thought I should let you know that the Root files zip that's posted is corrupt. I downloaded to my PC and tried to open it(extract all files)twice and got the same thing. Folder looked empty as well. EDIT: After following mkbkr1's instructions in the 1st post(using my phone and not my computer to download the files) I had found the Root Files.zip to be just fine and I was able to install all three items to the root of the SD card.
  8. mkbkr1

    mkbkr1 Well-Known Member

    You must have gotten a bad download. I just downloaded the zip and opened with winzip. All three files are there. When try to open it, just click on the zip and select open with winzip. I also downloaded to my phone and opened it with androzip. Again, no problem, all three files are there.
    AndyOpie150 likes this.
  9. yogi-4

    yogi-4 Well-Known Member

    I just downloaded it as well... all 3 files were there. Your isp might not like you?! :)
    AndyOpie150 likes this.
  10. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I'm using firefox as my browser on a PC with windows vista 32.Question? what type of file is it. Maybe that's my problem(I hate being a "Nuub" sometimes).It happened again,and if it can happen to me, then it can happen to anyone not real computer savvy.EDIT: I'll try and download it to my phone which is the whole point of this thread. Sorry mkbkr1
  11. mkbkr1

    mkbkr1 Well-Known Member

    This guide is designed for use on your phone. If you'd like to test it install androzip from the market, and follow the instructions. I tested all the download steps and adrozip steps to put the files in right place on the sd card. Just tested it again on my work pc. Either open with winzip or extract all worked fine. Must be a problem with your download or browser. What program are you using to open it?
  12. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    O.K. I downloaded Androzip from the market. Downloaded the Root files zip. Went to downloads folder,not there.Went to download folder,it was there. Tapped Root Files.zip,chose Extract to...,Hit the back button to get to root of SD card,tapped extract here,got unpack zip operation failed, 3 times. Went back to download folder and tapped on Root Files.zip, chose Extract file here,it worked. I noticed the xionia_cwma_12518.4_virgin.zip was all ready renamed vrecovery.img,Cool! Moved it to root of SD card.Moved flash_image,and GingerBreak-v1,20.apk to root of SD card. O.K. all files are now where they should be. Sorry for all the Overthinking mkbkr1 (I'm not just a member,I'm a worry wart.).EDIT: Again my apologies for stirring up undue stress. Some times in my zeal and desire to help I can be a bit annoying. You have done a fine job with presenting and preparing this thread,and it should allow all the members a fool proof way to root and install a custom recovery
  13. mkbkr1

    mkbkr1 Well-Known Member

    No problem. Glad you got it figured out.
  14. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Per are previous discussion on function keys when in recovery. I'm running xionia_cwma_12518.4_virgin.zip and my selection key is the menu key. I had to mention this in case someone couldn't get their home key to work to make a selection and it caused their screen to go blank.All they have to do is hit the home key again to get the menu back and use the menu key instead. It seems odd that this should happen with the same version of xionia, unless the difference is in the phones.
  15. sadielynn

    sadielynn Well-Known Member

    Wow, kudos to mkbkr1 for putting this all together! *applause*

    Also, I agree w/ Andy-my menu button is the select button when using xionia recovery

    Also, I just want to add: make sure you have a large-ish amount of space on your sdcard before you make your backup (mine was over 500mb!). If you don't have space, make room, or get a bigger sdcard before you even try this stuff-do NOT proceed w/o a backup!
    (insert JerryScript's "always backup before you flash" animation here :))
  16. mkbkr1

    mkbkr1 Well-Known Member

    The recovery I uploaded (xionia 1.2518.4) is the one I am using on my phone. It is same one I used when rooting my phone. The home button will select on this recovery, which is why I wrote it the way I did.
  17. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Something else I just remembered. The GingerBreak .apk is kinda picky about the SD card that's used. With my install I had to take out the 8G card and reformat to default settings the stock SD card. Then it worked.
    KammieD likes this.
  18. Joestradamus

    Joestradamus Member

    I tried several other ways to root, this one did it for me. Thanks! All I really wanted to do was free up internal space, but will look into other root options.
  19. mkbkr1

    mkbkr1 Well-Known Member

    Rooting by itself will not free any space. Also all the bloat is in the system apps, so deleting them will not give you any more usable memory. If you want more app space you will have to look into installing a rom. Just make sure they are for the Optimus V and follow the instructions for installing.
  20. sadielynn

    sadielynn Well-Known Member

    Harmonia is a really good rom for more space! I have over 120 apps (give or take a few) and around 90mgs internal space, just by moving apps to sd (the normal Froyo method, and using titanium backup to move a few others that couldn't be moved naturally)
  21. Anamacha

    Anamacha Well-Known Member

    okay -- I have an LG Optimus V. I installed GingerBreak, followed all the instructions up to that point. GB tried to root my phone and it said that either the rooting failed or the reboot failed. I rebooted my phone manually and no superuse (went to Terminal to see), and no Superuser app.

    I kept my phone active as GingerBreak tried to work.

    Not sure what's going on here -- can anyone help?

    I am trying it again to see if it will work the 2d time.

    edit: 2d time didn't work. Running GingerBreak v1.2, whatever came in the zip file that the OP put up.
    The message follows: GingerBreak -- Not sure what happened here. Either the exploit failed or the reboot failed. Please reboot manually and see if you have Superuser !


    Gratefully my phone still works at this point :)

    Any other ideas on how I can root my phone, if GingerBreak v1.2, didn't work?
  22. yogi-4

    yogi-4 Well-Known Member

    You could always try SuperOneClick. That's what I used for my first root. Couldn't hurt to try!!

    EDIT: But that only gives you temp root. Root goes away when you reboot.
  23. Anamacha

    Anamacha Well-Known Member

    is there a way to get SuperOneClick to give permanent root?

    Where can I find instructions on how to use SOC?
  24. mkbkr1

    mkbkr1 Well-Known Member

    Did you have usb debugging turned on? This is the most common mistake. Make sure it is checked, and try again. Sometimes it tasks a few tries.
  25. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    Did you remember my advice on how picky the Gingerbreak .apk can be towards SD cards. Be patient. Be careful. Be thinking. Gingerbreak will not mess up your phone. I have a paper weight because I messed up using SuperOneClick. Take your time and go thru the checklist that I gave you in the last post of your thread:Support freeing space. It will work. Try to find the stock 2g SD card, reformat in your phone then download the apk and try again. Also you have to power off and power on your phone after each failed attempt(this is called rebooting). If it does not work on the next try after reformatting,Reboot and try again(if it doesn't work after 12min,pull battery(this will be the same as rebooting)and install battery,power on,and try again. If for some reason it doesn't work on the third attempt, Reformat the SD card by inserting it in your PC. go to start/computer/right click on SD card a window will pop up. select format. another window will pop up. Select restore device defaults, then select start. when it's done put the card back in your phone and start over. remember to reboot at each failed attempt. This will not mess up your phone but it will eventually work. It worked for me after I reformated using my PC.
Loading...

Share This Page