1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[GUIDE] Unbrick Attain


  1. travisantonio

    travisantonio Active Member

    Please follow every step as wrote.

    Hello guys!, I'm new here but I'm an old developer of many older devices and OSs for mobiles :p, my name is Travis Antonio nice to meet ya all.

    With this guide you will bring your Attain back to life like I did with mine.​



    NOW THE TIME HAS COME!, Follow the steps :)

    Step 1. Files to download:

    -Heimdall Suite: CLICK HERE TO DOWNLOAD

    -GA Fix: CLICK HERE TO DOWNLOAD


    Step 2. Heimdall Suite

    Heimdall Suite is a suite made by Benjamin Dobell, so thanks to him we can have the Galaxy Attain back to life.

    -Extract the Heimdall Suite wherever you want, but to make sure extract it in the main disk (C:\).

    -After you have extracted it go into the folder of Heimdall Suite and open the Heimdall-fronted.exe (To make sure you have MS Visual C++ 2010)

    --In case it gives error MSVCP100.DLL, download MS Visual C++ 2010 here: CLICK HERE TO DOWNLOAD

    --Also make sure you have lastest Samsung USB Drivers, if you don't have it here is a link: CLICK HERE TO DOWNLOAD


    Step 3. Preparing/Configuring Drivers

    -In the folder of Heimdall Suite go to a folder named Drivers.

    -Attach USB to your Attain and put it into download mode. (without battery) *Volume Down + Power* then *Volume Up*

    -After the computer recognizes it open zadig.exe

    -Click on Options and click on List All Devices.

    -Go to the List and mow you should see "Samsung USB Composite Device" on the list.

    -Click on Install Drivers

    -Done.


    Step 4. Attain Back to Life / Heimdall Suite

    -Go back to Heimdall Folder and open heimdall-fronted

    -Click on Browse and look for the AttainFix.tar.gz

    -Click on Load/Customise.

    -Click on Flash.

    -Voila! (Done).


    If you have any question or anything to ask, just feel free I'm here to help,

    Special thanks to:

    *MobilePlay
    *DadCup


    Also thanks to:

    *Shabbypenguin
    For their great support and all the files =D

    If you like my work buy me a beer :beer:

    Advertisement
    :
  2. mobileplay

    mobileplay Well-Known Member

    Thank you Travis. Even though I don't have an attain anymore I am glad that people won't be stuck sith a phone that they can't use.

    Thanks to Shabby for helping me with pulling partitions, and showing me how to pull the factoryrfs so I could make some flashable themes, and dadcup as well for helping figure out some of the partitions. IM glad we could all work together and help Travis to get this done.
    travisantonio and dadcup like this.
  3. travisantonio

    travisantonio Active Member

    Files are done uploading, I like my crappy internet :D thank you too MobilePlay (B...)
  4. dsspro

    dsspro Member

    Thanks to everyone who worked on this project...This once bricked phone now lives again :)

    I only have 1 problem..I cant seem to enter Diag mode and I need that to be able to read phone in CDMA WS..Any way to fix that? the ##3424# doesnt work.

    Ok I got it figured out....its *#7284# then choose CDMA MODEM for UART and USB...then it reads fine :)
  5. travisantonio

    travisantonio Active Member

    Cool. Glad to see this worked out for you :)
  6. Tokenpoke

    Tokenpoke Well-Known Member

    Does this take you to full stock? I kinda deleted a few system files and I can't reprogram the number anymore....
  7. travisantonio

    travisantonio Active Member

    No, but I will be uploading the stock one when I recover my broken HDD, I think I will do it this night, wait for it.
  8. Tokenpoke

    Tokenpoke Well-Known Member

    sweet... oh, gtalk is hating me... try mail if anyone needs me.

    i just need the metro and Samsung apk hidden menus and a copy of the metrpcs folders in /system
  9. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    the prerooted has all the apps etc just also is rooted. the original factoryfs.rfs i uploaded in my partition dump thread was unrooted and a virgin phone
    Tokenpoke likes this.
  10. Tokenpoke

    Tokenpoke Well-Known Member

    yeah. i hit up the preroot and got her up and running. couldn't stand the connect battery any more.
  11. hojotogo

    hojotogo New Member

    Thank you for the work, I am caught in boot loop though and can't get computer to recognize the phone. Any ideas?
  12. travisantonio

    travisantonio Active Member

    What are the problems?, tell them all and we will be able to help you.
  13. cuteazlez

    cuteazlez New Member

    Thank you so much for this my phone has been bricked for a while thinks to yo its up and running i have one question how do you fix battary drain problem
  14. travisantonio

    travisantonio Active Member

    Battery drain problems, I haven't see any with the Attain since I had it, explain yourself.
  15. Loveofandroid

    Loveofandroid Member

    I'm stuck in a boot loap after trying to unbrick .. PLEASE HELP A.S.A.P
  16. travisantonio

    travisantonio Active Member

    You're not supposed to have a bootloop, did you follow all the steps right?
  17. Loveofandroid

    Loveofandroid Member

    I fixed my Attain !!! Omg I'm so happy I brought my phone back to life !!

    I'm rooted using GASMOD
    I followed the steps, all I had to do was do a factory reset & it booted right up just fine

    Screenshots right here , everything works !!
    I'm very grateful & I really appreciate your work. Thanx man
    You are a f*ckin genius !!

    Attached Files:

    drexn likes this.
  18. travisantonio

    travisantonio Active Member

    Nice ;)
  19. jdenisen

    jdenisen New Member

    Mine is fixed now. But how do I get the original ROM back? I tried the GASMOD ROM before my Attain bricked. And I am new to androids and did not back up the original ROM.
  20. Tokenpoke

    Tokenpoke Well-Known Member


    Use odin to flash the rooted stock
  21. jdenisen

    jdenisen New Member

    How do I do that? Which file is the rooted stock?

    I have Odin, and the files for pre-root. But I cannot seem to find the rooted stock.

    Any help would be nice. Thankz

    Also, the ROM that is on there now made the Google Play Store vanish, and I cannot use youtube.
    drexn likes this.
  22. Frozin

    Frozin Well-Known Member

    The pre root.tar is the stock rom with root.

    If ur using gasmod go to titanium backup and make google play and youtube a system app. If u don't have google play dl it and do the above once its installed
    drexn and Tokenpoke like this.
  23. mrnut25

    mrnut25 Member

    I didn't read up and see that you can't root the new fg02 update and im bricked..... please help i just bought this phone friday(11/9/12) and i dont wanna feel like i wasted my money... how do i come back from this?
  24. oBey110

    oBey110 Member

    How exactly did you get bricked? And have you tried using the steps on this guide?
  25. mrnut25

    mrnut25 Member

    I tried every unbrick thread... i first tried to do the pre rooted tar on odin and then it started to just reboot into the hold volume up to continue and then i tried to do redo the fg02 update from the samsung support page... that didn't work... so i tried this and gets to the factoryfs around 27% and this pops up every time
    ERROR: Failed to begin file transfer sequence!
    FACTORYFS upload failed!
    Ending session...

    please help me
Loading...

Share This Page