Had the N1 for a week now some issues


Last Updated:

  1. Pabuzalaf

    Pabuzalaf Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    12
    Likes Received:
    21
    Ive had my Nexus since early last week now and I have come to love it. I use to have a blackberry bold 9000 on AT&T so its a very different experience. Since I use an employee plan, I had to use my AT&T service until I could get switched to TMobile. I found At&t edge to be unusable for web browsing regular sites on the N1, mobile versions were ok. I've used Tmobile for about a day and half now and when i can get 3G its fantastic. However it seems to prefer EDGE. The Tmobile edge seems to be way faster then at&t, does this make any sense to anyone ? I was thinking that maybe I am using 3G and its just not being displayed. I live in southern california specifically the Diamond Bar, Rowland Heights, Orange County area. While expected to not get 3G at my home in Diamond Bar i dont understand why i dont get 3G all the time at work in Rowland Heights. I have full bars and I know Tmobile has great 3g coverage there. In addition it seems that i often times have to tap the screen 2 or 3 times to get the phone to respond.
    These are my only issues in what has otherwise been a really great switch for me. I love being able to customize my home screens and add widgets. It really gives the phone its own personality. Plus the screen is absolutely the best screen ive ever seen on any cell phone period Droid,Iphone various blackberrys all taken into account. The camera is absolutely fantastic also. Ofcourse the thing is blazing fast. So im very happy. I would just love to get those other issues squared away. Is there any news regarding the 3G and touch screen problems. Anyone with the same issues that has found a fix. Much appreciated !
     

    Advertisement

Share This Page

Loading...