Haptic Feedback IssuesSupport


  1. rgs

    rgs Well-Known Member

    Although I have vibrate turned on in settings and I've turned it off and on several times I don't get any vibration on touch. Anyone have an idea?

    Advertisement
  2. marctronixx

    marctronixx Moderator Moderator

    reset the phone. press and hold the volume DOWN button whilst pressing the power button. follow the instructions on the screen. not a hard reset, just clears cache and untangles a few cords (EM's phrase I stole ;) )
    Abird! likes this.
  3. ChrisH76

    ChrisH76 Member

    Hello everyone

    Have just upgraded to the One frrom the One X and like the vast majority, absolutley love the phone.

    On the One X, I reallyliked the haptic feedback you got when using the bottom buttons. Now, I don't know if it's just me but I am getting no Haptic feedback at all when pressing the Home or Back buttons.

    Vibrate on touch is checked in the options settings.

    Should I be getting feedback? Should i be able to feel it? Is my phone defected or am I just being stupid.

    Thanks for looking and here's hoping someone out there can shed some light......

    Cheers
    Chris
  4. Dr Jones

    Dr Jones Member

    Did you turn Power Save Mode on? One of the auto-settings within Power Save is to kill the haptic feedback.
    TitusAndronicus and ChrisH76 like this.
  5. Fonzig

    Fonzig Well-Known Member

    Go to Settings>Sound, at the end of the list is "Vibrate On Touch."

    Make sure this is ticked ;)
  6. ChrisH76

    ChrisH76 Member

    Well done the Dr. It was power save that was to blame.
    I now have a slight haptic feedback, better than it was but is significantly less than I had on the One X.

    Now I know the issue, I think I'll go back to Power Save on. Don't know what power is being saved, but saving power, it's gotta be good, aint it?
  7. Dr Jones

    Dr Jones Member

    ChrisH76 - You can keep haptic feedback on while in Power Save mode! Just turn Power Save mode off by pulling the top slider down and clicking the check box. Now that it's off, click on the Power Save mode icon to the far left (this is the battery w/ leaf symbol when you pull the top slider down). This will give you the Power Saver options. You can pick which items the Power Saver will throttle. I think it's the 2nd from the bottom is vibration/haptic. Uncheck that, then turn Power Save back on. Bingo... now you have haptic feedback, and still in power save.
    marctronixx likes this.
  8. ChrisH76

    ChrisH76 Member

    Dr J - Yeah I discovered that after making the original change you suggested. I now have haptic feedback whilst power save is on, cheers.
    marctronixx likes this.
  9. stubetts

    stubetts New Member

    Hi,

    I recently got the HTC One (silver) and love it but at the weekend, my battery was running low after being out all day and, as expected, the phone went into power save mode. When I got to a charger and charged it up and checked all the settings, but since then have had no vibration on my phone and even getting occasional small clicking sounds when pressing keys. I have checked everything, rebooted and still no vibration. Any ideas?

    Cheers
  10. marctronixx

    marctronixx Moderator Moderator

    did you turn off power save and reactivate the vibration motor?

    does the phone use the vibration motor when its in vibrate mode? say, when a call comes in and its set to vibrate, does it vibrate?

    kindly post your carrier also.

    press and hold the power button until the unit shuts off and restarts on its own. then release the button.

    make sure fastboot is unticked and make sure power save is not activated once rebooted.

    change your settings from vibrate to silent to ringtone.. just toggle them.

    re test the device...
  11. stubetts

    stubetts New Member

    Thanks for the reply.

    All vibration options are switched on, including key presses, and for calls, but I get no vibrations for anything.

    My carrier is O2.

    Thanks again for the reply, but it made no difference.

    Cheers
  12. marctronixx

    marctronixx Moderator Moderator

    under sound settings, do you have the vibrate options checked?
    did you uncheck fastboot?

    are you rooted?

    do you use any screen launcher or task manager app?

    the vibration motor is at the bottom of the phone. give it a light tap (no im serious).

    the rocker volume buttons--tap UP and DOWN one tick at a time--should go through ringtone, silent, vibration, etc.

    if phone is not vibrating and you don't have any other task manager apps, or power save apps running and your device is not rooted, you may need to do a factory reset.

    this is really an easy solution and if after going through these steps the vibration function does not work, do a factory reset or take the unit back for a swap. could be hardware related.
  13. stubetts

    stubetts New Member

    I have been though all the settings, and still nothing. (Its only a month old and unmodified). I will try a factory reset tonight, then failing that, will take it back to the shop.

    Cheers
    marctronixx likes this.
  14. Bubu91

    Bubu91 New Member

    I just bought a HTC One and noticed that, with the haptic feed on, when i type, after a few normal feedback vibrations, there is "strange" one - as if the screen isnt connected properly to the main body. And it does that after each 4-8 normal vubrations.

    Should i demand a new unit or is it something normal?
  15. marctronixx

    marctronixx Moderator Moderator

    hard to tell over the internet if its "something normal", however, if you are still under your grace period with your cellular provider, by all means return it for a new one.

    I use a launch day sprint stock non rooted htc one and the feedback is solid and routine each time. so in my case i have no issues with the vibration motor.
  16. TitusAndronicus

    TitusAndronicus New Member

    Thanks man, you just saved my life.... Well maybe not my life, but thanks!

Share This Page