HARDWARE ID MISSING - windows cannot identify the deviceSupport


Last Updated:

  1. chewedpup

    chewedpup Well-Known Member

    non rooted SAMSUNG GALAXY SII for sprint..... suddenly developed a problem

    HELP! Suddenly, out of nowhere, today when I plugged my Sii into my laptop with the USB cable, instead of it showing up as an external drive (which I wanted, so I can move some pics over) - it shows up with the attached "HARDWARE ID MISSING - windows cannot identify the device plugged into the Samsung mobile USB composite device. NEVER happened before. I have looked on the internet and see some people suggest uninstalling KIES. On my samsung Sii, there is no option to uninstall it, only to uninstall the updates (which I have done).

    I have tried selecting the USB debugging option in developer options - no help. I looked where people suggested under Settings - More - (then looking for USB options but my Sii doesn't have that option) - so that was pointless. I have rebooted phone AND laptop.... no good - I still keep getting that error - and as far as I know, nothing has changed on my phone.

    :-(
    I just took TONS of photos in London and can't even put them onto my laptop now :-(((((

    Hardware version D710.10
    android version 4.0.4
    model number SPH-D710

    Attached Files:


    Advertisement
  2. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    This I have not heard before, have you tried uninstalling and reinstalling your drivers to see if this continues?

    DS
  3. chewedpup

    chewedpup Well-Known Member

    I'm not sure where the problem lies - if it's with the phone now or the laptop? And no I haven't uninstalled or reinstalled any drivers - I don't know how to do that on either laptop or phone - if you tell me how I'd be happy to try. I looked up on the internet and it seems a lot of people suddenly have the same problems (well, I say suddenly, but since September last year) - but none of their solutions have worked for me....
    thank you! :)
  4. KitsapAndroid

    KitsapAndroid Well-Known Member

    Try uninstalling Kies from your laptop, downloading the newest version directly from Samsung, and then reinstalling it. People have had luck with doing that it seems.
  5. chewedpup

    chewedpup Well-Known Member

    KIES actually isn't installed on my laptop at all. Whenever I've used it, I just type in the url given to me on my phone, type that in and go to that website and get the photos etc. from there. So KIES isn't installed anywhere except on my phone. It makes no difference whether I use the updated KIES or uninstall the updates on my phone, if I plug my phone in using my usb cable, it will not show up as an additional drive, and I get the HARDWARE ID MISSING error message.
  6. chewedpup

    chewedpup Well-Known Member

    I did as was recommended and installed KIES onto my laptop from the internet (it had never been installed before, I only ever used Kies Air) - and after a lengthy installation, installing Kies onto my laptop - suddenly everything works. I must admit to not knowing that there even was a KIES program to install on my laptop - I'd only ever used KIES Air, whereby you just run the app on the phone, it generates a URL which I type in on my browser on laptop and it would take me to my phone. Actually downloading and installing KIES to my laptop somehow fixed the drivers because then I just plugged in my Galaxy and it installed some other drivers, and worked PERFECTLY. Now it shows up as another drive and I can move stuff back and forth - so THANK YOU THANK YOU for this information and for resolving my problem.
    On a side note, while trying to resolve all this, someone recommended using WIFI FILE TRANSFER, an app for my phone - so I downloaded it, and it works very similarly to Kies Air - it generates a URL, you type in that URL on your laptop browser and it gives you immediate access to your phone. I will use that when I have good wifi - but if I'm somewhere where I don't have access to the internet, at least now I CAN hardwife my phone to my laptop with the USB cable and transfer files that way. THANK YOU!!!!!
  7. john_ralph

    john_ralph Well-Known Member

    Another possibility that I have run into before is a cheap usb cable. Some of the low cost ones cause this issue.
  8. chewedpup

    chewedpup Well-Known Member

    Definitely not the usb cable - this is the original one that came with the phone, genuine Samsung Galaxy USB cable, and now that I have installed KIES, everything works as normal. It is a good thought though, as in the past, with other phones, cheap usb cables have caused problems - so that's definitely a good thing to consider. Thank you

Share This Page