1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Has Google's new security slowed down Gmail to Gmail app sync?


Last Updated:

  1. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    I have noticed that Gmail is taking a little bit longer to sync, if it syncs at all. I have had to use the manual refresh in my Gmail app to populate mail most of the day today.

    I have run some tests, and it appears that Gmail will sync in random amounts of time. Sometimes 5-10 minutes, sometimes more than 15 minutes. Up until yesterday, it was almost instantaneous.

    When I send mail, or change labels, or delete mail on my Droid, the changes are noticed on my Gmail account within a minute or so...just like normal. It appears to only be a problem with fetching new mails.

    I have cleared the Gmail app cache, I have turned off sync - rebooted my phone - turned sync on again....everything I can think of.

    Could this be a problem because Google has implemented HTTPS on all of their email access?

    Anybody else experiencing this today?
     

    Advertisement
  2. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    Sorry - Did some research on Google's website and came up with this:

    Errors when attempting to read or send mail : Troubleshooting - Mobile Help

    So this confirms my suspicions above. My performance for syncing was definitely affected by the changes Google made to Gmail yesterday. I have it set up now and it works great again!

    Hope this helps anyone else who has this issue!
     
  3. shakuyi

    shakuyi Well-Known Member

    Joined:
    Jan 7, 2010
    Messages:
    45
    Likes Received:
    1
    awesome good find i was wondering about this myself
     
  4. regression

    regression Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    I am looking at the instructions for version 1.5, and I don't have the "Always use secure network connections (slower performance)" option... I have a Sprint HTC Hero. I have been having problems on and off today with Gmail syncing.

    Edit: Opps, just saw this on Google's page. I have always had use https enabled on my account, so not sure why it is now becoming an issue.

    If you don't have this setting in the app, you can:

    Disable the 'Always use https' setting in Gmail
    Access Gmail via your mobile browser
     
  5. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    Version 2.0.1 doesn't have the "Always use secure network connections (slower performance)" option either. I had to go with the alternative of turning HTTPS off.

    HTTPS is something that Google set as the default option yesterday....late. I don't remember seeing that option before in Gmail options. In fact, today, when I found this and checked it out...nothing was selected for me. So, I selected "Don't always use HTTPS" as my option. But...because nothing was selected, Google was sending me to their secure site.

    I never read my emails on public computers...only on my home computer...or my phone. I'm not too concerned about turning it off.

    On a side note, I don't think all is perfect yet. My syncing is still taking a little extra time, and I have noticed that when I look at my Account Sync settings, and check the time date stamps of my syncing, it's not very consistant. :confused:
     
  6. regression

    regression Well-Known Member

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    I believe always use HTTPS was a lab feature before? Perhaps that is why you didn't see it??

    Anyway, I agree, all is not perfect yet. I have been using "always use https" (via the web browser) since I have had my Android phone and up until today, no problems.
     
  7. thepinkc

    thepinkc Well-Known Member

    Joined:
    Dec 28, 2009
    Messages:
    174
    Likes Received:
    13
    I haven't had any problems getting emails immediately via my Moment.
     
  8. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    Still having problems today. I am bummed that this isn't working properly any more, but I'll live. I have looked around at some other forums and there are plenty of other people experiencing the same thing....all starting around the same time frame. Too many people for it to be an issue with individual phones in my opinion. There HAS to be another reason behind it.

    Today I cleared out my Data and Cache for Gmail and Gmail Storage apps. I followed the instructions in this troubleshooting posting in Google support:
    http://www.google.com/support/mobile/bin/answer.py?answer=113869

    I have ensured that when I log into Gmail on a computer, it is HTTP...not HTTPS....so I have that set up properly.

    Still....long delays receiving, and sometimes not receiving at all, unless I manually refresh. :(

    NEW QUESTIONS: Is there a way to sign out of Gmail and sign back in? I see that if I go into Menu/Settings, then select Accounts & Sync Settings I can go into my gmail account. When I get in there, there is an option to Remove Account. If I do this, can I add it back in? Will this mess up my whole phone since my phone was set up to be linked to this Gmail account?

    I'm using a Droid...so Android version 2.0.1.

    Thanks for any insight!
     
  9. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    OK...so I am probably posting too many times...but I am running tests and hopefully providing some help to people.

    So...I redid the troubleshooting item from Google Support, which I posted above. I had neglected to reboot the phone the first time. This time I rebooted the phone right after clearing data and cache and low and behold....Gmail is syncing again. I am getting notified within 1 or 2 minutes of the time stamp of the email. Maybe that's the permanent fix....I am hopeful. :)

    Again...sorry for posting so much on this thread...but I hope some benefit for all of us comes out of it.
     
  10. shakuyi

    shakuyi Well-Known Member

    Joined:
    Jan 7, 2010
    Messages:
    45
    Likes Received:
    1
    general rule of thumb with a smartphone, reboot first if it doesnt work then begin troubleshooting ;)
     
  11. Keener

    Keener Member

    Joined:
    Jan 9, 2010
    Messages:
    15
    Likes Received:
    0
    Vandalduck, you're NOT posting too often. Great info, keep it coming if you discover anything else.
    I'm new to the android phone thing, and just bought an LG Eve last week. About 2 days ago, my google accounts all crashed and I had to start new accounts. It hasn't been the same since, but what you're saying makes sense. I'm off to see if I can fix it. Thanks again.
     
  12. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    I had rebooted....per my first post, but that didn't work. The clearing of my cache and data along with another reboot seems to have solved the issues. All systems are still working as of this evening. :)
     
  13. ddarvish

    ddarvish Well-Known Member

    Joined:
    Nov 9, 2009
    Messages:
    54
    Likes Received:
    1
    i have NO idea what you are talking about and doing all this secure http stuff and the settings on the phone. i dont see any of that shit on my phone.... anyone help? btw using moto droid
     
  14. VandalDuck

    VandalDuck Well-Known Member This Topic's Starter

    Joined:
    Dec 8, 2009
    Messages:
    94
    Likes Received:
    9
    Google made adjustments to all Gmail accounts this week due to a coordinated attack on their system from within China. They turned on HTTPS by default....if you go into your Gmail on a computer, you will more than likely be taken to https://mail.google.com..... This has had an effect on mobile phone access to Gmail...to a point where Google posted a support article on it...as referenced above in one of my posts.

    First of all, if you want to turn off Secure Gmail (HTTPS) then go into your Gmail settings and set yourself up to Not always use HTTPS.

    If that does not take care of any issues you are having with your Gmail sync, then go to your home screen, go to Settings/Applications/Manage Applications. Set your filter to all. Go to the Gmail Storage Application and clear your data, then go to Gmail and clear your data and cache. Reboot your phone and you will be set.

    This should reset everything to process so that you are not using Secure HTTPS with your Gmail sync on your phone. Our phones (Moto Droids) do not have an option for Secure Access to Gmail.

    Of course...this assumes you are having trouble with your syncing. :rolleyes:
     

Share This Page

Loading...