Having Issues rooting HTC Desire


Last Updated:

  1. hitandamiss

    hitandamiss Member

    Hi Guys,

    Joined the forum to try and get some help with rooting my HTC Desire. I have tried using the Unrevoked application through the unlockr.com although it failed multiple times saying that my firmware may be too up-to-date. :confused:

    True enough I have accepted every OTA update available.

    My current phone details are as follows:

    Android Version - 2.2
    Baseband Version - 32.49.00.32U_5.11.05.27
    Kernel Version - 2.6.32.15-gd96f2c0
    Build Number - 2.14.207.3 CL274424 release-keys
    Software Number - 2.14.207.3
    Browser Version - Webkit 3.1
    BRAVO PVT1 SHIP S-ON
    HBOOT - 0.93.0001

    I've tried to include as much detail here as possible as i'm not entirely sure what is relevant to the root process. The main goal is to install a Custom ROM so I can use a base version of android as i'm told this frees up some space on the phone's memory.

    Any help would be much appreciated!

    Thanks

    Advertisement
  2. Hadron

    Hadron Well-Known Member Contributor

    Welcome aboard!

    There's a very comprehensive guide to rooting, written by SUroot, which is worth a read. You can find it from the "all about rooting" sticky post (linked in my sig - red link).

    On your specific problem, I doubt your software really is too new. Sometimes error messages can be misleading. Are you particularly short of space at the moment? Sometimes if you have too little space free unrevoked fails, and I think it gives that error message then.
  3. hitandamiss

    hitandamiss Member

    I don't have a lot of free space available on my phone at the minute so hopefully that's the reason it is failing.

    I've cleared out a load of apps and will re-try the process and let you know.

    Thanks!
  4. hitandamiss

    hitandamiss Member

    OK so i free'd up a lot of space on my phone but Unrevoked is still giving the error "Is your firmware too new?"

    I went to your guide on rooting and found this point:

    "2) If you forced all apps to SD card, this is impairing the installation of the superuser app. Go back through the guide and substitute "pm setInstallLocation 2" foir "pm setInstallLocation 0" and try it again"

    I'm not sure what this means to Go back through the guide and substitute "pm setInstallLocation 2" foir "pm setInstallLocation 0" and try it again

    I did use ES File Explorer to copy my applications onto the SD card so should I just return them to the phone and try again?

    Thanks
  5. Rastaman-FB

    Rastaman-FB Well-Known Member

    There's no need for you to be concerned if you don't know what that is. You would know what this was if you had changed it to 2 in the first place.

    That firmware you are running is o2 firmware and if taken by ota they seem to be difficult to root but they are rootable with some time and patience.

    First of all try downloading unrevoked 3.21 this can be done by right clicking the download link of unrevoked and copy link, paste in addressbar and change the numbers to 3.21

    If that doesn't work and gives you a misc error (notorious with o2 builds) then you will need to create a goldcard and use teppics downgrader to take it to 2.1, root it, flash froyo radio from our dropbox for root users then flash aa custom froyo/gb rom of choice
    hitandamiss likes this.
  6. SUroot

    SUroot Well-Known Member Developer

    3.21 is linked in my root guide
    hitandamiss likes this.
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    I couldn't remember Susan, I'm on phan app over GSM. Not good for back tracking and checking
  8. hitandamiss

    hitandamiss Member

    Guys thanks very much for the help, i deleted my backups of apps which were on my SD card and seemed to do the trick.

    Into the world of Custom ROMs I go, I hear cynagenmod is the way to go if i'm looking for a fast reliable Android build, would that be right?
  9. Hadron

    Hadron Well-Known Member Contributor

    It's one way - CM, GingerVillain (based on CM), Oxygen and Redux are all in that camp (AOSP based - Android Open Source Project). CM and GV have the largest number of features, Redux is the most stripped-down. All work well, and there's no "right" answer - it's a matter of personal preference.

    Have a read through the "what ROM are you using" sticky thread to get some impressions.

    Also, always read the first couple of posts of a ROM's thread at xda developers carefully: some ROMs have their own requirements or tricks, and these will be described there. For example, google apps (market, gmail etc) are a separate add-on with CyanogenMod, which often catches out people who just download the ROM and flash it.
  10. hitandamiss

    hitandamiss Member

    Ok so I went for the Cyanogenmod 7.0.3 ROM, I wiped the phone using the settings in the recovery screen and wiped the cache partition also.

    It seems that the Cyanogenmod splash screen is just looping indefinitely at the startup screen when I install from the zip on sd card... Is this supposed to take a stupidly long time?

    This is the second time I have tried it as I used a restore point from before as I didn't think it was going to stop looping...

    Please help!
  11. SUroot

    SUroot Well-Known Member Developer

    It can take upto 10 minutes to build dalvik cache. Did you flash anything else? Did you try wiping again? What about a battery pull?
  12. hitandamiss

    hitandamiss Member

    it was looping for over half an hour so figured it wasnt going to work. I flashed the google apps, that was the only other thing...

    I've been reading up on it and some people are saying you need ClockworkMod Recovery 3.x to work with Cyanogenmod 7, i've checked and I only have v2.5.0.7 installed so I'm going to install v3 over the top and try to reinstall CM again.

    Sound like a plan?
  13. SUroot

    SUroot Well-Known Member Developer

    Sounds like a plan. A very bad plan.

    Keep 2.5.0.7 as you have clearly already flashed it. It would not flash at all if that was an issue.

    2.5.0.7 is the best and last official version. Everything else is buggy as hell.

    Try flashing the rom without gapps and see if that boots. Wipe again
  14. hitandamiss

    hitandamiss Member

    Got it working! :D

    Feels like getting a brand new phone...

    Thanks for your help!

Share This Page