Having issues running RUU?


  1. Joehunni

    Joehunni Well-Known Member

    Ok, so I know i'm not nearly the only person whos had a shitload of problems trying to run an RUU so this is for some of you that had the same issues as myself. I originally saw this posted on an xda forum and it worked for me so i'm passing it along. If you are trying to RUU and keep getting stuck at the "waiting for bootloader" screen and then it ultimately fails with usb connection error 171, try this. After going through said process, instead of unplugging the phone, pulling the battery, hanging your head, and saying FML, all you have to do is leave the phone as is after first failed RUU attempt then re-run it. I know it sounds rediculously simple and impossible but trust me, just run it a second time without messing with the phone or anything (still stuck at the black HTC screen) and then run the RUU installer again, IT'S THAT EASY, enjoy! Hoped this makes someone elses day, or rather, lifetime of the phone!

    Advertisement
    MsGtx, Murrfk, udiaz75 and 4 others like this.
  2. maajick

    maajick New Member

    THANK YOU, THANK YOU, THANK YOU!!!!!! This worked! Tonight I installed the update on my husband's phone (we are with cellular south) with no problems. Then I started to work on my phone and the RUU failed. Then of course I started going through all the normal fixes, the sync was not connecting...it was saying the drivers were not installed blah blah blah. I was getting very frustrated until I found this post. I tried again and voila I am up and running!!
  3. Joehunni

    Joehunni Well-Known Member

    Lol congratulations, I remember being thrilled when this worked for me. Seemed so unlikely that it would work but when it did I was ecstatic.
  4. rjc

    rjc New Member

    Joehunni thanks so much! Such a simple but useful tip, saved me a significant amount of panic!
  5. Toyzruskid1976

    Toyzruskid1976 Well-Known Member

    Hello... capitan obvious... your table is ready.... Wow... holy jumped up whatever... This worked like a charm man! Thank you!!!!!!!!!
    I'm still semi kicking myself for not running it a second time on the HTC screen.
  6. LBPHeretic

    LBPHeretic Well-Known Member

    Yeah, when I tell people how to reflash the original Android 2.1 RUU, I usually mention that they may have to run it twice to get it to work. It seems to be a quirk with the software.

    On another note, an even easier method to get your stock Android 2.1 with Sense ROM back on your Sprint HTC Hero with no need for HTC Sync or even a computer is right here: [RUU] Official 2.31.651.7 in ZIP Format, Flashable from Fastboot - xda-developers .
  7. udiaz75

    udiaz75 Member

    Holy crap! I've spent hours trying to figure this out. I'd like to buy you a beer!! Thanks so much.
  8. LBPHeretic

    LBPHeretic Well-Known Member

    You can thank me by pressing the "Thanks" button. No pressure on that though.

    Yeah, the flashable RUU file has helped me and my friend out a few times. It is nice to have.
    MsGtx likes this.
  9. tyler3137

    tyler3137 Member

    I seriously wish I knew this before I pulled my battery and restated the phone. Now I just keep getting the battery is less than 30% error. Even though its charged. **hangs head** fml
  10. permazorch

    permazorch Well-Known Member

    I keep trying to redo/restart the process, but the phone reboots before any progress is made.
    Do you mean restart without hitting the 'exit' button?

    Sorry I'm such a dolt.
  11. eriador

    eriador Member

    Sorry to say that did not work for me, even after three tries. But at least I still have my Desire S and it's not a brick.
    I think the only solution now would be an OTA??
  12. xevious

    xevious Well-Known Member

    When I first tried loading a custom ROM onto my phone, I'd get to around 15 minutes of waiting at the white HTC screen and think the phone had gotten stuck, to then pull the battery. What I didn't realize is that sometimes it takes a LONG time for the process to complete the first time around.

    RECOMMENDATION:
    With your phone plugged into USB, run "adb logcat". This way you can see what's happening on your phone. IF you see a lot of null pointer exceptions or other errors that keep repeating (you can do a "select all" copy/paste to get a snapshot of the log), then there is probably something wrong and you should abort. But in all likelihood, you will see some errors but also a lot of normal output without anything repeating endlessly. In that case, just be patient.

    I found only ONE posting on the Internet about doing this. I wish it had been a standard step in all of the ROM loading guides, as I find it extremely useful and fear assuaging.

Share This Page