Having problems on adding anroid plugin to my eclipse

Discussion in 'Application Development' started by xerxes, May 25, 2010.

  1. xerxes

    xerxes New Member
    5

    May 25, 2010
    2
    0
    5
    hi..im using linux arch... i downloaded eclipse galileo,android sdk and android plugin ..but when i try to add android plugin to eclipse as they told in this address ADT Plugin for Eclipse | Android Developers
    it gives this fault:
    Cannot complete the install because one or more required items could not be found.
    Software being installed: Android Development Tools 0.9.7.v201005071157-36220 (com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220)
    Missing requirement: Android Development Tools 0.9.7.v201005071157-36220 (com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220) requires 'org.eclipse.gef 0.0.0' but it could not be found..

    can you help me about this ?
    thank you .
     

    Advertisement
  2. Schwin97

    Schwin97 Well-Known Member
    48

    Apr 6, 2010
    170
    12
    48
    I would guess the eclipse version you have doesn't have the prerequisites needed by android. Either you need to figure out a way to add the requirements to your eclipse, or you need to look to install a different flavor of eclipse that has all the prerequisites installed already.
     
  3. xerxes

    xerxes New Member
    5

    May 25, 2010
    2
    0
    5
    well yea you are right beacuse i find a solution for org.eclipse.gef but now there is another one..
    org.eclipse.wst.sse.core 0.0.0
    it is hard to find these from eclipse'S webside anyway thank you for replying
     
  4. m11hut

    m11hut New Member
    5

    May 29, 2010
    1
    0
    5
    What Eclipse did you install, I'm getting the same errors, I'm using the Eclipse Classic Galileo.

    Code (Text):
    1.  
    2. Cannot complete the install because one or more required items could not be found.
    3.   Software being installed: Android Development Tools 0.9.7.v201005071157-36220 (com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220)
    4.   Missing requirement: Android Development Tools 0.9.7.v201005071157-36220 (com.android.ide.eclipse.adt.feature.group 0.9.7.v201005071157-36220) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found
    5.  
    I've followed the installation instructions precisely, set the PATH for the android tools directory, as well as the jdk, I have no clue what is wrong.

    ------------------------------------
    (Edit) The Answer To My Above Post :
    ------------------------------------
    + Download the JEE Eclipse IDE
     
  5. dirtbag

    dirtbag New Member
    5

    Jul 26, 2010
    1
    0
    5
    I am running linux. I was getting this error until:

    1.) I put the directory of my SDK in the PATH. Then I restarted my shell. Then I restarted eclipse from that shell. That seemed to solve the problem.

    2.) I also opened up the permissions in the eclipse install directory. Not sure if that made a difference, but I suspect the install of the plugin requires writing in the eclipse directory.

    -hope that helps someone
     

Share This Page

Loading...