HDMI MHL connection problemSupport


  1. rich00cap

    rich00cap Member

    Hi all,

    I have a strange HDMI MHL connection issue I'd appreciate some advice with please. I have aS4 which has recently had the 4.3 Jellybean update.

    I have a MHL adapter, which I don't think is a Samsung product, at least it doesn't say Samsung on it. I can connect it to my cheap Supermarket brand HDTV ( Lowry) and to a smaller LG HDTV. However the TV I really want to use it which is my much higher quality and slightly bigger SONY will not work. When I connect it the phone says hdmi cable connected and the HDMI 1 message in the corner of the TV becomes brighter but it won't work. I've tried all three HDMI ports and the same. I even changed the HDMI cable over as I wanted to rule that out.
    Can anyone offer any suggestions as to why this is happening?

    Many thanks and a merry Christmas everyone

    Attached Files:


    Advertisement
  2. Cincy73

    Cincy73 Active Member

    I could be wrong but the S4 has a different pin adapter then the other MHLs. You need to buy either the right MHL made specifically for the S4 or the right adapter with the appropriate pins...
  3. allanlaw

    allanlaw Well-Known Member

    The S3 and S4 require an 11 pin / 5 pin micro-USB adapter to work with a standard MHL-HDMI cable. The OP's older TV's may not care, but his SONY seems more sensitive. I'm using MONOPRICE's special adapter cable for the S3/S4 (item 10020, $10.49) to connect my S4 to my SONY Bravia and it streams NETFLIX perfectly in HD. :)
  4. rich00cap

    rich00cap Member

    Thank you and everyone for replies, I'm sorry for not replying sooner. I asked for automatic emails for new messages but didnt't get any.
    I'll check that Monoprice site but I'm in the UK, might be a problem!

    Thanks again

    Richard
  5. Zurkster

    Zurkster Member

    This problem has gone largely unannounced because of the general lack of S4 owners who use HDMI adapters, like me. The fault started after the most recent Jellybean 4.3 update a couple of weeks ago. HDMI output suddenly became inoperable. The issue has come to the attention of the developers, but a resolution is no where near release. You could get your S4 re-flashed with 4.2 but I have been informed that could well brick your handset because of new security protocols deployed around Knox. Be patient they will eventually roll out a fix. just don't hold ya breath!:)
  6. Zurkster

    Zurkster Member

    It's not the adapter, my adapter was working just fine with my S4 before the 4.3 Jellybean update just after Christmas. I have two adapters, both ceased to function after the update. The phone still reports that it is connected to the HDMI adapter, but does not have video or audio output.
  7. allanlaw

    allanlaw Well-Known Member

    So you are using a proper 11 pin / 5 pin adapter, separate or integrated into your MHL/HDML cable (like my Monoprice cable), which worked before Christmas and now does not work? I just tried mine to see if it was still working, and it worked on a Panasonic Plasma. This is on Verizon, baseband ending in MK2. BTW I had to make sure the TV was first turned on and plugged into the cable, then phone plugged in, or else no picture or sound - I'm sure you tried all those combinations. HDML is well known for sometimes needing a certain sequence of power-on for devices in order to work.
  8. Zurkster

    Zurkster Member

    Yes I have both adapters and as I stated before, both my adapters were working fine before the latest 4.3 JellyBean update.
    I am on T-Mobile UK. I'm told though that service provider doesn't matter, it's a recognised problem and should be addressed on the next Jellybean update.
  9. allanlaw

    allanlaw Well-Known Member

    My conclusion is that there is something in your Jellybean version (perhaps interacting with some hardware feature unique to the S4 version you have) that is causing the problem, since yours is not the only phone with the issue and my Verizon version is fine. Good luck.
  10. frederic877

    frederic877 New Member

    i'am from limoges france, i have a xperia sp , 4.1 to 4.3 and now i have no sound with adaptater mhl belkin after the 4.3 update

Share This Page